summaryrefslogtreecommitdiffstats
path: root/main/musl
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2014-06-21 15:08:54 +0300
committerTimo Teräs <timo.teras@iki.fi>2014-06-21 15:10:45 +0300
commitccaf9c7c7c77ee9db219b6643a59d637301bcfc9 (patch)
tree113a8aa55815ad81df87d4d49cc84d3c0b7ac051 /main/musl
parent392b45118185170f78d56099a3360c80351f4f33 (diff)
downloadaports-ccaf9c7c7c77ee9db219b6643a59d637301bcfc9.tar.bz2
aports-ccaf9c7c7c77ee9db219b6643a59d637301bcfc9.tar.xz
main/musl: upgrade to git snapshot 2014-06-21
includes syslog.h fix that is needed to fix sysklogd crashes
Diffstat (limited to 'main/musl')
-rw-r--r--main/musl/0003-3fa2eb2a-to-70d9c303.patch84
-rw-r--r--main/musl/1003-fix-gethostby-_r-result-pointer-value-on-error.patch43
-rw-r--r--main/musl/APKBUILD10
3 files changed, 89 insertions, 48 deletions
diff --git a/main/musl/0003-3fa2eb2a-to-70d9c303.patch b/main/musl/0003-3fa2eb2a-to-70d9c303.patch
new file mode 100644
index 000000000..f2d218cee
--- /dev/null
+++ b/main/musl/0003-3fa2eb2a-to-70d9c303.patch
@@ -0,0 +1,84 @@
+diff --git a/configure b/configure
+index 0cff13d..b1cf998 100755
+--- a/configure
++++ b/configure
+@@ -298,12 +298,9 @@ fi
+ tryflag CFLAGS_MEMOPS -fno-tree-loop-distribute-patterns
+
+ #
+-# If debugging is explicitly enabled, don't auto-enable optimizations
++# Enable debugging if requessted.
+ #
+-if test "$debug" = yes ; then
+-CFLAGS_AUTO=-g
+-test "$optimize" = auto && optimize=no
+-fi
++test "$debug" = yes && CFLAGS_AUTO=-g
+
+ #
+ # Possibly add a -O option to CFLAGS and select modules to optimize with
+diff --git a/include/syslog.h b/include/syslog.h
+index 71dbd99..5b4d296 100644
+--- a/include/syslog.h
++++ b/include/syslog.h
+@@ -69,21 +69,17 @@ void vsyslog (int, const char *, va_list);
+ #if defined(SYSLOG_NAMES)
+ #define INTERNAL_NOPRI 0x10
+ #define INTERNAL_MARK (LOG_NFACILITIES<<3)
+-struct __CODE {
+- const char *c_name;
+- int c_val;
+-};
+ typedef struct {
+ char *c_name;
+ int c_val;
+ } CODE;
+-#define prioritynames ((CODE *)(const struct __CODE []){ \
++#define prioritynames ((CODE *)(const CODE []){ \
+ { "alert", LOG_ALERT }, { "crit", LOG_CRIT }, { "debug", LOG_DEBUG }, \
+ { "emerg", LOG_EMERG }, { "err", LOG_ERR }, { "error", LOG_ERR }, \
+ { "info", LOG_INFO }, { "none", INTERNAL_NOPRI }, \
+ { "notice", LOG_NOTICE }, { "panic", LOG_EMERG }, \
+ { "warn", LOG_WARNING }, { "warning", LOG_WARNING }, { 0, -1 } })
+-#define facilitynames ((CODE *)(const struct __CODE []){ \
++#define facilitynames ((CODE *)(const CODE []){ \
+ { "auth", LOG_AUTH }, { "authpriv", LOG_AUTHPRIV }, \
+ { "cron", LOG_CRON }, { "daemon", LOG_DAEMON }, { "ftp", LOG_FTP }, \
+ { "kern", LOG_KERN }, { "lpr", LOG_LPR }, { "mail", LOG_MAIL }, \
+diff --git a/src/network/gethostbyaddr_r.c b/src/network/gethostbyaddr_r.c
+index 73e7644..66e0330 100644
+--- a/src/network/gethostbyaddr_r.c
++++ b/src/network/gethostbyaddr_r.c
+@@ -18,6 +18,8 @@ int gethostbyaddr_r(const void *a, socklen_t l, int af,
+ socklen_t sl = af==AF_INET6 ? sizeof sa.sin6 : sizeof sa.sin;
+ int i;
+
++ *res = 0;
++
+ /* Load address argument into sockaddr structure */
+ if (af==AF_INET6 && l==16) memcpy(&sa.sin6.sin6_addr, a, 16);
+ else if (af==AF_INET && l==4) memcpy(&sa.sin.sin_addr, a, 4);
+diff --git a/src/network/gethostbyname2_r.c b/src/network/gethostbyname2_r.c
+index aa8b0a9..81f71d2 100644
+--- a/src/network/gethostbyname2_r.c
++++ b/src/network/gethostbyname2_r.c
+@@ -17,6 +17,7 @@ int gethostbyname2_r(const char *name, int af,
+ int i, cnt;
+ size_t align, need;
+
++ *res = 0;
+ cnt = __lookup_name(addrs, canon, name, af, AI_CANONNAME);
+ if (cnt<0) switch (cnt) {
+ case EAI_NONAME:
+diff --git a/src/network/sendmmsg.c b/src/network/sendmmsg.c
+index ff9f861..eeae1d0 100644
+--- a/src/network/sendmmsg.c
++++ b/src/network/sendmmsg.c
+@@ -12,6 +12,7 @@ int sendmmsg(int fd, struct mmsghdr *msgvec, unsigned int vlen, unsigned int fla
+ * and the cmsg blocks cannot be modified in-place. */
+ int i;
+ if (vlen > IOV_MAX) vlen = IOV_MAX; /* This matches the kernel. */
++ if (!vlen) return 0;
+ for (i=0; i<vlen; i++) {
+ /* As an unfortunate inconsistency, the sendmmsg API uses
+ * unsigned int for the resulting msg_len, despite sendmsg
diff --git a/main/musl/1003-fix-gethostby-_r-result-pointer-value-on-error.patch b/main/musl/1003-fix-gethostby-_r-result-pointer-value-on-error.patch
deleted file mode 100644
index e753d7ede..000000000
--- a/main/musl/1003-fix-gethostby-_r-result-pointer-value-on-error.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-From a9c5a6208a5afdfbc3f9855887ad39b0d1921514 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Timo=20Ter=C3=A4s?= <timo.teras@iki.fi>
-Date: Fri, 20 Jun 2014 13:53:23 +0300
-Subject: [PATCH] fix gethostby*_r result pointer value on error
-
-man-pages states that the GNU extension functions gethostbyaddr_r,
-gethostbyname_r and gethostbyname2_r are guaranteed to set result
-pointer to NULL in case of error or no result. E.g. openjdk7 can
-crash unless this is not done (it checks for result pointer value
-only and ignores the returned error code).
----
- src/network/gethostbyaddr_r.c | 2 ++
- src/network/gethostbyname2_r.c | 1 +
- 2 files changed, 3 insertions(+)
-
-diff --git a/src/network/gethostbyaddr_r.c b/src/network/gethostbyaddr_r.c
-index 73e7644..66e0330 100644
---- a/src/network/gethostbyaddr_r.c
-+++ b/src/network/gethostbyaddr_r.c
-@@ -18,6 +18,8 @@ int gethostbyaddr_r(const void *a, socklen_t l, int af,
- socklen_t sl = af==AF_INET6 ? sizeof sa.sin6 : sizeof sa.sin;
- int i;
-
-+ *res = 0;
-+
- /* Load address argument into sockaddr structure */
- if (af==AF_INET6 && l==16) memcpy(&sa.sin6.sin6_addr, a, 16);
- else if (af==AF_INET && l==4) memcpy(&sa.sin.sin_addr, a, 4);
-diff --git a/src/network/gethostbyname2_r.c b/src/network/gethostbyname2_r.c
-index aa8b0a9..81f71d2 100644
---- a/src/network/gethostbyname2_r.c
-+++ b/src/network/gethostbyname2_r.c
-@@ -17,6 +17,7 @@ int gethostbyname2_r(const char *name, int af,
- int i, cnt;
- size_t align, need;
-
-+ *res = 0;
- cnt = __lookup_name(addrs, canon, name, af, AI_CANONNAME);
- if (cnt<0) switch (cnt) {
- case EAI_NONAME:
---
-2.0.0
-
diff --git a/main/musl/APKBUILD b/main/musl/APKBUILD
index 22f31c60b..9812962f3 100644
--- a/main/musl/APKBUILD
+++ b/main/musl/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Timo Teräs <timo.teras@iki.fi>
pkgname=musl
pkgver=1.1.2
-pkgrel=3
+pkgrel=4
pkgdesc="the musl c library (libc) implementation"
url="http://www.musl-libc.org/"
arch="all"
@@ -15,9 +15,9 @@ subpackages="$pkgname-dev $pkgname-utils"
source="http://www.musl-libc.org/releases/musl-$pkgver.tar.gz
0001-v1.1.2-to-66fcde4a.patch
0002-66fcde4a-to-3fa2eb2a.patch
+ 0003-3fa2eb2a-to-70d9c303.patch
1001-add-basic-dns-record-parsing-functions.patch
1002-reimplement-if_nameindex-and-getifaddrs-using-netlin.patch
- 1003-fix-gethostby-_r-result-pointer-value-on-error.patch
ldconfig
getopt_long.c
@@ -121,9 +121,9 @@ utils() {
md5sums="a81309e54efdf9c68baf679790fc5678 musl-1.1.2.tar.gz
a6a1f5c4f34f80cb1fd4c6e1b7936013 0001-v1.1.2-to-66fcde4a.patch
3a852204b383784506d861b3a307b939 0002-66fcde4a-to-3fa2eb2a.patch
+1f4f1caf7be196015e1444c6acfeb7f4 0003-3fa2eb2a-to-70d9c303.patch
a3810683ef61ac27e2f6ec9801280c81 1001-add-basic-dns-record-parsing-functions.patch
83c3bd2a50b1de5ef948704d3f4e0583 1002-reimplement-if_nameindex-and-getifaddrs-using-netlin.patch
-b0102f0fb7acda7fca9d93932d144a2b 1003-fix-gethostby-_r-result-pointer-value-on-error.patch
013be8897f27c3909ada59c62020502f ldconfig
61c6c1e84ed1df82abbe6d75e90cf21c getopt_long.c
0df687757221bbb0fc1aa67f1bd646f9 __stack_chk_fail_local.c
@@ -133,9 +133,9 @@ cb82d21fed17a116b44b830adba71c5a getconf.c
sha256sums="dac94112b9a22d2657cd3f36ca0d62ee1eb10707a22bfc97d5746147ef92852b musl-1.1.2.tar.gz
2cd863b8a7d4af3d592607b20479163c1a011cf5a458cf7f0dc2dc9c08f5b57c 0001-v1.1.2-to-66fcde4a.patch
0c09923f514729533992f251b7eaa776c414373b3fa20ec2274257c29323028d 0002-66fcde4a-to-3fa2eb2a.patch
+a65e7423db737122b2cc0d0f17b613c38a98ade638a9b87eeca86ee8399fb91a 0003-3fa2eb2a-to-70d9c303.patch
758390768b1bc4159d56908ca332b9640cd0552ed3b4b2b8d4a6d499c54c11a1 1001-add-basic-dns-record-parsing-functions.patch
1c25880095e869b827f02997e864fdf4bf157a4e923e52d97dbd05e657aedb70 1002-reimplement-if_nameindex-and-getifaddrs-using-netlin.patch
-5cca6e1b1ab896d47acf48d5f9c0b255191859b6cbeff74d99343d839d088132 1003-fix-gethostby-_r-result-pointer-value-on-error.patch
398dc26ec82cc6af056c738e8ac62da212ba978229d9839eb8b61f7ce536da4a ldconfig
d9b644ec20bc33e81a7c52b9fcf7973d835923a69faf50f03db45534b811bd96 getopt_long.c
299a7d75a09de3e2e11e7fb4acc3182e4a14e868093d2f30938fce9bfcff13da __stack_chk_fail_local.c
@@ -145,9 +145,9 @@ f79a2930a2e5bb0624321589edf8b889d1e9b603e01e6b7ae214616605b3fdd7 iconv.c"
sha512sums="54d279efea6e122567c936e47401df5c0f1493c42eb3199b0ba3053b1882a864fc1a71d19ad945bc4f328407231c54a7897413e37f4bc33337a243c044a26b4a musl-1.1.2.tar.gz
631b93b875d0b4451e8ab4587d4cd495617fe4b8627387bb7d19af5e9b354ae726e91b24abea87acc63f9b30ea55e1f65d87cf8ecfba2c69e0cdcdab15d84fa9 0001-v1.1.2-to-66fcde4a.patch
a29bc04846875ce54f00ce14c11dfc0075ace05acd15c7c95a14c639fd02d6dad7c57f1fbffea85984d13c089d2620e25238ee377041cf15c742b831c8a1e6f2 0002-66fcde4a-to-3fa2eb2a.patch
+c60d044380d1c60739a24c6dc970d416c8921ce6faacc23387a375b1180809b5b964f0b0b1a4c5039d0607a764ed8d503edf6bc7399ec589fafa2074e388d4a9 0003-3fa2eb2a-to-70d9c303.patch
dad965258daf69371b844f76bfe5a914b0eca0ca76f3fc340b8fd7acf598b5f87bbe6d68b1f43ed0293ee0ed3bfd85d5173ccc169aa6265646248d5b8a906708 1001-add-basic-dns-record-parsing-functions.patch
72cf33738d2cf31f6ec02312bc494d754c17470b519172bb8bd7e2e29ac3b119023088a2b3fbc0dbc2fddd0078ccbae62096106cae361f8c31d6a9950043af25 1002-reimplement-if_nameindex-and-getifaddrs-using-netlin.patch
-faa7c2b944d643f271f797077cef9368e16f38bc83a5f96ab18a9e58e781020a06fab7b8fd0622d5394f6a8e5a98ae99784dd994185ceb1c55f5000c734b7a9e 1003-fix-gethostby-_r-result-pointer-value-on-error.patch
33e13d2242063f3dc9ec199ae9528e469a52ccae4d3726faa3c866e0c7dcf546f69294f9c00307324cee05fd965f84350ae100b8b1138f9d9c8c916de04ab0d1 ldconfig
140f3f20d30bd95ebce8c41b8cc7f616c6cbedf4ea06c729c21014e74f6043796825cc40ebc5180620ea38173afdba23f09ebf6d8b11fa05440b14d23764fca9 getopt_long.c
062bb49fa54839010acd4af113e20f7263dde1c8a2ca359b5fb2661ef9ed9d84a0f7c3bc10c25dcfa10bb3c5a4874588dff636ac43d5dbb3d748d75400756d0b __stack_chk_fail_local.c