summaryrefslogtreecommitdiffstats
path: root/main/mythes
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-04-10 14:53:51 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-04-10 14:59:57 +0000
commita27d2bd8bf2de9ab847935fa6ec2363a85270ee7 (patch)
treed4d1143a035b38ce48a76c50276630b70c562904 /main/mythes
parenta1ab97672a9f84f79ee19643f8aea3774ccbba3b (diff)
downloadaports-a27d2bd8bf2de9ab847935fa6ec2363a85270ee7.tar.bz2
aports-a27d2bd8bf2de9ab847935fa6ec2363a85270ee7.tar.xz
main/mythes: moved to main
Diffstat (limited to 'main/mythes')
-rw-r--r--main/mythes/APKBUILD55
1 files changed, 55 insertions, 0 deletions
diff --git a/main/mythes/APKBUILD b/main/mythes/APKBUILD
new file mode 100644
index 000000000..b4f24aa94
--- /dev/null
+++ b/main/mythes/APKBUILD
@@ -0,0 +1,55 @@
+# Contributor: Timo Teräs <timo.teras@iki.fi>
+# Maintainer: Timo Teräs <timo.teras@iki.fi>
+pkgname=mythes
+pkgver=1.2.4
+pkgrel=0
+pkgdesc="A simple thesaurus"
+url="http://hunspell.sourceforge.net/"
+arch="all"
+license="GPL2+ LGPL2+ MPL 1.1"
+subpackages="$pkgname-dev"
+depends=""
+depends_dev="perl hunspell-dev"
+makedepends="$depends_dev"
+source="http://downloads.sourceforge.net/hunspell/$pkgname-$pkgver.tar.gz
+ "
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --disable-static \
+ --disable-dependency-tracking \
+ --enable-fast-install \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make -j1 DESTDIR="$pkgdir" install || return 1
+ rm "$pkgdir"/usr/lib/*.la || return 1
+}
+
+dev() {
+ default_dev
+
+ mkdir -p "$subpkgdir"/usr
+ mv "$pkgdir"/usr/bin "$subpkgdir"/usr
+}
+
+md5sums="a8c2c5b8f09e7ede322d5c602ff6a4b6 mythes-1.2.4.tar.gz"
+sha256sums="1e81f395d8c851c3e4e75b568e20fa2fa549354e75ab397f9de4b0e0790a305f mythes-1.2.4.tar.gz"
+sha512sums="a04da39812bcfb1391a2cba7de73e955eafe141679ec03ed6657d03bebf360b432480d0037dff9ed72a1dfda5a70d77d44ac2bb14cdb109fd8e2a38376feee21 mythes-1.2.4.tar.gz"