summaryrefslogtreecommitdiffstats
path: root/main/nasm
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-01-01 12:44:58 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-01-01 12:44:58 +0000
commit415897deaba77bd80267c4d85f5005534055bae0 (patch)
treeb854f3aaa16fc774c4da05d4ffa2b423b51191e1 /main/nasm
parentb3f89957cf32c4629b7c267cc10be620ed0f047a (diff)
downloadaports-415897deaba77bd80267c4d85f5005534055bae0.tar.bz2
aports-415897deaba77bd80267c4d85f5005534055bae0.tar.xz
main/nasm: bugfix for space after backslash
fixes building of zsnes
Diffstat (limited to 'main/nasm')
-rw-r--r--main/nasm/APKBUILD22
-rw-r--r--main/nasm/space-after-backslash.patch31
2 files changed, 48 insertions, 5 deletions
diff --git a/main/nasm/APKBUILD b/main/nasm/APKBUILD
index 661ca83fc..963f64822 100644
--- a/main/nasm/APKBUILD
+++ b/main/nasm/APKBUILD
@@ -1,18 +1,29 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=nasm
pkgver=2.10.06
-pkgrel=0
+pkgrel=1
pkgdesc="80x86 assembler designed for portability and modularity"
url="http://nasm.sourceforge.net"
arch="all"
license="LGPL"
depends=
-source="http://www.nasm.us/pub/nasm/releasebuilds/$pkgver/$pkgname-$pkgver.tar.bz2"
+source="http://www.nasm.us/pub/nasm/releasebuilds/$pkgver/$pkgname-$pkgver.tar.bz2
+ space-after-backslash.patch"
subpackages="$pkgname-doc"
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
build () {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$_builddir"
export CFLAGS=
export CXXFLAGS=
./configure --prefix=/usr
@@ -21,7 +32,8 @@ build () {
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$_builddir"
make INSTALLROOT="$pkgdir" install
}
-md5sums="875c4217b2e581dbae0bf96d45a6067a nasm-2.10.06.tar.bz2"
+md5sums="875c4217b2e581dbae0bf96d45a6067a nasm-2.10.06.tar.bz2
+87a4def3898f4dddfde17bcc7b57fd40 space-after-backslash.patch"
diff --git a/main/nasm/space-after-backslash.patch b/main/nasm/space-after-backslash.patch
new file mode 100644
index 000000000..c6e0df5dd
--- /dev/null
+++ b/main/nasm/space-after-backslash.patch
@@ -0,0 +1,31 @@
+From 490f85e73d8bca15ada1c0bacc101c136e5d9cee Mon Sep 17 00:00:00 2001
+From: Cyrill Gorcunov <gorcunov@gmail.com>
+Date: Thu, 27 Dec 2012 20:02:17 +0400
+Subject: [PATCH] br3392236: Don't treat \Space after \BackSlash as a sign for line continuation
+
+In commit f1fe4fdeabeaf2e5e4d02ef43beeb09a6fbfed1b I occasionally
+made a \Space after \BackSlash being a sign of line continuation.
+
+Fix it.
+
+Signed-off-by: Cyrill Gorcunov <gorcunov@gmail.com>
+---
+ preproc.c | 2 +-
+ 1 files changed, 1 insertions(+), 1 deletions(-)
+
+diff --git a/preproc.c b/preproc.c
+index 8c5bf7a..9d65917 100644
+--- a/preproc.c
++++ b/preproc.c
+@@ -844,7 +844,7 @@ static char *read_line(void)
+ case '\\':
+ next = fgetc(istk->fp);
+ ungetc(next, istk->fp);
+- if (next == ' ' || next == '\r' || next == '\n') {
++ if (next == '\r' || next == '\n') {
+ cont = true;
+ nr_cont++;
+ continue;
+--
+1.6.5.GIT
+