summaryrefslogtreecommitdiffstats
path: root/main/ocfs2-tools
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2013-01-07 12:47:50 +0100
committerCarlo Landmeter <clandmeter@gmail.com>2013-01-07 12:47:50 +0100
commitb6226d09b1cd479150a69861bc35ef8ee79038ee (patch)
tree9bc78ce6b46e65ab91109a208c81c480b4296c74 /main/ocfs2-tools
parentefab697c63d275c149f9d9226efe7b9aed1966e8 (diff)
downloadaports-b6226d09b1cd479150a69861bc35ef8ee79038ee.tar.bz2
aports-b6226d09b1cd479150a69861bc35ef8ee79038ee.tar.xz
main/ocfs2-tools: fix build on eglibc
Diffstat (limited to 'main/ocfs2-tools')
-rw-r--r--main/ocfs2-tools/APKBUILD6
-rw-r--r--main/ocfs2-tools/ocfs2-tools-1.6.4-umode_t.patch12
2 files changed, 16 insertions, 2 deletions
diff --git a/main/ocfs2-tools/APKBUILD b/main/ocfs2-tools/APKBUILD
index 36974afd8..ee4b71d89 100644
--- a/main/ocfs2-tools/APKBUILD
+++ b/main/ocfs2-tools/APKBUILD
@@ -17,7 +17,8 @@ source="http://oss.oracle.com/projects/ocfs2-tools/dist/files/source/v${pkgver%.
$pkgname.initd
$pkgname.confd
$pkgname.cluster-conf
- ocfs2-tools-1.6-operations-missing-include.patch"
+ ocfs2-tools-1.6-operations-missing-include.patch
+ ocfs2-tools-1.6.4-umode_t.patch"
_builddir="$srcdir"/$pkgname-$pkgver
@@ -63,4 +64,5 @@ c938040f0e77a4bb23e952c8f99b6cc5 build.patch
601fbd79acdc52a9046293aa977b1547 ocfs2-tools.initd
d81b6ab068ec92a137b58c9ad56c4637 ocfs2-tools.confd
189e433cf001465f1565faae2e6e10ac ocfs2-tools.cluster-conf
-f1d6bd7f02e69b31b8a103d18c7209f6 ocfs2-tools-1.6-operations-missing-include.patch"
+f1d6bd7f02e69b31b8a103d18c7209f6 ocfs2-tools-1.6-operations-missing-include.patch
+cd4710efdb07660459fda1b514cfa8a6 ocfs2-tools-1.6.4-umode_t.patch"
diff --git a/main/ocfs2-tools/ocfs2-tools-1.6.4-umode_t.patch b/main/ocfs2-tools/ocfs2-tools-1.6.4-umode_t.patch
new file mode 100644
index 000000000..fb8b71408
--- /dev/null
+++ b/main/ocfs2-tools/ocfs2-tools-1.6.4-umode_t.patch
@@ -0,0 +1,12 @@
+--- ocfs2-tools-1.6.4/include/ocfs2-kernel/ocfs2_fs.h 2010-12-29 07:30:55.000000000 +0100
++++ ocfs2-tools-1.6.4.n/include/ocfs2-kernel/ocfs2_fs.h 2012-04-23 19:13:46.402253336 +0200
+@@ -1638,7 +1638,7 @@
+ }
+
+ static inline void ocfs2_set_de_type(struct ocfs2_dir_entry *de,
+- umode_t mode)
++ unsigned short mode)
+ {
+ de->file_type = ocfs2_type_by_mode[(mode & S_IFMT)>>S_SHIFT];
+ }
+