summaryrefslogtreecommitdiffstats
path: root/main/openrc
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-04-28 09:47:36 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-04-28 12:04:02 +0000
commit2e7922af924772cbe2c0c7a251d9e9663cc7977d (patch)
tree2faed76571936877af37fc892565ceb5348bd0c0 /main/openrc
parent5a230bb9a4f48f305eac4beda9ae602fee96ff4e (diff)
downloadaports-2e7922af924772cbe2c0c7a251d9e9663cc7977d.tar.bz2
aports-2e7922af924772cbe2c0c7a251d9e9663cc7977d.tar.xz
main/openrc: upgrade to 0.14
Diffstat (limited to 'main/openrc')
-rw-r--r--main/openrc/0001-sysctl.Linux.in-fix-for-busybox-sysctl.patch36
-rw-r--r--main/openrc/0001-sysctl.Linux.in-remove-lxc-from-exclusion-list.patch26
-rw-r--r--main/openrc/APKBUILD24
-rw-r--r--main/openrc/begin-end-decls.patch46
4 files changed, 46 insertions, 86 deletions
diff --git a/main/openrc/0001-sysctl.Linux.in-fix-for-busybox-sysctl.patch b/main/openrc/0001-sysctl.Linux.in-fix-for-busybox-sysctl.patch
new file mode 100644
index 000000000..a58712674
--- /dev/null
+++ b/main/openrc/0001-sysctl.Linux.in-fix-for-busybox-sysctl.patch
@@ -0,0 +1,36 @@
+From 01dba03704574dda2c43ec3a0609144a8c03c641 Mon Sep 17 00:00:00 2001
+From: Natanael Copa <ncopa@alpinelinux.org>
+Date: Tue, 28 Apr 2015 12:26:46 +0200
+Subject: [PATCH] sysctl.Linux.in: fix for busybox sysctl
+
+busybox sysctl does not support --system
+---
+ init.d/sysctl.Linux.in | 13 ++++++++++++-
+ 1 file changed, 12 insertions(+), 1 deletion(-)
+
+diff --git a/init.d/sysctl.Linux.in b/init.d/sysctl.Linux.in
+index 1defcec..2371b29 100644
+--- a/init.d/sysctl.Linux.in
++++ b/init.d/sysctl.Linux.in
+@@ -14,6 +14,17 @@ start()
+ yesno $rc_verbose || quiet=-q
+
+ ebegin "Configuring kernel parameters"
+- sysctl ${quiet} --system
++ set --
++ for i in /run/sysctl.d/*.conf \
++ /etc/sysctl.d/*.conf \
++ /usr/local/lib/sysctl.d/*.conf \
++ /usr/lib/sysctl.d/*.conf \
++ /lib/sysctl.d/*.conf \
++ /etc/sysctl.conf; do
++ if [ -e "$i" ]; then
++ set -- "$@" "$i"
++ fi
++ done
++ sysctl ${quiet} -p "$@"
+ eend $? "Unable to configure some kernel parameters"
+ }
+--
+2.3.6
+
diff --git a/main/openrc/0001-sysctl.Linux.in-remove-lxc-from-exclusion-list.patch b/main/openrc/0001-sysctl.Linux.in-remove-lxc-from-exclusion-list.patch
deleted file mode 100644
index 16dc69495..000000000
--- a/main/openrc/0001-sysctl.Linux.in-remove-lxc-from-exclusion-list.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From d93684053a03f1babfaec323fde7a97812254bcc Mon Sep 17 00:00:00 2001
-From: Kaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>
-Date: Wed, 2 Jul 2014 11:45:14 +0300
-Subject: [PATCH] sysctl.Linux.in: remove lxc from exclusion list
-
-certain tunables can be set independently for each container
----
- init.d/sysctl.Linux.in | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/init.d/sysctl.Linux.in b/init.d/sysctl.Linux.in
-index 1ebce66..cda86b5 100644
---- a/init.d/sysctl.Linux.in
-+++ b/init.d/sysctl.Linux.in
-@@ -5,7 +5,7 @@
- depend()
- {
- before bootmisc logger
-- keyword -lxc -prefix -vserver
-+ keyword -prefix -vserver
- }
-
- start()
---
-1.8.3.1
-
diff --git a/main/openrc/APKBUILD b/main/openrc/APKBUILD
index a50618b05..10f65e46b 100644
--- a/main/openrc/APKBUILD
+++ b/main/openrc/APKBUILD
@@ -1,8 +1,8 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=openrc
-pkgver=0.12.4
+pkgver=0.14
_ver=${pkgver/_git*/}
-pkgrel=8
+pkgrel=0
pkgdesc="OpenRC manages the services, startup and shutdown of a host"
url="http://git.overlays.gentoo.org/gitweb/?p=proj/openrc.git"
arch="all"
@@ -11,14 +11,13 @@ depends=""
makedepends="bsd-compat-headers"
subpackages="$pkgname-doc $pkgname-dev"
install="$pkgname.post-install $pkgname.post-upgrade"
-source="http://distfiles.gentoo.org/distfiles/$pkgname-$_ver.tar.bz2
+source="openrc-$pkgver.tar.gz::https://github.com/OpenRC/openrc/archive/$pkgver.tar.gz
openrc-0.4.3-mkmntdirs.patch
0001-Force-root-be-rw-before-localmount.patch
- 0001-sysctl.Linux.in-remove-lxc-from-exclusion-list.patch
+ 0001-sysctl.Linux.in-fix-for-busybox-sysctl.patch
swap-umount-tmpfs.patch
swap-ifexists.patch
- begin-end-decls.patch
hide-migrate-to-run-error.patch
hostname.initd
@@ -66,13 +65,12 @@ package() {
install -d "$pkgdir"/etc/local.d "$pkgdir"/run
}
-md5sums="6c89372f4bbbcb351ec9ee0b3b5ac0bd openrc-0.12.4.tar.bz2
+md5sums="9cf465c6013bf95ae003bc4a9d11aed4 openrc-0.14.tar.gz
8c2c1c2ee0509b63966b7187a2079f4b openrc-0.4.3-mkmntdirs.patch
4fd036ff07ed9ad7fb76af6a3ffc0695 0001-Force-root-be-rw-before-localmount.patch
-dc910534c79ebcb0dd76c634b2ff57c5 0001-sysctl.Linux.in-remove-lxc-from-exclusion-list.patch
+09df9c2a6fbf3e18586c3737cd481e67 0001-sysctl.Linux.in-fix-for-busybox-sysctl.patch
c2af5e52da614a6cef02d1e4d537e360 swap-umount-tmpfs.patch
1c426b84d13a725ad493647b5253f239 swap-ifexists.patch
-00c0d99a19915fac57a20e5995f57bdb begin-end-decls.patch
679c559aa54f9e855cd735866eeaaad6 hide-migrate-to-run-error.patch
c32e15b0858eef708497e7ee6355a055 hostname.initd
ce3832d8ed5906367ef0f4776b38f3bd hwdrivers.initd
@@ -81,13 +79,12 @@ ce3832d8ed5906367ef0f4776b38f3bd hwdrivers.initd
673667abbca920c3cb203e621e761f30 modloop.initd
55aeca82475cb5a146abff8333bfdf85 networking.initd
c1ec888202d868710b5749f7b217d1e3 modloop.confd"
-sha256sums="c4edda2fff4b613f50b9cc265bb457a9ab0170fbc1fe7c26eccd4a5d63b2625c openrc-0.12.4.tar.bz2
+sha256sums="fbc1a88ac53e01681a8945dccc16a71c86550a741e8f32fd3e75ba46512653f3 openrc-0.14.tar.gz
c807aed11d7eb42de5c421a6d117532f6215697f159f40cb3404bdc80270bee1 openrc-0.4.3-mkmntdirs.patch
e869e2076c10a7134f5d9e4ae4a5d09ca35c6333d400556f1e329170d2e58066 0001-Force-root-be-rw-before-localmount.patch
-984451737f15c7715b77ce8c9ff3ba4146b0b35032aa721dfdd2973e60751146 0001-sysctl.Linux.in-remove-lxc-from-exclusion-list.patch
+8125caab3798d97acfae678ab81085ac247d570e471238c0cfc5b08a84cb61bd 0001-sysctl.Linux.in-fix-for-busybox-sysctl.patch
84d67ed2cf050e20f52d4ea048e7452e78356ba02b396d8c064a4458c0811ea4 swap-umount-tmpfs.patch
8978b00492d90b573f5254cc394582e8f1a5cd8b4d6c928fa0a9a022dd17fe9c swap-ifexists.patch
-d3b20f5cb053ed24d7b76b75aeef98b9f2bc77401930fa934c9452fa634db18c begin-end-decls.patch
786580df90a5a75087e5adfd395d160dee2df4b994e0938e8524198aeaf2d774 hide-migrate-to-run-error.patch
e91790d23135c43102ea73e5768d4b0d25e9a7d28fca90f1b902aac9c41e1d5c hostname.initd
a71a38309beb6f4718a2ece863659735a5e157a7c927518265e562cd90fc71ff hwdrivers.initd
@@ -96,13 +93,12 @@ a6f013c02ca3efb4e29b4844e4d27710cfd319e66157c4fd88a8169e06e7151f keymaps.initd
407f4830fd11ff187b97edfdea5b81dcd2747545fe2dbf28ec7dfba48cc91cda modloop.initd
dc30c4e0cac37597dda3f97f68aa2f8a5e87a9856de8b2fd08579916117de8ed networking.initd
a5a0316cd59f5401b1d789bb466c98186201277ba6f014017b14965fcc10c254 modloop.confd"
-sha512sums="14e188e382dfe02037d3e4211fa3265152d5ec92ca491b1e86154c0615583ddfc0a2592ca849ab453068dd60000886e57e7da024036fa58d7474acdbb6b92208 openrc-0.12.4.tar.bz2
+sha512sums="5d2eb8a81fa243b0d1fc6c6a3026461752bf491ba5aa2155b182d3249d98fb3729630ccaaa811402d7f5eaaf08399304357c4011d6523cac0cf69e1d10a02274 openrc-0.14.tar.gz
eee27fbf72776fb70d3aa6c6464180731d522191e5755aa431ab09ea11dd11bf001a95618adcaa5ccc08455268003ca2917b2bff31adc9894214221c469a97db openrc-0.4.3-mkmntdirs.patch
51c77be5ab726d50ef1d0b9dab644edef1ff739e855e3a12ab27beada8911998e0c6a7491eb92df621dcdb633b672d933a4edc00115ec43bdf1271105239ebb7 0001-Force-root-be-rw-before-localmount.patch
-7713a532340f21ebd813b28cbcf6e86425822d5e3235935227cbadcd7ed6c674f909b293ae6abb44c6bd2884ff4b6b34a70e052fe273b593f560f39ec5f1f824 0001-sysctl.Linux.in-remove-lxc-from-exclusion-list.patch
+ce9c2cc211a391f20702dbc51fe0cf3c979cb25f5d6d3bdf2ebbaf1c5fd6d39d102a7a37effa751c02a865f91e316672819e0a4c1cd76e0524a7a2a7e2b9a1f6 0001-sysctl.Linux.in-fix-for-busybox-sysctl.patch
8fd442d372401740b1c523367c928f49efa8179604aac2b517cdc4264daf303056d5a5e0a2c996db5e6ef9b7cdd0619a16cfabc15c3399e322384844e2a36542 swap-umount-tmpfs.patch
c5b8806c693b0ea48ff87e0e3669304f5c2f95954ad54814889047a933f367081a8c8d3bb771dd1ed6c3bc845df894232bd6b662066d09eba3abf3964187d1d1 swap-ifexists.patch
-92788e88c0da278f6673df90cd34f8204b8226305f7ee3e43e33566f1c7b8ff819bba954d82c14305f4174a76398abe7e029ee99e816cc94963a65d42ec89c92 begin-end-decls.patch
750e3305913d3f6fa6baa0b34b851fe17aacb922e864b95ec9b4b451e8e3c16d0c10686a12f4c7cb9b5d05894e1d89b0dac3beed19b1223d3fbc672f25769145 hide-migrate-to-run-error.patch
6de80fd9ff9692bb15aa0a90255beea939a4f79b4fdff9fdf443d85bf168c162183efa44d7769af855f9c2460c77f29df19037eca09156ac42dd01fba7be9934 hostname.initd
932669915d0e4c8b7d23823c6d057d5d3bbc7f2f67532547201fea986c7e3208607d69cfdd41b0b0b1828f33c4e87efb8d65f7a715c33a8c9cdc846b7ec7439b hwdrivers.initd
diff --git a/main/openrc/begin-end-decls.patch b/main/openrc/begin-end-decls.patch
deleted file mode 100644
index 19e67949b..000000000
--- a/main/openrc/begin-end-decls.patch
+++ /dev/null
@@ -1,46 +0,0 @@
---- openrc-0.11.8.orig/src/libeinfo/einfo.h
-+++ openrc-0.11.8/src/libeinfo/einfo.h
-@@ -48,7 +48,9 @@
- # endif
- #endif
-
--__BEGIN_DECLS
-+#ifdef __cplusplus
-+extern "C" {
-+#endif
-
- /*! @brief Color types to use */
- typedef enum
-@@ -140,5 +142,8 @@
- /*! @brief Prefix each einfo line with something */
- void eprefix(const char * EINFO_RESTRICT);
-
--__END_DECLS
-+#ifdef __cplusplus
-+}
-+#endif
-+
- #endif
---- openrc-0.11.8.orig/src/librc/rc.h.in
-+++ openrc-0.11.8/src/librc/rc.h.in
-@@ -31,7 +31,9 @@
- #include <stdbool.h>
- #include <stdio.h>
-
--__BEGIN_DECLS
-+#ifdef __cplusplus
-+extern "C" {
-+#endif
-
- #define RC_PREFIX "@PREFIX@"
- #define RC_SYSCONFDIR "@SYSCONFDIR@"
-@@ -563,5 +565,8 @@
- * we have our own */
- ssize_t rc_getline(char **, size_t *, FILE *);
-
--__END_DECLS
-+#ifdef __cplusplus
-+}
-+#endif
-+
- #endif