summaryrefslogtreecommitdiffstats
path: root/main/openrc
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-02-05 14:03:01 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2013-02-05 14:04:23 +0100
commit90e8b091cd1484e0a7b28ee905bd792e4b12d56c (patch)
treecefcc52e9eb824548ce63e319fce3881a25d4b0d /main/openrc
parentba39f71b2a8dfd155684df4b01f098039b68389e (diff)
downloadaports-90e8b091cd1484e0a7b28ee905bd792e4b12d56c.tar.bz2
aports-90e8b091cd1484e0a7b28ee905bd792e4b12d56c.tar.xz
openrc: hwdrivers: respect blacklist and fix for whitepaces in /sys paths
Diffstat (limited to 'main/openrc')
-rw-r--r--main/openrc/APKBUILD4
-rw-r--r--main/openrc/hwdrivers.initd9
2 files changed, 6 insertions, 7 deletions
diff --git a/main/openrc/APKBUILD b/main/openrc/APKBUILD
index 395eb0240..fcc31f2f4 100644
--- a/main/openrc/APKBUILD
+++ b/main/openrc/APKBUILD
@@ -2,7 +2,7 @@
pkgname=openrc
pkgver=0.10.5
_ver=${pkgver/_git*/}
-pkgrel=7
+pkgrel=8
pkgdesc="OpenRC manages the services, startup and shutdown of a host"
url="http://git.overlays.gentoo.org/gitweb/?p=proj/openrc.git"
arch="all"
@@ -70,7 +70,7 @@ c2af5e52da614a6cef02d1e4d537e360 swap-umount-tmpfs.patch
1c426b84d13a725ad493647b5253f239 swap-ifexists.patch
4a2ec4d9d988423fdafc332d2174ecdf rc-sys-lxc.patch
c32e15b0858eef708497e7ee6355a055 hostname.initd
-78e9f0df010ac8095c5e76a91a1d3b12 hwdrivers.initd
+ce3832d8ed5906367ef0f4776b38f3bd hwdrivers.initd
33ca3e558c42cdd17adccbc7807298f7 keymaps.initd
098a1f16812f56fcb56eb6b6f0fa31f6 modules.initd
d10c4fd412faf0b970bb470f493fe718 modloop.initd
diff --git a/main/openrc/hwdrivers.initd b/main/openrc/hwdrivers.initd
index d4551ca23..86b78e2b6 100644
--- a/main/openrc/hwdrivers.initd
+++ b/main/openrc/hwdrivers.initd
@@ -14,14 +14,13 @@ start() {
ewarn "Autodetection of hardware disabled from boot cmdline"
return 0
fi
-
ebegin "Loading hardware drivers"
- find /sys -name modalias | xargs sort -u \
- | xargs modprobe -a 2> /dev/null
+ find /sys -name modalias -type f -print0 | xargs -0 sort -u \
+ | xargs modprobe -b -a 2> /dev/null
# we run it twice so we detect all devices
- find /sys -name modalias | xargs sort -u \
- | xargs modprobe -a 2> /dev/null
+ find /sys -name modalias -type f -print0 | xargs -0 sort -u \
+ | xargs modprobe -b -a 2> /dev/null
# check if framebuffer drivers got pulled in
if [ -e /sys/module/fb ] && ! [ -e /sys/module/fbcon ]; then