summaryrefslogtreecommitdiffstats
path: root/main/orc
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-05-04 16:14:41 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-05-04 16:14:41 +0000
commitce400100c0ca35db2fcad4ddee22040a386932fa (patch)
treec68a1853334d4d0672bb951dbb1a5667a1752f57 /main/orc
parent0f73e1ef1ccd8f74f5401660c15ac6683fb3332b (diff)
downloadaports-ce400100c0ca35db2fcad4ddee22040a386932fa.tar.bz2
aports-ce400100c0ca35db2fcad4ddee22040a386932fa.tar.xz
main/orc: new aport
The Oil Run-time Compiler http://code.entropywave.com/projects/orc/
Diffstat (limited to 'main/orc')
-rw-r--r--main/orc/APKBUILD57
1 files changed, 57 insertions, 0 deletions
diff --git a/main/orc/APKBUILD b/main/orc/APKBUILD
new file mode 100644
index 000000000..3a20abfda
--- /dev/null
+++ b/main/orc/APKBUILD
@@ -0,0 +1,57 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=orc
+pkgver=0.4.14
+pkgrel=0
+pkgdesc="The Oil Run-time Compiler"
+url="http://code.entropywave.com/projects/orc/"
+arch="all"
+license="BSD"
+depends=
+depends_dev=
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc $pkgname-compiler"
+source="http://code.entropywave.com/download/orc/orc-$pkgver.tar.gz"
+
+_builddir="$srcdir"/orc-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" -name '*.la' -delete
+}
+
+dev() {
+ default_dev
+ mkdir -p "$subpkgdir"/usr/bin
+ mv "$pkgdir"/usr/bin/orc-bugreport "$subpkgdir"/usr/bin/
+}
+
+compiler() {
+ pkgdesc="Orc compiler"
+ mkdir -p "$subpkgdir"/usr/
+ mv "$pkgdir"/usr/bin "$subpkgdir"/usr/
+}
+
+md5sums="6b3ff209e9763ebe40e152538884bd71 orc-0.4.14.tar.gz"