summaryrefslogtreecommitdiffstats
path: root/main/ortp
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-02-12 11:43:54 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-02-12 11:44:22 +0000
commit1fe29dc93d8a893c1f5ca0a29df26c117cc0dc2e (patch)
tree832a57c7ab6e7b134e45c8653a8b0939303b3b08 /main/ortp
parent3daae17ded9bb9808c30220ff6ea97a89494b9a0 (diff)
downloadaports-1fe29dc93d8a893c1f5ca0a29df26c117cc0dc2e.tar.bz2
aports-1fe29dc93d8a893c1f5ca0a29df26c117cc0dc2e.tar.xz
main/ortp: upgrade to 0.18.0
Diffstat (limited to 'main/ortp')
-rw-r--r--main/ortp/APKBUILD8
-rw-r--r--main/ortp/ortp-0.16.1-retval.patch20
-rw-r--r--main/ortp/ortp-0.16.1-unusedvar.patch42
3 files changed, 2 insertions, 68 deletions
diff --git a/main/ortp/APKBUILD b/main/ortp/APKBUILD
index a9f059dbd..e32aff035 100644
--- a/main/ortp/APKBUILD
+++ b/main/ortp/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=ortp
-pkgver=0.16.5
+pkgver=0.18.0
pkgrel=0
pkgdesc="A C library implementing the RTP protocol (RFC3550)"
url="http://www.linphone.org/index.php/code_review/ortp"
@@ -12,8 +12,6 @@ makedepends=""
install=""
subpackages="$pkgname-dev"
source="http://nongnu.askapache.com/linphone/ortp/sources/ortp-$pkgver.tar.gz
- ortp-0.16.1-retval.patch
- ortp-0.16.1-unusedvar.patch
"
_builddir="$srcdir"/ortp-$pkgver
@@ -42,6 +40,4 @@ package() {
rm -f "$pkgdir"/usr/lib/*.la
}
-md5sums="94546901d14b85f97342f4ecf39489b1 ortp-0.16.5.tar.gz
-cdd971e04073b3de2e935e6ff502110f ortp-0.16.1-retval.patch
-f3323a01f3d82279c3ce5ed1bb1969c5 ortp-0.16.1-unusedvar.patch"
+md5sums="098e984f9325d9e2648bfd9863eed501 ortp-0.18.0.tar.gz"
diff --git a/main/ortp/ortp-0.16.1-retval.patch b/main/ortp/ortp-0.16.1-retval.patch
deleted file mode 100644
index 679f8d7d4..000000000
--- a/main/ortp/ortp-0.16.1-retval.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-diff -up ortp-0.16.1/src/stun.c.retval ortp-0.16.1/src/stun.c
---- ortp-0.16.1/src/stun.c.retval 2010-09-04 10:14:53.000000000 +0200
-+++ ortp-0.16.1/src/stun.c 2010-09-04 10:15:10.000000000 +0200
-@@ -1191,6 +1191,7 @@ stunRand(void)
- int maxFd=0;
- struct timeval tv;
- int e;
-+ int res;
-
- int fd=open("/dev/random",O_RDONLY);
-
-@@ -1213,7 +1214,7 @@ stunRand(void)
- closesocket(fd);
- return random();
- }
-- read(fd,&tick,sizeof(tick));
-+ res = read(fd,&tick,sizeof(tick));
- closesocket(fd);
- }
- #else
diff --git a/main/ortp/ortp-0.16.1-unusedvar.patch b/main/ortp/ortp-0.16.1-unusedvar.patch
deleted file mode 100644
index 0e5d18c86..000000000
--- a/main/ortp/ortp-0.16.1-unusedvar.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-diff -up ortp-0.16.1/src/stun.c.unusedvar ortp-0.16.1/src/stun.c
---- ortp-0.16.1/src/stun.c.unusedvar 2011-03-15 12:35:33.000000000 +0000
-+++ ortp-0.16.1/src/stun.c 2011-03-15 12:35:33.000000000 +0000
-@@ -1191,7 +1191,7 @@ stunRand(void)
- int maxFd=0;
- struct timeval tv;
- int e;
-- int res;
-+ __attribute__((__unused__)) int res;
-
- int fd=open("/dev/random",O_RDONLY);
-
-@@ -1985,7 +1985,7 @@ stunSendTest( Socket myFd, StunAddress4
-
- bool_t changePort=FALSE;
- bool_t changeIP=FALSE;
-- bool_t discard=FALSE;
-+ __attribute__((__unused__)) bool_t discard=FALSE;
-
- StunMessage req;
- char buf[STUN_MAX_MESSAGE_SIZE];
-@@ -2154,7 +2154,7 @@ stunNatType( StunAddress4 *dest,
-
- bool_t respTestI=FALSE;
- bool_t isNat=TRUE;
-- StunAddress4 testIchangedAddr;
-+ __attribute__((__unused__)) StunAddress4 testIchangedAddr;
- StunAddress4 testImappedAddr;
- bool_t respTestI2=FALSE;
- bool_t mappedIpSame = TRUE;
-diff -up ortp-0.16.1/src/tests/rtprecv.c.unusedvar ortp-0.16.1/src/tests/rtprecv.c
---- ortp-0.16.1/src/tests/rtprecv.c.unusedvar 2011-03-15 12:36:28.000000000 +0000
-+++ ortp-0.16.1/src/tests/rtprecv.c 2011-03-15 12:36:53.000000000 +0000
-@@ -162,7 +162,7 @@ int main(int argc, char*argv[])
- if (err>0) stream_received=1;
- /* this is to avoid to write to disk some silence before the first RTP packet is returned*/
- if ((stream_received) && (err>0)) {
-- size_t ret = fwrite(buffer,1,err,outfile);
-+ __attribute__((__unused__)) size_t ret = fwrite(buffer,1,err,outfile);
- if (sound_fd>0)
- ret = write(sound_fd,buffer,err);
- }