summaryrefslogtreecommitdiffstats
path: root/main/ortp
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-08-10 09:07:35 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-08-10 12:46:49 +0000
commit9ef72de4812339d34f1e4c5b189d813892484ecf (patch)
treea63debd4dafa0dfa83764bf9bdc1e7abd7852167 /main/ortp
parentfcb175a506839b40c111af26ae5f99e9a313338a (diff)
downloadaports-9ef72de4812339d34f1e4c5b189d813892484ecf.tar.bz2
aports-9ef72de4812339d34f1e4c5b189d813892484ecf.tar.xz
main/ortp: moved from testing
Diffstat (limited to 'main/ortp')
-rw-r--r--main/ortp/APKBUILD47
-rw-r--r--main/ortp/ortp-0.16.1-retval.patch20
-rw-r--r--main/ortp/ortp-0.16.1-unusedvar.patch42
3 files changed, 109 insertions, 0 deletions
diff --git a/main/ortp/APKBUILD b/main/ortp/APKBUILD
new file mode 100644
index 000000000..bc419952a
--- /dev/null
+++ b/main/ortp/APKBUILD
@@ -0,0 +1,47 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=ortp
+pkgver=0.16.1
+pkgrel=0
+pkgdesc="A C library implementing the RTP protocol (RFC3550)"
+url="http://www.linphone.org/index.php/code_review/ortp"
+arch="all"
+license="LGPLv2+ VSL"
+depends=""
+makedepends=""
+install=""
+subpackages="$pkgname-dev"
+source="http://nongnu.askapache.com/linphone/ortp/sources/ortp-$pkgver.tar.gz
+ ortp-0.16.1-retval.patch
+ ortp-0.16.1-unusedvar.patch
+ "
+
+_builddir="$srcdir"/ortp-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --disable-static \
+ --enable-ipv6 \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="bc96cdcb9c139d366a720a94200f92dd ortp-0.16.1.tar.gz
+cdd971e04073b3de2e935e6ff502110f ortp-0.16.1-retval.patch
+f3323a01f3d82279c3ce5ed1bb1969c5 ortp-0.16.1-unusedvar.patch"
diff --git a/main/ortp/ortp-0.16.1-retval.patch b/main/ortp/ortp-0.16.1-retval.patch
new file mode 100644
index 000000000..679f8d7d4
--- /dev/null
+++ b/main/ortp/ortp-0.16.1-retval.patch
@@ -0,0 +1,20 @@
+diff -up ortp-0.16.1/src/stun.c.retval ortp-0.16.1/src/stun.c
+--- ortp-0.16.1/src/stun.c.retval 2010-09-04 10:14:53.000000000 +0200
++++ ortp-0.16.1/src/stun.c 2010-09-04 10:15:10.000000000 +0200
+@@ -1191,6 +1191,7 @@ stunRand(void)
+ int maxFd=0;
+ struct timeval tv;
+ int e;
++ int res;
+
+ int fd=open("/dev/random",O_RDONLY);
+
+@@ -1213,7 +1214,7 @@ stunRand(void)
+ closesocket(fd);
+ return random();
+ }
+- read(fd,&tick,sizeof(tick));
++ res = read(fd,&tick,sizeof(tick));
+ closesocket(fd);
+ }
+ #else
diff --git a/main/ortp/ortp-0.16.1-unusedvar.patch b/main/ortp/ortp-0.16.1-unusedvar.patch
new file mode 100644
index 000000000..0e5d18c86
--- /dev/null
+++ b/main/ortp/ortp-0.16.1-unusedvar.patch
@@ -0,0 +1,42 @@
+diff -up ortp-0.16.1/src/stun.c.unusedvar ortp-0.16.1/src/stun.c
+--- ortp-0.16.1/src/stun.c.unusedvar 2011-03-15 12:35:33.000000000 +0000
++++ ortp-0.16.1/src/stun.c 2011-03-15 12:35:33.000000000 +0000
+@@ -1191,7 +1191,7 @@ stunRand(void)
+ int maxFd=0;
+ struct timeval tv;
+ int e;
+- int res;
++ __attribute__((__unused__)) int res;
+
+ int fd=open("/dev/random",O_RDONLY);
+
+@@ -1985,7 +1985,7 @@ stunSendTest( Socket myFd, StunAddress4
+
+ bool_t changePort=FALSE;
+ bool_t changeIP=FALSE;
+- bool_t discard=FALSE;
++ __attribute__((__unused__)) bool_t discard=FALSE;
+
+ StunMessage req;
+ char buf[STUN_MAX_MESSAGE_SIZE];
+@@ -2154,7 +2154,7 @@ stunNatType( StunAddress4 *dest,
+
+ bool_t respTestI=FALSE;
+ bool_t isNat=TRUE;
+- StunAddress4 testIchangedAddr;
++ __attribute__((__unused__)) StunAddress4 testIchangedAddr;
+ StunAddress4 testImappedAddr;
+ bool_t respTestI2=FALSE;
+ bool_t mappedIpSame = TRUE;
+diff -up ortp-0.16.1/src/tests/rtprecv.c.unusedvar ortp-0.16.1/src/tests/rtprecv.c
+--- ortp-0.16.1/src/tests/rtprecv.c.unusedvar 2011-03-15 12:36:28.000000000 +0000
++++ ortp-0.16.1/src/tests/rtprecv.c 2011-03-15 12:36:53.000000000 +0000
+@@ -162,7 +162,7 @@ int main(int argc, char*argv[])
+ if (err>0) stream_received=1;
+ /* this is to avoid to write to disk some silence before the first RTP packet is returned*/
+ if ((stream_received) && (err>0)) {
+- size_t ret = fwrite(buffer,1,err,outfile);
++ __attribute__((__unused__)) size_t ret = fwrite(buffer,1,err,outfile);
+ if (sound_fd>0)
+ ret = write(sound_fd,buffer,err);
+ }