summaryrefslogtreecommitdiffstats
path: root/main/oscam
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2014-08-25 22:55:02 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2014-08-25 22:55:02 +0200
commit4139dc4590012e78eeac7f653a71dcc1fb1d3965 (patch)
tree7fd921d9ebf9ddcc2d3ee3f6a5e5c6b09f2e1eb4 /main/oscam
parenta5c09e2911ffa5e8b2a71dde4b1d09bf5b6761d9 (diff)
downloadaports-4139dc4590012e78eeac7f653a71dcc1fb1d3965.tar.bz2
aports-4139dc4590012e78eeac7f653a71dcc1fb1d3965.tar.xz
main/oscam: create custom dbg sub pkg
Diffstat (limited to 'main/oscam')
-rw-r--r--main/oscam/APKBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/main/oscam/APKBUILD b/main/oscam/APKBUILD
index 63180cdfb..fedc3c979 100644
--- a/main/oscam/APKBUILD
+++ b/main/oscam/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer:
pkgname=oscam
pkgver=0_svn20140825
-pkgrel=0
+pkgrel=1
pkgdesc="An Open Source Conditional Access Module software"
url="http://www.streamboard.tv/oscam/"
arch="all"
@@ -31,8 +31,8 @@ prepare() {
esac
done
# do not strip oscam binary to enable dgb subpkg
- sed -i '/STRIP/d' \
- Makefile || return 1
+ #sed -i '/STRIP/d' \
+ # Makefile || return 1
}
build() {
@@ -87,6 +87,12 @@ list_smargo() {
"$subpkgdir"/usr/bin/list_smargo || return 1
}
+dbg() {
+ mkdir -p "$subpkgdir"/usr/bin
+ mv "$_builddir"/oscam.debug \
+ "$subpkgdir"/usr/bin || return 1
+}
+
md5sums="55a8560dc6feb93bae145257c35e72c9 oscam-0_svn20140825.tar.gz
222cb70633d6c65760054efa064255e1 oscam.initd
3108b2f38140b5791d15cf49dae4ad35 oscam.confd