summaryrefslogtreecommitdiffstats
path: root/main/osmo
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-11-06 14:31:50 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-11-06 14:32:01 +0000
commit65ecb9f25c57dab32e9b332fc2fc6486711ead2b (patch)
tree37bb753a59f0b895857155b0b2cd3316cfa57cba /main/osmo
parent751958d52c181ee88fd249dd6f3f176679e48572 (diff)
downloadaports-65ecb9f25c57dab32e9b332fc2fc6486711ead2b.tar.bz2
aports-65ecb9f25c57dab32e9b332fc2fc6486711ead2b.tar.xz
main/osmo: upgrade to 0.2.12
Diffstat (limited to 'main/osmo')
-rw-r--r--main/osmo/APKBUILD14
-rw-r--r--main/osmo/osmo-0.2.10-libnotify-0.7.patch48
2 files changed, 8 insertions, 54 deletions
diff --git a/main/osmo/APKBUILD b/main/osmo/APKBUILD
index 33a771d66..d2e568d21 100644
--- a/main/osmo/APKBUILD
+++ b/main/osmo/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=osmo
-pkgver=0.2.10
-pkgrel=4
+pkgver=0.2.12
+pkgrel=0
pkgdesc="A handy personal organizer"
url="http://clayo.org/osmo/"
arch="all"
@@ -11,7 +11,6 @@ install=
subpackages="$pkgname-doc $pkgname-lang"
source="http://downloads.sourceforge.net/$pkgname-pim/$pkgname-$pkgver.tar.gz
osmo-0.2.10-build-mo.patch
- osmo-0.2.10-libnotify-0.7.patch
"
_builddir="$srcdir"/$pkgname-$pkgver
@@ -41,6 +40,9 @@ package() {
make -j1 DESTDIR="$pkgdir" install || return 1
}
-md5sums="a774db748228efee96186158d553ade9 osmo-0.2.10.tar.gz
-6c9939fd4df9d25e1a220585e6875c78 osmo-0.2.10-build-mo.patch
-92f7208e2e67482df61d20e6c04747dd osmo-0.2.10-libnotify-0.7.patch"
+md5sums="567fb326603a693667d735942a64895d osmo-0.2.12.tar.gz
+6c9939fd4df9d25e1a220585e6875c78 osmo-0.2.10-build-mo.patch"
+sha256sums="93bda51614f92e4193840451612e792219f7d8c90d78bdc7ea6d6c14a2be6b78 osmo-0.2.12.tar.gz
+ab81ce85449170a0256b6b4ef6bee1a5513772b46ee31571983ee0dc4fa63339 osmo-0.2.10-build-mo.patch"
+sha512sums="3ff70cd04c0626568bfd338ce11c6a2a256565cead519e3d9ca217f167a0e3307eb37e6826e658134e3763e7835f84d5d43d80b9d63677aa855c952830e1b5ba osmo-0.2.12.tar.gz
+c9e49a3177f6135b2cedc00b0bc36ef7421a34941349bcfe242702dcfb5ebf13907d0ae8f8af1e26065b21e53f29e69c1fe36fd6724bfbb86556c3df828c8f23 osmo-0.2.10-build-mo.patch"
diff --git a/main/osmo/osmo-0.2.10-libnotify-0.7.patch b/main/osmo/osmo-0.2.10-libnotify-0.7.patch
deleted file mode 100644
index 72e9f1ab9..000000000
--- a/main/osmo/osmo-0.2.10-libnotify-0.7.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-http://pkgs.fedoraproject.org/gitweb/?p=osmo.git;a=blob_plain;f=osmo-0.2.10-libnotify-0.7.0.patch;hb=HEAD
-
---- ./src/check_events.c
-+++ ./src/check_events.c
-@@ -454,9 +454,9 @@
- a->date = 0;
-
- if (textdesc != NULL)
-- a->notify = notify_notification_new (item->summary, textdesc, GTK_STOCK_DIALOG_WARNING, NULL);
-+ a->notify = notify_notification_new (item->summary, textdesc, GTK_STOCK_DIALOG_WARNING);
- else
-- a->notify = notify_notification_new (item->summary, text, GTK_STOCK_DIALOG_WARNING, NULL);
-+ a->notify = notify_notification_new (item->summary, text, GTK_STOCK_DIALOG_WARNING);
-
- g_free (textdesc);
- g_free (text);
-@@ -483,9 +483,6 @@
- #endif /* HAVE_LIBNOTIFY */
-
- if (gtk_status_icon_get_visible (appGUI->osmo_trayicon)) {
--#ifdef HAVE_LIBNOTIFY
-- notify_notification_attach_to_status_icon (a->notify, appGUI->osmo_trayicon);
--#endif /* HAVE_LIBNOTIFY */
- gtk_status_icon_set_from_stock (appGUI->osmo_trayicon, OSMO_STOCK_SYSTRAY_TASK);
-
- if (config.blink_on_events) {
-@@ -532,9 +529,9 @@
- a->time = -1;
- a->date = 0;
- if (textdesc != NULL)
-- a->notify = notify_notification_new (_("Alarm warning!"), textdesc, GTK_STOCK_DIALOG_INFO, NULL);
-+ a->notify = notify_notification_new (_("Alarm warning!"), textdesc, GTK_STOCK_DIALOG_INFO);
- else
-- a->notify = notify_notification_new (_("Alarm warning!"), text, GTK_STOCK_DIALOG_INFO, NULL);
-+ a->notify = notify_notification_new (_("Alarm warning!"), text, GTK_STOCK_DIALOG_INFO);
-
- notify_notification_set_timeout (a->notify, NOTIFY_EXPIRES_NEVER);
- notify_notification_set_urgency (a->notify, NOTIFY_URGENCY_NORMAL);
-@@ -545,9 +542,6 @@
- #endif /* HAVE_LIBNOTIFY */
-
- if (gtk_status_icon_get_visible (appGUI->osmo_trayicon)) {
--#ifdef HAVE_LIBNOTIFY
-- notify_notification_attach_to_status_icon (a->notify, appGUI->osmo_trayicon);
--#endif /* HAVE_LIBNOTIFY */
- gtk_status_icon_set_from_stock (appGUI->osmo_trayicon, OSMO_STOCK_SYSTRAY_TASK);
-
- if (config.blink_on_events) {