summaryrefslogtreecommitdiffstats
path: root/main/partimage
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-09-18 08:12:19 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-09-18 08:13:34 +0000
commitf5edf3be6fda2e25ce8a47eba346c266351fb30f (patch)
treebfa74b471aed9e1e3a3be301932f663c8a1eec9f /main/partimage
parent2f95d3f2773af24d5a18cf59088a857ef4923f63 (diff)
downloadaports-f5edf3be6fda2e25ce8a47eba346c266351fb30f.tar.bz2
aports-f5edf3be6fda2e25ce8a47eba346c266351fb30f.tar.xz
main/partimage: move from testing
Diffstat (limited to 'main/partimage')
-rw-r--r--main/partimage/APKBUILD54
-rw-r--r--main/partimage/partimage-0.6.9-common.patch10
-rw-r--r--main/partimage/partimage-0.6.9-zlib-1.2.6.patch35
3 files changed, 99 insertions, 0 deletions
diff --git a/main/partimage/APKBUILD b/main/partimage/APKBUILD
new file mode 100644
index 000000000..c6ad86a1f
--- /dev/null
+++ b/main/partimage/APKBUILD
@@ -0,0 +1,54 @@
+# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
+pkgname=partimage
+pkgver=0.6.9
+pkgrel=1
+pkgdesc="Saves partitions having a supported filesystem to an image file"
+url="http://www.partimage.org"
+arch="all"
+license="GPL"
+depends=
+makedepends="bzip2-dev newt-dev zlib-dev gettext-dev slang-dev openssl-dev
+ newt-dev"
+install=
+subpackages="$pkgname-doc"
+source="http://downloads.sourceforge.net/project/$pkgname/stable/$pkgver/$pkgname-$pkgver.tar.bz2
+ partimage-0.6.9-zlib-1.2.6.patch
+ partimage-0.6.9-common.patch
+"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ export LIBS="$LIBS -lintl"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --disable-nls
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="1bc046fd915c5debbafc85729464e513 partimage-0.6.9.tar.bz2
+6139caa49838f71e6b8ac11624252cf7 partimage-0.6.9-zlib-1.2.6.patch
+82e01a132c3d4ca656f3c7e96bf86c72 partimage-0.6.9-common.patch"
+sha256sums="753a6c81f4be18033faed365320dc540fe5e58183eaadcd7a5b69b096fec6635 partimage-0.6.9.tar.bz2
+67bb600b135ab4e9febf2b17ca4666d8bb0a334abc4e548d555a167a32b9615d partimage-0.6.9-zlib-1.2.6.patch
+5beebb0fa26168eecccbd9baf609d5ed207cdf5f420d75218e700be95c9d6760 partimage-0.6.9-common.patch"
+sha512sums="252885921b23933fdcdf0bb6efa4b82066b08ca95cc653296912d384ae875b421c1d39f347a90115315139176d4eab4a930c24919c2d38cf00ed29c764cd14d9 partimage-0.6.9.tar.bz2
+f6feaf6967620ca5512aec50ada13e1b3676976ee2e04cebb3cd64c991ec8be47b337cd99c2656b3a1c77ce4ea25661784a8217f6d8325fd346f1d15463392ce partimage-0.6.9-zlib-1.2.6.patch
+39faba3b75302c0fb04e343b3854549c06447e28040f9c49a83d595533901e3c6af252a18d8db0394cbaabc7c9c1bde014f2d423cab80dadb6ea5322dc19a381 partimage-0.6.9-common.patch"
diff --git a/main/partimage/partimage-0.6.9-common.patch b/main/partimage/partimage-0.6.9-common.patch
new file mode 100644
index 000000000..98d3df893
--- /dev/null
+++ b/main/partimage/partimage-0.6.9-common.patch
@@ -0,0 +1,10 @@
+--- a/src/shared/common.h
++++ b/src/shared/common.h
+@@ -21,6 +21,7 @@
+
+ #include <stdarg.h>
+ #include <pthread.h>
++#include <sys/types.h>
+
+ #include <sys/param.h>
+
diff --git a/main/partimage/partimage-0.6.9-zlib-1.2.6.patch b/main/partimage/partimage-0.6.9-zlib-1.2.6.patch
new file mode 100644
index 000000000..9922daa81
--- /dev/null
+++ b/main/partimage/partimage-0.6.9-zlib-1.2.6.patch
@@ -0,0 +1,35 @@
+diff --git a/src/client/imagefile.cpp b/src/client/imagefile.cpp
+index dd83411..62d0f72 100644
+--- a/src/client/imagefile.cpp
++++ b/src/client/imagefile.cpp
+@@ -783,7 +783,7 @@ void CImage::openWriting()
+ else if (m_options.dwCompression == COMPRESS_GZIP) // Gzip compression
+ {
+ showDebug(1, "open gzip\n");
+- m_gzImageFile = (gzFile *) gzdopen(m_nFdImage, "wb"); //"wb1h");
++ m_gzImageFile = gzdopen(m_nFdImage, "wb"); //"wb1h");
+ if (m_gzImageFile == NULL)
+ {
+ showDebug(1, "error:%d %s\n", errno, strerror(errno));
+@@ -1098,7 +1098,7 @@ void CImage::openReading(CVolumeHeader *vh /* = NULL */)
+ }
+ else if (m_options.dwCompression == COMPRESS_GZIP) // Gzip compression
+ {
+- m_gzImageFile = (gzFile *) gzdopen(m_nFdImage, "rb");
++ m_gzImageFile = gzdopen(m_nFdImage, "rb");
+ if (m_gzImageFile == NULL)
+ THROW(ERR_ERRNO, errno);
+ else
+diff --git a/src/client/imagefile.h b/src/client/imagefile.h
+index 4ba8910..6adb098 100644
+--- a/src/client/imagefile.h
++++ b/src/client/imagefile.h
+@@ -41,7 +41,7 @@ class CImage
+ COptions m_options;
+
+ FILE *m_fImageFile;
+- gzFile *m_gzImageFile;
++ gzFile m_gzImageFile;
+ BZFILE *m_bzImageFile;
+
+ int m_nFdImage;