summaryrefslogtreecommitdiffstats
path: root/main/pax-utils
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-05-15 07:31:52 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-05-15 07:31:52 +0000
commit50c29e7f45e7c905e13b8dca46c20cf61a2f0086 (patch)
tree7262b795533d0221fb9d54fd0aa95ce223df4859 /main/pax-utils
parent18b03d71b39c95eca6a591256695e5b558c03f17 (diff)
downloadaports-50c29e7f45e7c905e13b8dca46c20cf61a2f0086.tar.bz2
aports-50c29e7f45e7c905e13b8dca46c20cf61a2f0086.tar.xz
main/pax-utils: upgrade to 0.8
Diffstat (limited to 'main/pax-utils')
-rw-r--r--main/pax-utils/APKBUILD16
-rw-r--r--main/pax-utils/musl-decl.patch24
2 files changed, 34 insertions, 6 deletions
diff --git a/main/pax-utils/APKBUILD b/main/pax-utils/APKBUILD
index e19d9b9cb..46a1844c0 100644
--- a/main/pax-utils/APKBUILD
+++ b/main/pax-utils/APKBUILD
@@ -1,14 +1,15 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=pax-utils
-pkgver=0.7
-pkgrel=4
+pkgver=0.8
+pkgrel=0
pkgdesc="ELF related utils for ELF 32/64 binaries"
url="http://hardened.gentoo.org/pax-utils.xml"
arch="all"
license='GPL2'
depends="scanelf"
makedepends=
-source="http://dev.gentoo.org/~vapier/dist/pax-utils-$pkgver.tar.xz"
+source="http://dev.gentoo.org/~vapier/dist/pax-utils-$pkgver.tar.xz
+ musl-decl.patch"
subpackages="$pkgname-doc scanelf:_scanelf"
_builddir="$srcdir"/pax-utils-$pkgver
@@ -39,6 +40,9 @@ _scanelf() {
mv "$pkgdir"/usr/bin/scanelf "$subpkgdir"/usr/bin/
}
-md5sums="8ae7743ad11500f7604f2e817221d877 pax-utils-0.7.tar.xz"
-sha256sums="1ac4cee9a9ca97a723505eb29a25e50adeccffba3f0f0ef4f035cf082caf3b84 pax-utils-0.7.tar.xz"
-sha512sums="d99f325b1d3ffc4955bc09aedcbeabea2d87a9647da31db1518de9daa55fbe0e5dd09feedd8dbcd8c4b53825a788ae7c9b904a927abc9ae995385dfd00d44f4a pax-utils-0.7.tar.xz"
+md5sums="8ad6dd304919948e4b305f743c69de8f pax-utils-0.8.tar.xz
+1056671d887efe6b7b6882fe1aff2052 musl-decl.patch"
+sha256sums="cb6f00654c5278a0a9a28cf32cbdbae9914f20226adcb98f1ce6df4a872b20b6 pax-utils-0.8.tar.xz
+63ba759021a3a40ab978ef007d6517123286c48061127c15d1c1557b41ff49c4 musl-decl.patch"
+sha512sums="a2cdd9ec3e9b16601bbee5d08a271bad9e9b6e993074c92465184e06f3e033470ac98085ee43ecd3202ebbc5d81710873074d40b7d949977e168bd8c956512bb pax-utils-0.8.tar.xz
+0ceac13c8d8a897408841c7cfc762670fe3ebc6732b7a0cdabb46afc6beec117a33abccddbaf3cc62ddef0355167baf41ecb6331aa907751b7a60cc177306f1c musl-decl.patch"
diff --git a/main/pax-utils/musl-decl.patch b/main/pax-utils/musl-decl.patch
new file mode 100644
index 000000000..cbb23ada6
--- /dev/null
+++ b/main/pax-utils/musl-decl.patch
@@ -0,0 +1,24 @@
+--- ./elf.h.orig
++++ ./elf.h
+@@ -21,7 +21,9 @@
+
+ #include <features.h>
+
+-__BEGIN_DECLS
++#ifdef __cplusplus
++extern "C" {
++#endif
+
+ /* Standard ELF types. */
+
+@@ -3374,7 +3376,8 @@
+
+ #define R_TILEGX_NUM 130
+
+-
+-__END_DECLS
++#ifdef __cplusplus
++}
++#endif
+
+ #endif /* elf.h */