summaryrefslogtreecommitdiffstats
path: root/main/perl-rt-authen-externalauth
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2013-12-26 09:07:46 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2013-12-26 09:07:46 +0000
commit8392f5d75bd9861f039d5ae6773c226d540b773f (patch)
tree11aa8de386ea918d21b3672678f307710945f1f1 /main/perl-rt-authen-externalauth
parent2dd523d6c18ffc6db86c29ebd7bea7b13ee4b74b (diff)
downloadaports-8392f5d75bd9861f039d5ae6773c226d540b773f.tar.bz2
aports-8392f5d75bd9861f039d5ae6773c226d540b773f.tar.xz
testing/perl-rt-authen-externalauth: move to main
Diffstat (limited to 'main/perl-rt-authen-externalauth')
-rw-r--r--main/perl-rt-authen-externalauth/APKBUILD57
-rw-r--r--main/perl-rt-authen-externalauth/dont-install-in-local-perl-rt-authen-externalauth.patch19
-rw-r--r--main/perl-rt-authen-externalauth/use-DESTDIR-perl-rt-authen-externalauth.patch21
3 files changed, 97 insertions, 0 deletions
diff --git a/main/perl-rt-authen-externalauth/APKBUILD b/main/perl-rt-authen-externalauth/APKBUILD
new file mode 100644
index 000000000..1bf4ccd12
--- /dev/null
+++ b/main/perl-rt-authen-externalauth/APKBUILD
@@ -0,0 +1,57 @@
+# Automatically generated by apkbuild-cpan, template 1
+# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
+pkgname=perl-rt-authen-externalauth
+_realname=RT-Authen-ExternalAuth
+pkgver=0.17
+pkgrel=1
+pkgdesc="RT Authentication using External Sources"
+url="http://search.cpan.org/~tsibley"
+arch="noarch"
+license="GPL PerlArtistic"
+cpandepends=""
+cpanmakedepends=" "
+depends="$cpandepends rt4 perl-dbi perl-ldap perl-net-ssleay"
+makedepends="perl-dev $cpanmakedepends"
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/T/TS/TSIBLEY/${_realname}-${pkgver}.tar.gz
+ use-DESTDIR-perl-rt-authen-externalauth.patch
+ dont-install-in-local-perl-rt-authen-externalauth.patch
+ "
+
+_builddir="$srcdir/$_realname-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ patch -p1 < ../use-DESTDIR-perl-rt-authen-externalauth.patch || return 1
+ patch -p1 < ../dont-install-in-local-perl-rt-authen-externalauth.patch || return 1
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor DESTDIR="$pkgdir" \
+ RTHOME="/usr/lib/rt4" PREFIX="/usr/lib/rt4"
+}
+
+build() {
+ cd "$_builddir"
+ export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ make DESTDIR="$pkgdir" RTHOME="/usr/lib/rt4" PREFIX="/usr/lib/rt4"
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" RTHOME="/usr/lib/rt4" PREFIX="/usr/lib/rt4" install || return 1
+ mkdir -p "$pkgdir"/etc/rt4/plugins
+ mv "$pkgdir"/usr/lib/rt4/plugins/RT-Authen-ExternalAuth/etc \
+ "$pkgdir"/etc/rt4/plugins/RT-Authen-ExternalAuth || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+ # leftover empty dirs
+ rm -rf "$pkgdir"/home
+}
+
+md5sums="f1d17f4c83d7ec2615db2e42f7b82d19 RT-Authen-ExternalAuth-0.17.tar.gz
+6e2fa78c896de4f10b3f4a3030dd8659 use-DESTDIR-perl-rt-authen-externalauth.patch
+b1c1136f726af56af275021b9ce8b12e dont-install-in-local-perl-rt-authen-externalauth.patch"
+sha256sums="cd12c0c223c4cd4588feb5de76eb234ab62c6cbc865f3f82249f0023c21f5aca RT-Authen-ExternalAuth-0.17.tar.gz
+6b254295f06fca929ebe96fdcd08d8f1c9fbae0ffaf9e1a9cd83ce57572f5bdc use-DESTDIR-perl-rt-authen-externalauth.patch
+2944a8139356ae9877020389e98cdb12db9e0e0239a88848d9d3cea8a1695c5c dont-install-in-local-perl-rt-authen-externalauth.patch"
+sha512sums="5110f21c46887049f0a43772cbc3d22bd24b29140a5753572dd3e29a75597bd3aaebb32dc73fb82482d98e321a1473cc2b8929b8d921702ef52adf08cb3ec85f RT-Authen-ExternalAuth-0.17.tar.gz
+880d36550d7272595407b032c5d08da32a949255c1cb772df5c19150b75be599023d5d263fbbc679531751ec878d2dfe6023c4e271738d11446a21cdb1434eed use-DESTDIR-perl-rt-authen-externalauth.patch
+8ddc26ff26ed190b4c2801dc7514e41cdedffe485d083de49d787cf71ce1adf6d8e3fdb68df8c64396e977c4acebe853c982bb0735ab38f451de98d22424b65a dont-install-in-local-perl-rt-authen-externalauth.patch"
diff --git a/main/perl-rt-authen-externalauth/dont-install-in-local-perl-rt-authen-externalauth.patch b/main/perl-rt-authen-externalauth/dont-install-in-local-perl-rt-authen-externalauth.patch
new file mode 100644
index 000000000..ccd2a52f1
--- /dev/null
+++ b/main/perl-rt-authen-externalauth/dont-install-in-local-perl-rt-authen-externalauth.patch
@@ -0,0 +1,19 @@
+Author: Tom Jampen <tom@cryptography.ch>
+Description: Fix plugin path to use debian's request-tracker plugin directory.
+
+diff -Naurp a/inc/Module/Install/RTx.pm b/inc/Module/Install/RTx.pm
+--- a/inc/Module/Install/RTx.pm 2012-05-10 16:22:06.166168825 +0200
++++ b/inc/Module/Install/RTx.pm 2012-06-11 12:51:31.879609814 +0200
+@@ -38,8 +38,9 @@ sub RTx {
+ @ARGV = grep { /PREFIX=(.*)/ ? ( ( $prefix = $1 ), 0 ) : 1 } @ARGV;
+
+ if ($prefix) {
+- $RT::LocalPath = $prefix;
+- $INC{'RT.pm'} = "$RT::LocalPath/lib/RT.pm";
++ push @INC, "$prefix";
++ require RT;
++ $RT::LocalPluginPath = "$prefix/plugins";
+ } else {
+ local @INC = (
+ $ENV{RTHOME} ? ( $ENV{RTHOME}, "$ENV{RTHOME}/lib" ) : (),
+
diff --git a/main/perl-rt-authen-externalauth/use-DESTDIR-perl-rt-authen-externalauth.patch b/main/perl-rt-authen-externalauth/use-DESTDIR-perl-rt-authen-externalauth.patch
new file mode 100644
index 000000000..88a90876d
--- /dev/null
+++ b/main/perl-rt-authen-externalauth/use-DESTDIR-perl-rt-authen-externalauth.patch
@@ -0,0 +1,21 @@
+diff --git a/inc/Module/Install/RTx.pm b/inc/Module/Install/RTx.pm
+index 20a354b..7e681c6 100755
+--- a/inc/Module/Install/RTx.pm
++++ b/inc/Module/Install/RTx.pm
+@@ -83,13 +83,13 @@ sub RTx {
+ if ( $RT::LocalPluginPath ) {
+ die "Because of bugs in RT 3.8.0 this extension can not be installed.\n"
+ ."Upgrade to RT 3.8.1 or newer.\n" if $RT::VERSION =~ /^3\.8\.0/;
+- $path{$_} = $RT::LocalPluginPath . "/$original_name/$_"
++ $path{$_} = '$(DESTDIR)' . $RT::LocalPluginPath . "/$original_name/$_"
+ foreach @DIRS;
+ } else {
+ foreach ( @DIRS ) {
+ no strict 'refs';
+ my $varname = "RT::Local" . ucfirst($_) . "Path";
+- $path{$_} = ${$varname} || "$RT::LocalPath/$_";
++ $path{$_} = '$(DESTDIR)' . (${$varname} || "$RT::LocalPath/$_");
+ }
+
+ $path{$_} .= "/$name" for grep $path{$_}, qw(etc po var);
+