summaryrefslogtreecommitdiffstats
path: root/main/perl-rt-authen-externalauth
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2015-04-17 06:25:17 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2015-04-17 06:26:25 +0000
commit9192f068fd2013b45bc78757170ea118c1c3e384 (patch)
tree8b2d0f59239dc9de16775e635d10529630e61be6 /main/perl-rt-authen-externalauth
parentcbc78a0b27ac07aa78b7810513a89e3dfe7d48d4 (diff)
downloadaports-9192f068fd2013b45bc78757170ea118c1c3e384.tar.bz2
aports-9192f068fd2013b45bc78757170ea118c1c3e384.tar.xz
main/perl-rt-authen-externalauth: upgrade to 0.25
Diffstat (limited to 'main/perl-rt-authen-externalauth')
-rw-r--r--main/perl-rt-authen-externalauth/01-fix-plugindir.patch24
-rw-r--r--main/perl-rt-authen-externalauth/APKBUILD59
-rw-r--r--main/perl-rt-authen-externalauth/dont-install-in-local-perl-rt-authen-externalauth.patch19
-rw-r--r--main/perl-rt-authen-externalauth/use-DESTDIR-perl-rt-authen-externalauth.patch21
4 files changed, 63 insertions, 60 deletions
diff --git a/main/perl-rt-authen-externalauth/01-fix-plugindir.patch b/main/perl-rt-authen-externalauth/01-fix-plugindir.patch
new file mode 100644
index 000000000..ea4fa485b
--- /dev/null
+++ b/main/perl-rt-authen-externalauth/01-fix-plugindir.patch
@@ -0,0 +1,24 @@
+Author: Tom Jampen <tom@cryptography.ch>
+Description:
+ Using the PREFIX environment variable defined in rules to find debian's request
+ tracker installation and fixing the plugin path to install to DESTDIR.
+
+diff -Naurp a/inc/Module/Install/RTx.pm b/inc/Module/Install/RTx.pm
+--- a/inc/Module/Install/RTx.pm 2014-10-15 08:41:45.631919231 +0200
++++ b/inc/Module/Install/RTx.pm 2014-10-15 08:41:04.130328032 +0200
+@@ -42,12 +42,14 @@ sub RTx {
+ $ENV{RTHOME} =~ s{/RT\.pm$}{} if defined $ENV{RTHOME};
+ $ENV{RTHOME} =~ s{/lib/?$}{} if defined $ENV{RTHOME};
+ my @try = $ENV{RTHOME} ? ($ENV{RTHOME}, "$ENV{RTHOME}/lib") : ();
++ my $prefix = $ENV{PREFIX};
++ push @INC, "$prefix/lib";
+ while (1) {
+ my @look = @INC;
+ unshift @look, grep {defined and -d $_} @try;
+ push @look, grep {defined and -d $_}
+ map { ( "$_/rt4/lib", "$_/lib/rt4", "$_/lib" ) } @prefixes;
+- last if eval {local @INC = @look; require RT; $RT::LocalLibPath};
++ last if eval {local @INC = @look; require RT; $RT::LocalPluginPath = '$(DESTDIR)'."$prefix/plugins"; $RT::LocalLibPath};
+
+ warn
+ "Cannot find the location of RT.pm that defines \$RT::LocalPath in: @look\n";
diff --git a/main/perl-rt-authen-externalauth/APKBUILD b/main/perl-rt-authen-externalauth/APKBUILD
index edfc1197c..60b911519 100644
--- a/main/perl-rt-authen-externalauth/APKBUILD
+++ b/main/perl-rt-authen-externalauth/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
pkgname=perl-rt-authen-externalauth
_realname=RT-Authen-ExternalAuth
-pkgver=0.20
+pkgver=0.25
pkgrel=0
pkgdesc="RT Authentication using External Sources"
url="http://search.cpan.org/~tsibley"
@@ -14,44 +14,63 @@ depends="$cpandepends rt4 perl-dbi perl-ldap perl-net-ssleay"
makedepends="perl-dev $cpanmakedepends"
subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/F/FA/FALCONE/${_realname}-${pkgver}.tar.gz
- use-DESTDIR-perl-rt-authen-externalauth.patch
- dont-install-in-local-perl-rt-authen-externalauth.patch
+ 01-fix-plugindir.patch
"
_builddir="$srcdir/$_realname-$pkgver"
prepare() {
cd "$_builddir"
- patch -p1 < ../use-DESTDIR-perl-rt-authen-externalauth.patch || return 1
- patch -p1 < ../dont-install-in-local-perl-rt-authen-externalauth.patch || return 1
+ for i in $source; do
+ case $i in
+ *.patch)
+ msg "Applying $i"
+ patch -p1 -i "$srcdir"/$i || return 1
+ ;;
+ esac
+ done
+
export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor DESTDIR="$pkgdir" \
- RTHOME="/usr/lib/rt4" PREFIX="/usr/lib/rt4"
+ export PREFIX="/usr/lib/rt4" \
+ INSTALLDIRS=vendor \
+ DESTDIR="$pkgdir" \
+ RTHOME="/usr/lib/rt4"
+
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL \
+ INSTALLDIRS=vendor \
+ DESTDIR="$pkgdir" \
+ RTHOME="/usr/lib/rt4" \
+ PREFIX="/usr/lib/rt4" \
+ INSTALLSITEARCH="/usr/share/man" \
+ INSTALLVENDORMAN1DIR="/usr/share/man/man1" \
+ INSTALLVENDORMAN3DIR="/usr/share/man/man3" \
+ INSTALLVENDORLIB="/usr/share/perl5/vendor_perl"
+
}
build() {
cd "$_builddir"
export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
- make DESTDIR="$pkgdir" RTHOME="/usr/lib/rt4" PREFIX="/usr/lib/rt4"
+ make DESTDIR="$pkgdir" \
+ RTHOME="/usr/lib/rt4" \
+ PREFIX="/usr/lib/rt4"
}
package() {
cd "$_builddir"
- make DESTDIR="$pkgdir" RTHOME="/usr/lib/rt4" PREFIX="/usr/lib/rt4" install || return 1
+ make DESTDIR="$pkgdir" \
+ RTHOME="/usr/lib/rt4" \
+ PREFIX="/usr/lib/rt4" \
+ install || return 1
mkdir -p "$pkgdir"/etc/rt4/plugins
- mv "$pkgdir"/usr/lib/rt4/plugins/RT-Authen-ExternalAuth/etc \
- "$pkgdir"/etc/rt4/plugins/RT-Authen-ExternalAuth || return 1
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
# leftover empty dirs
rm -rf "$pkgdir"/home
}
-md5sums="8721e3d18ec75bf44dd496cc7e7a8d9f RT-Authen-ExternalAuth-0.20.tar.gz
-6e2fa78c896de4f10b3f4a3030dd8659 use-DESTDIR-perl-rt-authen-externalauth.patch
-b1c1136f726af56af275021b9ce8b12e dont-install-in-local-perl-rt-authen-externalauth.patch"
-sha256sums="bd1dc1297cd1b13ada72501c93932add636e84a58eab0d76fc430c874e58c1ee RT-Authen-ExternalAuth-0.20.tar.gz
-6b254295f06fca929ebe96fdcd08d8f1c9fbae0ffaf9e1a9cd83ce57572f5bdc use-DESTDIR-perl-rt-authen-externalauth.patch
-2944a8139356ae9877020389e98cdb12db9e0e0239a88848d9d3cea8a1695c5c dont-install-in-local-perl-rt-authen-externalauth.patch"
-sha512sums="296ed55cd761560a211b1001ee7603b3769f2fb7d0139d4138794d6fcb761463edd97d285ab5ada703a57eab5e833d57e10ac7dd5daa2f2e565f02cc7607a5d7 RT-Authen-ExternalAuth-0.20.tar.gz
-880d36550d7272595407b032c5d08da32a949255c1cb772df5c19150b75be599023d5d263fbbc679531751ec878d2dfe6023c4e271738d11446a21cdb1434eed use-DESTDIR-perl-rt-authen-externalauth.patch
-8ddc26ff26ed190b4c2801dc7514e41cdedffe485d083de49d787cf71ce1adf6d8e3fdb68df8c64396e977c4acebe853c982bb0735ab38f451de98d22424b65a dont-install-in-local-perl-rt-authen-externalauth.patch"
+md5sums="18563039f685cddb30259b8869682cac RT-Authen-ExternalAuth-0.25.tar.gz
+bb86eb8fa789153221b020ab8ccb6ac4 01-fix-plugindir.patch"
+sha256sums="ac22f33429af4b53c2a487a3fded19becc79ad538ca35753ec5fa3de27f5911c RT-Authen-ExternalAuth-0.25.tar.gz
+e77b19ce51ab2ac1028d2d616d2dccaaefdf2fe0c4c83bd166b06887be1b93b5 01-fix-plugindir.patch"
+sha512sums="82306cb4c483bace0e209eecd9b033fd97e57dcd424a4fd56cefb5e7fa7592078078a896c2e0e604547188f198876a03c72be80afcdf058bdcd351ea55687d26 RT-Authen-ExternalAuth-0.25.tar.gz
+39411a0e0e3a8cc3de2386192e015bcc1044f529e814b5540df405e1b88b4a1569199d84afacaa78467c9d01b44060c02691777c0e9f013a527b0cd5782620ac 01-fix-plugindir.patch"
diff --git a/main/perl-rt-authen-externalauth/dont-install-in-local-perl-rt-authen-externalauth.patch b/main/perl-rt-authen-externalauth/dont-install-in-local-perl-rt-authen-externalauth.patch
deleted file mode 100644
index ccd2a52f1..000000000
--- a/main/perl-rt-authen-externalauth/dont-install-in-local-perl-rt-authen-externalauth.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-Author: Tom Jampen <tom@cryptography.ch>
-Description: Fix plugin path to use debian's request-tracker plugin directory.
-
-diff -Naurp a/inc/Module/Install/RTx.pm b/inc/Module/Install/RTx.pm
---- a/inc/Module/Install/RTx.pm 2012-05-10 16:22:06.166168825 +0200
-+++ b/inc/Module/Install/RTx.pm 2012-06-11 12:51:31.879609814 +0200
-@@ -38,8 +38,9 @@ sub RTx {
- @ARGV = grep { /PREFIX=(.*)/ ? ( ( $prefix = $1 ), 0 ) : 1 } @ARGV;
-
- if ($prefix) {
-- $RT::LocalPath = $prefix;
-- $INC{'RT.pm'} = "$RT::LocalPath/lib/RT.pm";
-+ push @INC, "$prefix";
-+ require RT;
-+ $RT::LocalPluginPath = "$prefix/plugins";
- } else {
- local @INC = (
- $ENV{RTHOME} ? ( $ENV{RTHOME}, "$ENV{RTHOME}/lib" ) : (),
-
diff --git a/main/perl-rt-authen-externalauth/use-DESTDIR-perl-rt-authen-externalauth.patch b/main/perl-rt-authen-externalauth/use-DESTDIR-perl-rt-authen-externalauth.patch
deleted file mode 100644
index 88a90876d..000000000
--- a/main/perl-rt-authen-externalauth/use-DESTDIR-perl-rt-authen-externalauth.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-diff --git a/inc/Module/Install/RTx.pm b/inc/Module/Install/RTx.pm
-index 20a354b..7e681c6 100755
---- a/inc/Module/Install/RTx.pm
-+++ b/inc/Module/Install/RTx.pm
-@@ -83,13 +83,13 @@ sub RTx {
- if ( $RT::LocalPluginPath ) {
- die "Because of bugs in RT 3.8.0 this extension can not be installed.\n"
- ."Upgrade to RT 3.8.1 or newer.\n" if $RT::VERSION =~ /^3\.8\.0/;
-- $path{$_} = $RT::LocalPluginPath . "/$original_name/$_"
-+ $path{$_} = '$(DESTDIR)' . $RT::LocalPluginPath . "/$original_name/$_"
- foreach @DIRS;
- } else {
- foreach ( @DIRS ) {
- no strict 'refs';
- my $varname = "RT::Local" . ucfirst($_) . "Path";
-- $path{$_} = ${$varname} || "$RT::LocalPath/$_";
-+ $path{$_} = '$(DESTDIR)' . (${$varname} || "$RT::LocalPath/$_");
- }
-
- $path{$_} .= "/$name" for grep $path{$_}, qw(etc po var);
-