summaryrefslogtreecommitdiffstats
path: root/main/pgcluster
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-09-29 08:45:29 +0000
committerTimo Teräs <timo.teras@iki.fi>2013-09-29 08:47:22 +0000
commit8f6f2e3166478b14b208ecfb94ddf01d69dd7bdc (patch)
treee1bdd0bbb491926306c1e43e72dabbbe235f4b62 /main/pgcluster
parent832a032dd3794c5cc3e67f4ee580e171996e8e29 (diff)
downloadaports-8f6f2e3166478b14b208ecfb94ddf01d69dd7bdc.tar.bz2
aports-8f6f2e3166478b14b208ecfb94ddf01d69dd7bdc.tar.xz
main/[various]: update config.sub (and remove charset.alias)
for musl build. the changes are automatically done based on previous build log errors, so this does not guarantee successful build, but is a required.
Diffstat (limited to 'main/pgcluster')
-rw-r--r--main/pgcluster/APKBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/main/pgcluster/APKBUILD b/main/pgcluster/APKBUILD
index f3fdf8be7..e68949d67 100644
--- a/main/pgcluster/APKBUILD
+++ b/main/pgcluster/APKBUILD
@@ -17,8 +17,15 @@ source="http://pgfoundry.org/frs/download.php/1705/$pkgname-$_myver.tar.gz
[ "$ALPINE_LIBC" = "eglibc" ] && arch=
+_builddir="$srcdir/$pkgname-$_myver"
+
+prepare() {
+ cd "$_builddir"
+ update_config_sub || return 1
+}
+
build() {
- cd "$srcdir"/$pkgname-$_myver || return 1
+ cd "$_builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -32,7 +39,7 @@ build() {
}
package() {
- cd "$srcdir"/$pkgname-$_myver || return 1
+ cd "$_builddir"
make DESTDIR="$pkgdir" install || return 1
install -D -m755 "$srcdir"/$pkgname.initd \