summaryrefslogtreecommitdiffstats
path: root/main/pllua
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-10-22 09:17:10 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-10-22 09:19:45 +0000
commit7829504193e18f04795cfb983bba4b994ca6971a (patch)
tree7a076949064776d38bd2669a7bc95c3d8d08aba8 /main/pllua
parent7a62b3143c0e4e4e3471f66c698e3bd48ca73e7b (diff)
downloadaports-7829504193e18f04795cfb983bba4b994ca6971a.tar.bz2
aports-7829504193e18f04795cfb983bba4b994ca6971a.tar.xz
main/pllua: upgrade to 1.0
Diffstat (limited to 'main/pllua')
-rw-r--r--main/pllua/9.3-headers.patch14
-rw-r--r--main/pllua/9.3-int2.patch13
-rw-r--r--main/pllua/9.3-notice-create-index.patch22
-rw-r--r--main/pllua/APKBUILD26
-rw-r--r--main/pllua/pllua-include.patch10
5 files changed, 68 insertions, 17 deletions
diff --git a/main/pllua/9.3-headers.patch b/main/pllua/9.3-headers.patch
new file mode 100644
index 000000000..859f2949c
--- /dev/null
+++ b/main/pllua/9.3-headers.patch
@@ -0,0 +1,14 @@
+diff --git a/pllua.h b/pllua.h
+index 888307b..b6e7419 100644
+--- a/pllua.h
++++ b/pllua.h
+@@ -11,6 +11,9 @@
+ #include <fmgr.h>
+ #include <funcapi.h>
+ #include <access/heapam.h>
++#if PG_VERSION_NUM >= 90300
++#include <access/htup_details.h>
++#endif
+ #include <catalog/namespace.h>
+ #include <catalog/pg_proc.h>
+ #include <catalog/pg_type.h>
diff --git a/main/pllua/9.3-int2.patch b/main/pllua/9.3-int2.patch
new file mode 100644
index 000000000..46b9782db
--- /dev/null
+++ b/main/pllua/9.3-int2.patch
@@ -0,0 +1,13 @@
+diff --git a/plluaapi.c b/plluaapi.c
+index f24cd0c..3e3513d 100644
+--- a/plluaapi.c
++++ b/plluaapi.c
+@@ -38,7 +38,7 @@ typedef struct luaP_Info {
+ /* extended type info */
+ typedef struct luaP_Typeinfo {
+ int oid;
+- int2 len;
++ int16 len;
+ char type;
+ char align;
+ bool byval;
diff --git a/main/pllua/9.3-notice-create-index.patch b/main/pllua/9.3-notice-create-index.patch
new file mode 100644
index 000000000..d30b62437
--- /dev/null
+++ b/main/pllua/9.3-notice-create-index.patch
@@ -0,0 +1,22 @@
+--- a/expected/plluatest.out
++++ b/expected/plluatest.out
+@@ -232,8 +232,8 @@
+ 1 | name | data
+ (1 row)
+
++SET client_min_messages = warning;
+ CREATE TABLE tree (id INT PRIMARY KEY, lchild INT, rchild INT);
+-NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index "tree_pkey" for table "tree"
+ CREATE FUNCTION filltree (t text, n int) RETURNS void AS $$
+ local p = server.prepare("insert into " .. t .. " values($1, $2, $3)",
+ {"int4", "int4", "int4"})
+--- a/sql/plluatest.sql
++++ b/sql/plluatest.sql
+@@ -160,6 +160,7 @@
+ SELECT * FROM get_rows('name');
+
+
++SET client_min_messages = warning;
+ CREATE TABLE tree (id INT PRIMARY KEY, lchild INT, rchild INT);
+
+ CREATE FUNCTION filltree (t text, n int) RETURNS void AS $$
diff --git a/main/pllua/APKBUILD b/main/pllua/APKBUILD
index ca0d1cd1b..86ec24845 100644
--- a/main/pllua/APKBUILD
+++ b/main/pllua/APKBUILD
@@ -1,19 +1,21 @@
# Contributor: Michael Mason <ms13sp@gmail.com>
# Maintainer: Michael Mason <ms13sp@gmail.com>
pkgname=pllua
-pkgver=0.3.2
+pkgver=1.0
pkgrel=0
pkgdesc="Procedural language for PostgreSQL using Lua"
-url="http://pgfoundry.org/projects/pllua"
+url="http://pllua.projects.pgfoundry.org/"
arch="all"
license="GPL"
depends="postgresql"
makedepends="postgresql-dev lua-dev"
install=
subpackages=""
-source="
- http://pgfoundry.org/frs/download.php/2401/pllua-$pkgver.tar.gz
- pllua-include.patch"
+source="http://pgfoundry.org/frs/download.php/3481/pllua-$pkgver.tar.gz
+ 9.3-headers.patch
+ 9.3-int2.patch
+ 9.3-notice-create-index.patch
+ "
_builddir="$srcdir"/pllua-$pkgver
prepare() {
@@ -35,5 +37,15 @@ package() {
make DESTDIR="$pkgdir" install
}
-md5sums="e91cbbaa0bbaca9bd4478255a98a264e pllua-0.3.2.tar.gz
-a0b6b84f0fb7776c70ed1052ae4f2c8e pllua-include.patch"
+md5sums="371aaf62fab5f5c954dd4270ec0dfa13 pllua-1.0.tar.gz
+175600e15def447ad421254e96bcf2e7 9.3-headers.patch
+33c1c28c9e2be890be0a85233ea6143f 9.3-int2.patch
+9fea64072610ebdef462cacd5763b9b6 9.3-notice-create-index.patch"
+sha256sums="a2a4f8172563485255d729f3e053a47b408b118105b0e77bcd5eef8b951ef429 pllua-1.0.tar.gz
+96189a72437ed604c068f4b508563af8e702c086838af5327b4b1c65606a1f73 9.3-headers.patch
+9276bcb75bf3978e46eca159dbbbf83ac6db2f502ecbf34863497f5059027e8f 9.3-int2.patch
+cd4ff054b629ad65fbedd3b333544722d07769fba56498d094671f5b1fe17cc9 9.3-notice-create-index.patch"
+sha512sums="99f007a39d5b7ac7f0c8bcdda1cb053b8a26b1d3f87006d8db61f73afeac29e0a9b054d398170a529cfc090e7083bb84098815fb67f2f6964b16297a47f5441b pllua-1.0.tar.gz
+de17345d216475d8524aa3ac58d4e66830326d8954529d6eb5c923d3038032af8975bfb66e34598e87bf6c27d49d341aed4b955e6a4f5054fc9699a9e7941308 9.3-headers.patch
+2066122be748ca0f99f6d8b62343412ead65329134f14040249dcc1389d01fa63e4bfbfff082a5ee1efff9e50d56a10b55629b961aa0b0e54a5ea6df0ccdc6e7 9.3-int2.patch
+fbeb59dbcb7667dc9b2ca7b513625db32bc51d5a40f5fc4ab081a633982a6433716c65dc2845c7647556c0eee660f32bfb3656c32dfd783e23cfcc97337f8eda 9.3-notice-create-index.patch"
diff --git a/main/pllua/pllua-include.patch b/main/pllua/pllua-include.patch
deleted file mode 100644
index 886efc9e5..000000000
--- a/main/pllua/pllua-include.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- ./pllua.h.orig Tue Oct 9 17:32:18 2012
-+++ ./pllua.h Tue Oct 9 17:32:27 2012
-@@ -25,6 +25,7 @@
- #include <utils/datum.h>
- #include <utils/builtins.h>
- #include <utils/array.h>
-+#include <utils/rel.h>
- /* Lua */
- #include <lua.h>
- #include <lualib.h>