summaryrefslogtreecommitdiffstats
path: root/main/postfix
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-10-14 06:26:55 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-10-14 06:26:55 +0000
commit1f4cc3c6082aec393b1f7019fedc582d366f57c1 (patch)
tree86b7e00f360746804327877c0d9144141f9e7db0 /main/postfix
parent11796ca36e2bab9a5e42c8b4bfd91a1e83719f1c (diff)
downloadaports-1f4cc3c6082aec393b1f7019fedc582d366f57c1.tar.bz2
aports-1f4cc3c6082aec393b1f7019fedc582d366f57c1.tar.xz
main/postfix: fix file descriptor passing
we need check if __GLIBC__ is defined at all before comparing verision ref #3423
Diffstat (limited to 'main/postfix')
-rw-r--r--main/postfix/APKBUILD7
-rw-r--r--main/postfix/no-glibc.patch18
2 files changed, 24 insertions, 1 deletions
diff --git a/main/postfix/APKBUILD b/main/postfix/APKBUILD
index c9e1961f2..c90ffdb09 100644
--- a/main/postfix/APKBUILD
+++ b/main/postfix/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=postfix
pkgver=2.11.1
-pkgrel=0
+pkgrel=1
pkgdesc="Secure and fast drop-in replacement for Sendmail (MTA)"
url="http://www.postfix.org/"
arch="all"
@@ -12,9 +12,11 @@ makedepends="db-dev pcre-dev openssl-dev postgresql-dev mysql-dev openldap-dev
install="$pkgname.pre-install"
subpackages="$pkgname-doc $pkgname-ldap $pkgname-mysql $pkgname-pcre
$pkgname-pgsql $pkgname-sqlite"
+options="suid"
source="ftp://ftp.porcupine.org/mirrors/$pkgname-release/official/$pkgname-$pkgver.tar.gz
$pkgname.initd
dynamic-maps.patch
+ no-glibc.patch
dynamicmaps.cf
postfix-ldap.post-install
postfix-mysql.post-install
@@ -162,6 +164,7 @@ sqlite() { _mv_dict sqlite ; }
md5sums="56ac1f1a79737c4ac1e24535a122a4a6 postfix-2.11.1.tar.gz
d773f01dcc965d219a8a37b88f89c5bf postfix.initd
c03239969df760e2a74c4e048ce514a1 dynamic-maps.patch
+cd39f4c05a6462c121a3ab3612d6a5bd no-glibc.patch
442efd1a95b0c061dfb8ab75456e0f24 dynamicmaps.cf
2ebe51a882eb9d6d7866583eb6af3969 postfix-ldap.post-install
2ebe51a882eb9d6d7866583eb6af3969 postfix-mysql.post-install
@@ -171,6 +174,7 @@ fd16ec00b60269c4ede4a0a0a514cefa postfix-pcre.post-install
sha256sums="487f98a73b95a5799409caf21ec065efea91c1dcdfb84c038a0e3a265d6489e2 postfix-2.11.1.tar.gz
6b3fe71542ab783c7adddbfa161f7e2dcb2325913ad5d611ca56f730876ce4ab postfix.initd
cfa5000955f1941082567a9e50764f52851f33c468f534c0431f6932d73e8ffb dynamic-maps.patch
+ad2d6b6889ea2e8b1eab05c87f153a1a2ce82e3a877e1235b595a990266dfc04 no-glibc.patch
2041ff6cd71fe16f3d75603ff40d90a08a8b97f0883e1de1d58563ab1521b5ea dynamicmaps.cf
fbd75ef31a5d78d5f82b67e08e5bf5ada380afa58a69ef4a07d756c47b3bb498 postfix-ldap.post-install
fbd75ef31a5d78d5f82b67e08e5bf5ada380afa58a69ef4a07d756c47b3bb498 postfix-mysql.post-install
@@ -180,6 +184,7 @@ fbd75ef31a5d78d5f82b67e08e5bf5ada380afa58a69ef4a07d756c47b3bb498 postfix-sqlite
sha512sums="988659ed7f256fdc831c6a211c33aede922d5baf32da7129afe0ec2fe5011ac95dacb21e59c92f658323b6ea773ebf2bcd66a796d9271c1e7b949d5d9b9ee977 postfix-2.11.1.tar.gz
c179534a7243bcf8c19b5367a703b54fcc88b7587ce7ef07ec111cfe00053779eed23b3ccda81eb20059599b857cae0a57cc02613526209f3dd966d65abd9a3f postfix.initd
1a92089410691d400953472be522c872be1456521203560a4feadb632cb85cfacaf3721108d62111873fb23478976b8a949077734cf801374ca58bcaf363922c dynamic-maps.patch
+4d2624ee98f798f8818789433b05cce4ee337750e93ee49c4074bc0c741c678d426c42bd09088596d5010f0bc680ec3b5aed630acfd3d5513512f6a6af15b61c no-glibc.patch
49b8205166f575e5fb9bdaaaaa042dc1be9b556331bf659a55b1115c9fa48486896941f18ca9fb633dd54675079f29a9d69d53c214170731c2127862456ec90b dynamicmaps.cf
b35931865eb15b5cd6a2b95bbf486cd064d1447eac1a91d507a7d23155229ac7e7fdf6b8518e663c5c7072b201786c72aead0d95e94d8708a9b5a7c3f37be138 postfix-ldap.post-install
b35931865eb15b5cd6a2b95bbf486cd064d1447eac1a91d507a7d23155229ac7e7fdf6b8518e663c5c7072b201786c72aead0d95e94d8708a9b5a7c3f37be138 postfix-mysql.post-install
diff --git a/main/postfix/no-glibc.patch b/main/postfix/no-glibc.patch
new file mode 100644
index 000000000..2e5e83330
--- /dev/null
+++ b/main/postfix/no-glibc.patch
@@ -0,0 +1,18 @@
+Check if we have __GLIBC__ defined at all before checking version
+http://bugs.alpinelinux.org/issues/3423
+
+This fixes the following when compiled with musl libc:
+warning: unix_send_fd: your system has no support for file descriptor passing
+
+
+--- ./src/util/sys_defs.h.orig
++++ ./src/util/sys_defs.h
+@@ -810,7 +810,7 @@
+ # define KERNEL_VERSION(a,b,c) (LINUX_VERSION_CODE + 1)
+ #endif
+ #if (LINUX_VERSION_CODE < KERNEL_VERSION(2,2,0)) \
+- || (__GLIBC__ < 2)
++ || (defined(__GLIBC__) && (__GLIBC__ < 2))
+ # define CANT_USE_SEND_RECV_MSG
+ # define DEF_SMTP_CACHE_DEMAND 0
+ #else