summaryrefslogtreecommitdiffstats
path: root/main/powertop
diff options
context:
space:
mode:
authorEivind Uggedal <eivind@uggedal.com>2014-06-19 10:10:57 +0000
committerEivind Uggedal <eivind@uggedal.com>2014-06-19 10:11:02 +0000
commit5c686395698d3ef20197149249b173fa8a94af66 (patch)
tree733eef049da0d91e2d7aadad8f1c244f7a2e777d /main/powertop
parentd1b8e8d443f5f7dca3725c227aca4c63ef1f4d8d (diff)
downloadaports-5c686395698d3ef20197149249b173fa8a94af66.tar.bz2
aports-5c686395698d3ef20197149249b173fa8a94af66.tar.xz
main/powertop: moved from testing and claim maintainership
Diffstat (limited to 'main/powertop')
-rw-r--r--main/powertop/APKBUILD48
-rw-r--r--main/powertop/libintl-underlink.patch13
-rw-r--r--main/powertop/stdio.patch12
3 files changed, 73 insertions, 0 deletions
diff --git a/main/powertop/APKBUILD b/main/powertop/APKBUILD
new file mode 100644
index 000000000..78e1dba4c
--- /dev/null
+++ b/main/powertop/APKBUILD
@@ -0,0 +1,48 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Eivind Uggedal <eivind@uggedal.com>
+pkgname=powertop
+pkgver=2.6.1
+pkgrel=0
+pkgdesc="Power consumption monitor"
+url="https://01.org/powertop"
+arch="all"
+license="GPLv2"
+depends=
+makedepends="ncurses-dev pciutils-dev zlib-dev libnl-dev gettext-dev"
+install=""
+subpackages="$pkgname-lang"
+source="https://01.org/sites/default/files/downloads/$pkgname/$pkgname-$pkgver.tar.gz
+ stdio.patch
+ libintl-underlink.patch"
+
+_builddir="$srcdir"/powertop-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="4391e7b0af854ecf722cdf712f24b631 powertop-2.6.1.tar.gz
+2cc285ac3868d1d6d2a373ce5875bdf0 stdio.patch
+8eb198cbf778b65d03ac66d0907d5fee libintl-underlink.patch"
+sha256sums="034cde6d5bb433fe0d29251d5cde5d4c2948abf05fe29ef10966b659331b20e4 powertop-2.6.1.tar.gz
+1d76eef4c19fb2ad48bdfc1097be7118c45b7c48ca2cef2ebc6d18c36beb50b1 stdio.patch
+04b7a013607baa349d91e52c734c2b69033ff27cc2b1c35984649015da463ae1 libintl-underlink.patch"
+sha512sums="f21018c2899c3a7f9eb764441667ac11ae10319dbc6fe2c4c3f892eeb637a1ec22fd50f5ba17aa88aa49f224ad534edfc6d28f5ec410d03d0a2c7d7cc5e86527 powertop-2.6.1.tar.gz
+fe795996e9629735bf5c96222b7c431f9a43d57ad44d4d21b13321c423e7362ecf4fba0b41bb9945c58a0cc5a6a7ecdce4d1e5c7c557d577e7710ba8501d23b1 stdio.patch
+9aeabff0454fb15da023d1ac4eac8dd360870e88e6ef6d1359450e765a66582df5760b12c11187be67855054b3b14590a9a919ae26d6cc28a520edc2a3a9ea92 libintl-underlink.patch"
diff --git a/main/powertop/libintl-underlink.patch b/main/powertop/libintl-underlink.patch
new file mode 100644
index 000000000..e330e0982
--- /dev/null
+++ b/main/powertop/libintl-underlink.patch
@@ -0,0 +1,13 @@
+diff --git a/src/Makefile.in b/src/Makefile.in
+index bdfadb1cc909..8d3ce3b6278b 100644
+--- a/src/Makefile.in
++++ b/src/Makefile.in
+@@ -347,7 +347,7 @@ powertop_SOURCES = parameters/persistent.cpp parameters/learn.cpp parameters/par
+ powertop_CXXFLAGS = -fno-omit-frame-pointer -fstack-protector -Wall -Wshadow -Wformat $(NCURSES_CFLAGS) $(PCIUTILS_CFLAGS) $(LIBNL_CFLAGS) $(GLIB2_CFLAGS)
+ powertop_CPPFLAGS = -D_FORTIFY_SOURCE=2 $(NCURSES_CFLAGS) $(PCIUTILS_CFLAGS) $(LIBNL_CFLAGS) $(GLIB2_CFLAGS) $(LIBZ_CFLAGS) -DLOCALEDIR=\"$(localedir)\"
+ powertop_LDADD = ../traceevent/libtraceevnet.la
+-AM_LDFLAGS = $(LIBS) $(NCURSES_LIBS) $(PCIUTILS_LIBS) $(LIBNL_LIBS) $(LIBZ_LIBS) $(PTHREAD_LIBS) $(RESOLV_LIBS)
++AM_LDFLAGS = $(LIBS) $(NCURSES_LIBS) $(PCIUTILS_LIBS) $(LIBNL_LIBS) $(LIBZ_LIBS) $(PTHREAD_LIBS) $(RESOLV_LIBS) $(LTLIBINTL)
+ BUILT_SOURCES = css.h
+ CLEANFILES = css.h
+ all: $(BUILT_SOURCES)
diff --git a/main/powertop/stdio.patch b/main/powertop/stdio.patch
new file mode 100644
index 000000000..5e413f359
--- /dev/null
+++ b/main/powertop/stdio.patch
@@ -0,0 +1,12 @@
+diff --git a/src/perf/perf.h b/src/perf/perf.h
+index ee072ae06d24..932588a684f9 100644
+--- a/src/perf/perf.h
++++ b/src/perf/perf.h
+@@ -26,6 +26,7 @@
+ #define _INCLUDE_GUARD_PERF_H_
+
+ #include <iostream>
++#include <stdio.h>
+
+
+ extern "C" {