summaryrefslogtreecommitdiffstats
path: root/main/ppp
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2011-03-29 20:37:35 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2011-03-29 20:37:35 +0000
commit31493f7ab008d85d639a8aad7b5f684e158ba7d2 (patch)
treea7cf72fe302e3c87821f2eb76ab47c8fd7630ae4 /main/ppp
parent67c9f0ff227b2ac6e2a939714dda6b8f810d28e9 (diff)
downloadaports-31493f7ab008d85d639a8aad7b5f684e158ba7d2.tar.bz2
aports-31493f7ab008d85d639a8aad7b5f684e158ba7d2.tar.xz
main/ppp: ipv6 fix
Diffstat (limited to 'main/ppp')
-rw-r--r--main/ppp/APKBUILD13
1 files changed, 11 insertions, 2 deletions
diff --git a/main/ppp/APKBUILD b/main/ppp/APKBUILD
index f13950f54..c3907106c 100644
--- a/main/ppp/APKBUILD
+++ b/main/ppp/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=ppp
pkgver=2.4.5
-pkgrel=5
+pkgrel=6
pkgdesc="A daemon which implements the PPP protocol for dial-up networking"
url="http://www.samba.org/ppp/"
arch="all"
@@ -22,13 +22,22 @@ _builddir="$srcdir"/$pkgname-$pkgver
build () {
cd "$_builddir"
+ # fix CFLAGS
+ # -D_GNU_SOURCE is needed for IPv6 to work apparently
+ export CFLAGS="$CFLAGS -D_GNU_SOURCE"
+ sed -i "s:-O2 -pipe -Wall -g:${CFLAGS}:" pppd/Makefile.linux
+ sed -i "s:-g -O2:${CFLAGS}:" pppd/plugins/Makefile.linux
+ sed -i "s:-O2:${CFLAGS}:" pppstats/Makefile.linux
+ sed -i "s:-O2 -g -pipe:${CFLAGS}:" chat/Makefile.linux
+ sed -i "s:-O:${CFLAGS}:" pppdump/Makefile.linux
# enable active filter
sed -i "s:^#FILTER=y:FILTER=y:" pppd/Makefile.linux
# enable ipv6 support
sed -i "s:^#HAVE_INET6=y:HAVE_INET6=y:" pppd/Makefile.linux
# Enable Microsoft proprietary Callback Control Protocol
sed -i "s:^#CBCP=y:CBCP=y:" pppd/Makefile.linux
-
+ # Fix build error with recent kernels
+ rm include/linux/if_pppol2tp.h
./configure --prefix=/usr
make COPTS="$CFLAGS" || return 1
}