summaryrefslogtreecommitdiffstats
path: root/main/presentproto
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-02-03 14:05:52 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-02-03 14:05:52 +0000
commit95b2edfbb1ae750afd594346bc67fc7022fd1ae1 (patch)
treeca85c5ca3cb2a345675b585804eae063440a5f4d /main/presentproto
parent894ae45be6e0fa6856160b3d1b559f1801a1bfd8 (diff)
downloadaports-95b2edfbb1ae750afd594346bc67fc7022fd1ae1.tar.bz2
aports-95b2edfbb1ae750afd594346bc67fc7022fd1ae1.tar.xz
main/presentproto: new aport
needed for xorg-server 1.15
Diffstat (limited to 'main/presentproto')
-rw-r--r--main/presentproto/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/main/presentproto/APKBUILD b/main/presentproto/APKBUILD
new file mode 100644
index 000000000..4ff8ca755
--- /dev/null
+++ b/main/presentproto/APKBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=presentproto
+pkgver=1.0
+pkgrel=0
+pkgdesc="Present protocol specification and Xlib/Xserver headers"
+url="http://xorg.freedesktop.org/"
+arch="noarch"
+license="custom"
+depends=""
+makedepends=""
+source="http://xorg.freedesktop.org/releases/individual/proto/$pkgname-$pkgver.tar.bz2"
+
+_builddir="$srcdir/$pkgname-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+md5sums="2d569c75884455c7148d133d341e8fd6 presentproto-1.0.tar.bz2"
+sha256sums="812c7d48721f909a0f7a2cb1e91f6eead76159a36c4712f4579ca587552839ce presentproto-1.0.tar.bz2"
+sha512sums="6d6b3cb78ff7c6ad8103d0003479f94702aea412640feec5d82cb630c9560fd0e1f7b6124e9eaba138adc9bf61ee08ef193537c2754c9b79737ef871c5114c59 presentproto-1.0.tar.bz2"