summaryrefslogtreecommitdiffstats
path: root/main/python
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2015-04-09 10:34:28 +0000
committerTimo Teräs <timo.teras@iki.fi>2015-04-09 10:34:28 +0000
commit40de2d730ca027d42d4e93561fbad80fb8823c2b (patch)
treebe203120c23019cbf71a8e078347de616b31ced2 /main/python
parent96398ac58d99a047a9a6c3f87c8929cdc0bfecdd (diff)
downloadaports-40de2d730ca027d42d4e93561fbad80fb8823c2b.tar.bz2
aports-40de2d730ca027d42d4e93561fbad80fb8823c2b.tar.xz
main/python: paxmark the real binary, not the symlink
Diffstat (limited to 'main/python')
-rw-r--r--main/python/APKBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/main/python/APKBUILD b/main/python/APKBUILD
index 907ce9863..e651c7f7d 100644
--- a/main/python/APKBUILD
+++ b/main/python/APKBUILD
@@ -2,7 +2,7 @@
pkgname=python
pkgver=2.7.9
_verbase=${pkgver%.*}
-pkgrel=1
+pkgrel=2
pkgdesc="A high-level scripting language"
url="http://www.python.org"
arch="all"
@@ -63,7 +63,7 @@ package() {
rm "$pkgdir/usr/bin/2to3" || return 1
# we need to enable emutramp - needed for virt-manager
# disable mprotect - needed for cffi
- paxmark -zxm "$pkgdir"/usr/bin/python
+ paxmark -zxm "$pkgdir"/usr/bin/python$_verbase || return 1
}
_mv_files() {