summaryrefslogtreecommitdiffstats
path: root/main/qt5-qtwebkit
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-01-28 10:13:16 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-01-29 11:07:31 +0000
commit497400cee97d09b09ff123bb06ac9ad0a4ce6de2 (patch)
tree841f3a96d28385616bbf92ac17fe09cec106d9ae /main/qt5-qtwebkit
parentfe28c596f5dabb3fed83a025a8cad5c73e1d3088 (diff)
downloadaports-497400cee97d09b09ff123bb06ac9ad0a4ce6de2.tar.bz2
aports-497400cee97d09b09ff123bb06ac9ad0a4ce6de2.tar.xz
main/qt5-qtwebkit: upgrade to 5.4.0
Diffstat (limited to 'main/qt5-qtwebkit')
-rw-r--r--main/qt5-qtwebkit/APKBUILD16
-rw-r--r--main/qt5-qtwebkit/fix-rpath.patch6
2 files changed, 11 insertions, 11 deletions
diff --git a/main/qt5-qtwebkit/APKBUILD b/main/qt5-qtwebkit/APKBUILD
index c21a36ba8..1abd8ee97 100644
--- a/main/qt5-qtwebkit/APKBUILD
+++ b/main/qt5-qtwebkit/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=qt5-qtwebkit
-pkgver=5.3.2
-pkgrel=1
+pkgver=5.4.0
+pkgrel=0
pkgdesc="Qt5 - QtWebKit components"
url="http://qt-project.org/"
arch="all"
@@ -73,15 +73,15 @@ package() {
sed -i -e 's:-L/home[^ ]\+::g' "$pkgdir"/usr/lib/pkgconfig/*.pc
}
-md5sums="0497b5b46540848e0db6a9e219d756fb qtwebkit-opensource-src-5.3.2.tar.xz
+md5sums="e62d72c410dffe5129043f80f624c896 qtwebkit-opensource-src-5.4.0.tar.xz
676350288efff119bee8513d9d0b2047 pic.patch
-0eb12ab99ceaea7f841d58193f5e6cce fix-rpath.patch
+722c871b648adae302413159b12ada6b fix-rpath.patch
7a2a2592e64561fa0bc8c0552181bf00 fix-execinfo.patch"
-sha256sums="e47122ed15e8e1cc32e11b3cd89bacc056437215134a204899f2fddb4fd92e5b qtwebkit-opensource-src-5.3.2.tar.xz
+sha256sums="6c672207765d5d2e88aa14b72b3876ad7bce453397a02e1a3d6e4670a8d188c1 qtwebkit-opensource-src-5.4.0.tar.xz
51c0e843c5c6453526ee51ed69f2d4a7959767621da321f1082985dfe9f001ef pic.patch
-15eb66062e11fef891285b0a288bab9a1b03cd6984f701a7ad890fe6933c1d23 fix-rpath.patch
+b3e52d54fae9588d908289b53dda6042b59ab133cd8c301f4de23c0ee8dc2c01 fix-rpath.patch
d8f6c84cf1a98174aa16660a422cd7b248a012e60bf37a9b5013f2bc61b6d63e fix-execinfo.patch"
-sha512sums="f04e18b550fe0feb1451361339f0a71cd95f65f6a1989b157ed79291e20fb42490f176fc30932ccf4326865ae6f01688b6ad5af7ac6a434d25add5f6557d175c qtwebkit-opensource-src-5.3.2.tar.xz
+sha512sums="1152f0074741156f298bc62f13174ed9c13eb953083d75918d1974f5c264fe62cc7e2fb4c3116210e0ead7249ab8a3f7dcf330a957e8097ff85cddc5c76c84ea qtwebkit-opensource-src-5.4.0.tar.xz
9a62a5e7af91c44311b517608262f88b5bc607e75dc5878dd08b0a0872ec03fb7a566df0a41413f7e60beb1b9880e24f084b90c38ed50d4219ec2ad6af9bd62f pic.patch
-28646d969c15f4ec7cec6bd483f9ead0c71becf42fb8e8261d0c209cb1b6973083515ea1c3fcf9ccaf80a22b81bab0401c4f7b4f29c1631b4433b3bf4aff0507 fix-rpath.patch
+00d59c0cdb58ae8e7cf6bc3d03f133697e74c267ccebe12238bcdc274d4c90210b82c2d8bdf0e949cd43da13a4fd8a4c35fb54a00ed5102a4ac4d23aa002d0fe fix-rpath.patch
f17c2f4b90090c8f12e4ba1f2cbd7a9f496c8de024ba6e0d55b98e5b89ab89298aff84f39e81905e0491fe6bd11544633a8b191403a866e16ed654d44cf8dc6f fix-execinfo.patch"
diff --git a/main/qt5-qtwebkit/fix-rpath.patch b/main/qt5-qtwebkit/fix-rpath.patch
index d365b8775..6b08fd1a3 100644
--- a/main/qt5-qtwebkit/fix-rpath.patch
+++ b/main/qt5-qtwebkit/fix-rpath.patch
@@ -1,11 +1,11 @@
--- ./Tools/qmake/mkspecs/features/unix/default_post.prf.orig
+++ ./Tools/qmake/mkspecs/features/unix/default_post.prf
-@@ -58,8 +58,6 @@
- QMAKE_OBJECTIVE_CFLAGS += -Wno-c++11-extensions -Wno-c++0x-extensions
+@@ -59,8 +59,6 @@
+ }
}
-contains(TEMPLATE, app): CONFIG += rpath
-
- CONFIG(debug, debug|release)|force_debug_info|separate_debug_info {
+ CONFIG(debug, debug|release)|force_debug_info {
# Make ld not cache the symbol tables of input files in memory to avoid memory exhaustion during the linking phase.
!force_static_libs_as_shared:config_gnuld: QMAKE_LFLAGS += -Wl,--no-keep-memory