summaryrefslogtreecommitdiffstats
path: root/main/qt5-qtwebkit
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-09-09 08:06:46 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-09-09 08:15:08 +0000
commit967af83a41c09a348aad6f00fc455129462b5cad (patch)
tree9ed85cb4c7156406c65f33806d20d648e84c51bc /main/qt5-qtwebkit
parent7dbda83b9c37a3554800c222ad674437b609966d (diff)
downloadaports-967af83a41c09a348aad6f00fc455129462b5cad.tar.bz2
aports-967af83a41c09a348aad6f00fc455129462b5cad.tar.xz
main/qt5-*: moved from testing
Diffstat (limited to 'main/qt5-qtwebkit')
-rw-r--r--main/qt5-qtwebkit/APKBUILD87
-rw-r--r--main/qt5-qtwebkit/fix-execinfo.patch20
-rw-r--r--main/qt5-qtwebkit/fix-rpath.patch11
-rw-r--r--main/qt5-qtwebkit/pic.patch11
4 files changed, 129 insertions, 0 deletions
diff --git a/main/qt5-qtwebkit/APKBUILD b/main/qt5-qtwebkit/APKBUILD
new file mode 100644
index 000000000..3aefbec7e
--- /dev/null
+++ b/main/qt5-qtwebkit/APKBUILD
@@ -0,0 +1,87 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=qt5-qtwebkit
+pkgver=5.3.1
+pkgrel=0
+pkgdesc="Qt5 - QtWebKit components"
+url="http://qt-project.org/"
+arch="all"
+license="LGPLv2 with exceptions or GPLv3 with exceptions"
+depends=""
+depends_dev="qt5-qtbase-dev qt5-qtdeclarative-dev gstreamer1-dev
+ gst-plugins-base1-dev libxslt-dev mesa-dev icu-dev libxext-dev
+ glib-dev libxcomposite-dev libxrender-dev
+ "
+makedepends="$depends_dev
+ bison
+ flex
+ fontconfig-dev
+ gperf
+ libjpeg-turbo-dev
+ libpng-dev
+ libwebp-dev
+ pcre-dev
+ ruby
+ sqlite-dev
+ zlib-dev
+ "
+install=""
+subpackages="$pkgname-dev"
+
+_ver=${pkgver/_/-}
+_ver=${_ver/beta0/beta}
+_ver=${_ver/rc0/rc}
+_V=${_ver/rc/RC}
+case $pkgver in
+*_beta*|*_rc*) _rel=development_releases;;
+*) _rel=official_releases;;
+esac
+
+source="http://download.qt-project.org/$_rel/qt/${pkgver%.*}/$_ver/submodules/qtwebkit-opensource-src-$_V.tar.xz
+ pic.patch
+ fix-rpath.patch
+ fix-execinfo.patch
+ "
+
+_builddir="$srcdir"/qtwebkit-opensource-src-$_V
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+ # remove some bundled
+ mkdir Source/ThirdParty/orig
+ mv Source/ThirdParty/gtest/ \
+ Source/ThirdParty/qunit/ \
+ Source/ThirdParty/orig/ \
+ || return 1
+}
+
+build() {
+ cd "$_builddir"
+ qmake && make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make install INSTALL_ROOT="$pkgdir" || return 1
+ rm "$pkgdir"/usr/lib/*.la || return 1
+ # remove rpath
+# chrpath --delete "$pkgdir"/usr/lib/qt5/libexec/* || return 1
+ sed -i -e 's:-L/home[^ ]\+::g' "$pkgdir"/usr/lib/pkgconfig/*.pc
+}
+
+md5sums="0f2bb8af6be2306b2b4d194a7ebf6fcc qtwebkit-opensource-src-5.3.1.tar.xz
+676350288efff119bee8513d9d0b2047 pic.patch
+0eb12ab99ceaea7f841d58193f5e6cce fix-rpath.patch
+7a2a2592e64561fa0bc8c0552181bf00 fix-execinfo.patch"
+sha256sums="69a47c5645918fc27bff630275685f300e42b4dfd99ccd3e5aa1c8a6d0725156 qtwebkit-opensource-src-5.3.1.tar.xz
+51c0e843c5c6453526ee51ed69f2d4a7959767621da321f1082985dfe9f001ef pic.patch
+15eb66062e11fef891285b0a288bab9a1b03cd6984f701a7ad890fe6933c1d23 fix-rpath.patch
+d8f6c84cf1a98174aa16660a422cd7b248a012e60bf37a9b5013f2bc61b6d63e fix-execinfo.patch"
+sha512sums="06ba1b63a6d4c835c1c334d0592c46ec8808603419fb4884b9ab5c6856bc18096759d13d0af8e69bc6c183a3100bdec575fdd97dd55e7437fa1865607fa45bfc qtwebkit-opensource-src-5.3.1.tar.xz
+9a62a5e7af91c44311b517608262f88b5bc607e75dc5878dd08b0a0872ec03fb7a566df0a41413f7e60beb1b9880e24f084b90c38ed50d4219ec2ad6af9bd62f pic.patch
+28646d969c15f4ec7cec6bd483f9ead0c71becf42fb8e8261d0c209cb1b6973083515ea1c3fcf9ccaf80a22b81bab0401c4f7b4f29c1631b4433b3bf4aff0507 fix-rpath.patch
+f17c2f4b90090c8f12e4ba1f2cbd7a9f496c8de024ba6e0d55b98e5b89ab89298aff84f39e81905e0491fe6bd11544633a8b191403a866e16ed654d44cf8dc6f fix-execinfo.patch"
diff --git a/main/qt5-qtwebkit/fix-execinfo.patch b/main/qt5-qtwebkit/fix-execinfo.patch
new file mode 100644
index 000000000..6fbf4ed8f
--- /dev/null
+++ b/main/qt5-qtwebkit/fix-execinfo.patch
@@ -0,0 +1,20 @@
+--- webkitgtk-2.2.0.orig/Source/WTF/wtf/Assertions.cpp
++++ webkitgtk-2.2.0/Source/WTF/wtf/Assertions.cpp
+@@ -64,7 +64,7 @@
+ #include <windows.h>
+ #endif
+
+-#if (OS(DARWIN) || (OS(LINUX) && !defined(__UCLIBC__))) && !OS(ANDROID)
++#if OS(DARWIN) || (OS(LINUX) && defined(__GLIBC__) && !defined(__UCLIBC__)) && !OS(ANDROID)
+ #include <cxxabi.h>
+ #include <dlfcn.h>
+ #include <execinfo.h>
+@@ -242,7 +242,7 @@
+
+ void WTFGetBacktrace(void** stack, int* size)
+ {
+-#if (OS(DARWIN) || (OS(LINUX) && !defined(__UCLIBC__))) && !OS(ANDROID)
++#if OS(DARWIN) || (OS(LINUX) && defined(__GLIBC__) && !defined(__UCLIBC__)) && !OS(ANDROID)
+ *size = backtrace(stack, *size);
+ #elif OS(WINDOWS) && !OS(WINCE)
+ // The CaptureStackBackTrace function is available in XP, but it is not defined
diff --git a/main/qt5-qtwebkit/fix-rpath.patch b/main/qt5-qtwebkit/fix-rpath.patch
new file mode 100644
index 000000000..d365b8775
--- /dev/null
+++ b/main/qt5-qtwebkit/fix-rpath.patch
@@ -0,0 +1,11 @@
+--- ./Tools/qmake/mkspecs/features/unix/default_post.prf.orig
++++ ./Tools/qmake/mkspecs/features/unix/default_post.prf
+@@ -58,8 +58,6 @@
+ QMAKE_OBJECTIVE_CFLAGS += -Wno-c++11-extensions -Wno-c++0x-extensions
+ }
+
+-contains(TEMPLATE, app): CONFIG += rpath
+-
+ CONFIG(debug, debug|release)|force_debug_info|separate_debug_info {
+ # Make ld not cache the symbol tables of input files in memory to avoid memory exhaustion during the linking phase.
+ !force_static_libs_as_shared:config_gnuld: QMAKE_LFLAGS += -Wl,--no-keep-memory
diff --git a/main/qt5-qtwebkit/pic.patch b/main/qt5-qtwebkit/pic.patch
new file mode 100644
index 000000000..ef8993ee3
--- /dev/null
+++ b/main/qt5-qtwebkit/pic.patch
@@ -0,0 +1,11 @@
+--- ./Source/WTF/wtf/InlineASM.h.orig 2013-10-07 11:36:58.995128674 +0000
++++ ./Source/WTF/wtf/InlineASM.h 2013-10-07 11:37:28.058792290 +0000
+@@ -42,7 +42,7 @@
+ #define THUMB_FUNC_PARAM(name)
+ #endif
+
+-#if (OS(LINUX) || OS(FREEBSD)) && CPU(X86_64)
++#if (OS(LINUX) || OS(FREEBSD)) && (CPU(X86_64) || defined(__PIC__))
+ #define GLOBAL_REFERENCE(name) #name "@plt"
+ #elif CPU(X86) && COMPILER(MINGW)
+ #define GLOBAL_REFERENCE(name) "@" #name "@4"