summaryrefslogtreecommitdiffstats
path: root/main/quagga
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-12-18 12:10:52 +0000
committerTimo Teräs <timo.teras@iki.fi>2013-12-18 12:11:55 +0000
commit24d925f4f79662b36f951da7fff391b43de674cf (patch)
tree72749df8db950cb66e50d470a24c06816c891c12 /main/quagga
parent4e222b34c6b359284ac9729bdd8ab7ca0632ae20 (diff)
downloadaports-24d925f4f79662b36f951da7fff391b43de674cf.tar.bz2
aports-24d925f4f79662b36f951da7fff391b43de674cf.tar.xz
main/quagga: use proc for ipforward, and fix musl build
musl does not have ipctl #define's and recent linux kernels have deprecated sysctl use. so migrate over to proc variant. fix also musl build.
Diffstat (limited to 'main/quagga')
-rw-r--r--main/quagga/APKBUILD13
-rw-r--r--main/quagga/musl-fix-headers.patch32
-rw-r--r--main/quagga/quagga-0.99.16-ipctl_forwarding.patch19
3 files changed, 39 insertions, 25 deletions
diff --git a/main/quagga/APKBUILD b/main/quagga/APKBUILD
index b585f5de6..64b42a9c8 100644
--- a/main/quagga/APKBUILD
+++ b/main/quagga/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=quagga
pkgver=0.99.22.4
-pkgrel=1
+pkgrel=2
pkgdesc="A free routing daemon replacing Zebra supporting RIP, OSPF and BGP."
url="http://quagga.net/"
arch="all"
@@ -13,7 +13,7 @@ subpackages="$pkgname-dev $pkgname-doc"
pkgusers="quagga"
pkggroups="quagga"
source="http://download.savannah.gnu.org/releases/quagga/quagga-$pkgver.tar.xz
- quagga-0.99.16-ipctl_forwarding.patch
+ musl-fix-headers.patch
bgpd.initd
ospf6d.initd
ospfd.initd
@@ -26,7 +26,7 @@ source="http://download.savannah.gnu.org/releases/quagga/quagga-$pkgver.tar.xz
_builddir="$srcdir"/$pkgname-$pkgver
prepare() {
cd "$_builddir"
- for i in i$source; do
+ for i in $source; do
case $i in
*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
esac
@@ -35,6 +35,7 @@ prepare() {
build() {
cd "$_builddir"
+ quagga_cv_ipforward_method=proc \
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -71,7 +72,7 @@ package() {
install -o quagga -g quagga -d -m755 "$pkgdir"/etc/quagga
}
md5sums="03ef24a448be47beba80efa2152f8a28 quagga-0.99.22.4.tar.xz
-2328ad4066584654cfc73f66d39dc267 quagga-0.99.16-ipctl_forwarding.patch
+27812f0aaaf8507c4338371aca1bd08d musl-fix-headers.patch
ec7ac8cc1103f023cf5b9482b26ece59 bgpd.initd
92aba039c049050c48abf984c2db7e2b ospf6d.initd
878328ead225e6eb5f5f77f05ab39106 ospfd.initd
@@ -80,7 +81,7 @@ cda4115283d9f4a8304fec1b6881a7eb ripngd.initd
172e5b0e3f169e2b3328123e73517084 zebra.initd
34e06a1d2bc602ce691abc9ed169dd15 zebra.confd"
sha256sums="5e12056692e2dbc272a929f96d0e98d9873f4e7f7ffcca62434b58f6660a6386 quagga-0.99.22.4.tar.xz
-f06053e2a9030be80992bb7d4b18f4cfecd2d43cb09458557b6b8c1ac3fd22ca quagga-0.99.16-ipctl_forwarding.patch
+19068f58f034891c07b8a1324d0645e0f078e3dc98d1360d51c677cecaae8c9e musl-fix-headers.patch
962afa79a0bcb781acc4c367ed55ccea2fbb927cf1271bc1fefaffcbb2f9389a bgpd.initd
f1017e7681692d99eab6f9842313be18104612055bcdab14dd7ac4ac1be38f53 ospf6d.initd
fed815e6530551f314297704e5491f5d2eeb16e930dcff6f12edc88a78b6023a ospfd.initd
@@ -89,7 +90,7 @@ fed815e6530551f314297704e5491f5d2eeb16e930dcff6f12edc88a78b6023a ospfd.initd
ca7c252cc1c79f05a55f933317d9a7f523dc6501bf5c72c553c43da4f8fd68dd zebra.initd
f7a52d383f60270a5a8fee5d4ac522c5c0ec2b7c4b5252cff54e260f32d9b323 zebra.confd"
sha512sums="bcf429e71073e4fc71efc364a21a6c8b70871a17c66bd1328bc57b57962c2c15182436183b2e363c9c1c0e85d84c49d304d4049d40129272f52d6140db330b8a quagga-0.99.22.4.tar.xz
-1f4c45765bc1a8678ad1404bfab65799d9329e8f78a897b5c9c294d167745dd10d25304ba490988d9e94ae815c2c6f107b13efb3c710c44515470a61e2dd7c84 quagga-0.99.16-ipctl_forwarding.patch
+28a1695bd77991790df3b1b5a2c8ced929e6413e9acb87c4a8286569d05b20e65cba466e118fc16a11c264ba11dd1581e4143031ce3bbb478177e900ea68cb07 musl-fix-headers.patch
a865d9f5d2593270abc56dc65785317115337da00e8f389df3bf9af314052a4dc9e8f7af1142f7726637e06f1d8f7640cafd2a9e5ee8a7b4fd6b4e7b7c5bc784 bgpd.initd
f76aaacb1949a528a71a4bb69e9b6fa522c507000e8fa0cd60e0d80b8d2820155fa40fe7dedd86bdf38dc8029b1958c90bfbc8423afc737aae59248adba906b3 ospf6d.initd
fa3edb10d5b543c3f53a4dbd82edcda011be01f2d94b7b208cc02c1137a33adb703b734e7a4f22a51ec4d66203c44918dc9441be02b67248858b413146c61c16 ospfd.initd
diff --git a/main/quagga/musl-fix-headers.patch b/main/quagga/musl-fix-headers.patch
new file mode 100644
index 000000000..12e96ece3
--- /dev/null
+++ b/main/quagga/musl-fix-headers.patch
@@ -0,0 +1,32 @@
+--- quagga-0.99.22.4.orig/lib/queue.h
++++ quagga-0.99.22.4/lib/queue.h
+@@ -33,8 +33,6 @@
+ #ifndef _SYS_QUEUE_H_
+ #define _SYS_QUEUE_H_
+
+-#include <sys/cdefs.h>
+-
+ /*
+ * This file defines four types of data structures: singly-linked lists,
+ * singly-linked tail queues, lists and tail queues.
+--- quagga-0.99.22.4.orig/lib/zebra.h
++++ quagga-0.99.22.4/lib/zebra.h
+@@ -51,7 +51,6 @@
+ #ifdef HAVE_STROPTS_H
+ #include <stropts.h>
+ #endif /* HAVE_STROPTS_H */
+-#include <sys/fcntl.h>
+ #ifdef HAVE_SYS_SELECT_H
+ #include <sys/select.h>
+ #endif /* HAVE_SYS_SELECT_H */
+--- quagga-0.99.22.4.orig/isisd/include-netbsd/iso.h
++++ quagga-0.99.22.4/isisd/include-netbsd/iso.h
+@@ -192,7 +192,7 @@
+ #else
+ /* user utilities definitions from the iso library */
+
+-#ifdef SUNOS_5
++#ifndef __GLIBC__
+ #define __P(x) x
+ #define __BEGIN_DECLS
+ #define __END_DECLS
diff --git a/main/quagga/quagga-0.99.16-ipctl_forwarding.patch b/main/quagga/quagga-0.99.16-ipctl_forwarding.patch
deleted file mode 100644
index 5a1e4e229..000000000
--- a/main/quagga/quagga-0.99.16-ipctl_forwarding.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-diff -Naur quagga-0.99.16.orig/zebra/ipforward_sysctl.c quagga-0.99.16/zebra/ipforward_sysctl.c
---- quagga-0.99.16.orig/zebra/ipforward_sysctl.c 2010-03-11 12:11:32.000000000 -0500
-+++ quagga-0.99.16/zebra/ipforward_sysctl.c 2010-03-11 12:11:39.000000000 -0500
-@@ -31,6 +31,15 @@
-
- #define MIB_SIZ 4
-
-+/* Fix for recent (2.6.14) kernel headers */
-+#ifndef IPCTL_FORWARDING
-+ #define IPCTL_FORWARDING NET_IPV4_FORWARD
-+#endif
-+
-+#ifndef IP6CTL_FORWARDING
-+ #define IP6CTL_FORWARDING NET_IPV6_FORWARDING
-+#endif
-+
- extern struct zebra_privs_t zserv_privs;
-
- /* IPv4 forwarding control MIB. */