summaryrefslogtreecommitdiffstats
path: root/main/raspberrypi
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2015-05-26 12:10:00 +0000
committerTimo Teräs <timo.teras@iki.fi>2015-05-26 12:10:00 +0000
commit4615b196852e781159e1c8da75efab6347c0f7e5 (patch)
tree0f0d302c458b72a1a4bee7899b967b7e8e3f8340 /main/raspberrypi
parentfb8d42be83f823b9a6e67831ff946a32c9e48927 (diff)
downloadaports-4615b196852e781159e1c8da75efab6347c0f7e5.tar.bz2
aports-4615b196852e781159e1c8da75efab6347c0f7e5.tar.xz
main/raspberrypi: upgrade to 2015.05.26
Diffstat (limited to 'main/raspberrypi')
-rw-r--r--main/raspberrypi/APKBUILD16
-rw-r--r--main/raspberrypi/fix-build.patch22
2 files changed, 32 insertions, 6 deletions
diff --git a/main/raspberrypi/APKBUILD b/main/raspberrypi/APKBUILD
index 77cb839ff..d3056dca8 100644
--- a/main/raspberrypi/APKBUILD
+++ b/main/raspberrypi/APKBUILD
@@ -1,18 +1,19 @@
# Maintainer: Timo Teräs <timo.teras@iki.fi>
pkgname=raspberrypi
-pkgver=0.20141017
-_commitid=4333d6d023a1f0dcc763d0706a1fe6523f9b6005
+pkgver=0.20150526
+_commitid=d4aa617de3b196399bb8e2ce32e181768cb52179
pkgrel=0
pkgdesc="Raspberry Pi support tools"
url="https://github.com/raspberrypi/userland"
arch="armhf"
license="BSD"
-depends=""
+depends="linux-headers"
makedepends="cmake"
install=""
options="!fhs"
subpackages="$pkgname-dev $pkgname-libs"
source="raspberrypi-$pkgver.tar.gz::https://github.com/raspberrypi/userland/archive/$_commitid.tar.gz
+ fix-build.patch
"
_sourcedir="$srcdir"/userland-$_commitid
@@ -51,6 +52,9 @@ libs() {
mv "$pkgdir"/opt/vc/lib/* "$subpkgdir"/opt/vc/lib
}
-md5sums="3cac9d31589cc7d41e8c03d02de76732 raspberrypi-0.20141017.tar.gz"
-sha256sums="8fb517d84f58b8c9c4ec6c8829300066e5a1fae23525a705ea5165ed97a63426 raspberrypi-0.20141017.tar.gz"
-sha512sums="249f8e44ea1048c0e339c3bb47d420845eb487809f2ba2f4896f19b1e955502856151d122a97ad4a82dcc0912e34be33d092447ec8c94bc7666fb5b19bc0fdb1 raspberrypi-0.20141017.tar.gz"
+md5sums="5d9885f0f6647223aa7adc0b8f03f924 raspberrypi-0.20150526.tar.gz
+5e2f8c8f8d59541370b7df4918352443 fix-build.patch"
+sha256sums="9f6959e80460fb3b0626712f59c0fc3b647281066d77bad881f5765834823c61 raspberrypi-0.20150526.tar.gz
+90610f473acb5267eff18baaaca39076401dd375156ce2bf2e220738fac0ee99 fix-build.patch"
+sha512sums="05396cb2b0c6440c37c37ccb408667207e9c76ce4ffdbf373f620b2fcb274d614c02eec888f972524bcfab94cda412b7969abb7ce627a72893b94673a5411c9d raspberrypi-0.20150526.tar.gz
+8697565069613dc824a516784553eb0ea5edcaa072dfc57fc38c32d0d7f6051273a2eedae840e8909fd046bf828eb4aaa50c2fff31c371c9ef23b7d4f33450aa fix-build.patch"
diff --git a/main/raspberrypi/fix-build.patch b/main/raspberrypi/fix-build.patch
new file mode 100644
index 000000000..2fb11e748
--- /dev/null
+++ b/main/raspberrypi/fix-build.patch
@@ -0,0 +1,22 @@
+--- userland-d4aa617de3b196399bb8e2ce32e181768cb52179.orig/host_applications/linux/apps/raspicam/RaspiVidYUV.c
++++ userland-d4aa617de3b196399bb8e2ce32e181768cb52179/host_applications/linux/apps/raspicam/RaspiVidYUV.c
+@@ -106,8 +106,6 @@
+ /// Run/record forever
+ #define WAIT_METHOD_FOREVER 4
+
+-extern FILE *stderr, *stdout;
+-
+ int mmal_status_to_int(MMAL_STATUS_T status);
+ static void signal_handler(int signal_number);
+
+--- userland-d4aa617de3b196399bb8e2ce32e181768cb52179.orig/host_applications/linux/libs/debug_sym/debug_sym.c
++++ userland-d4aa617de3b196399bb8e2ce32e181768cb52179/host_applications/linux/libs/debug_sym/debug_sym.c
+@@ -67,6 +67,8 @@
+ # else
+ # define PAGE_SIZE 4096
+ # endif
++#endif
++#ifndef PAGE_MASK
+ #define PAGE_MASK (~(PAGE_SIZE - 1))
+ #endif
+