summaryrefslogtreecommitdiffstats
path: root/main/rrdtool
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2013-09-01 23:48:46 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2013-09-01 23:49:54 +0000
commitab41b70761bbcb76e43c2c352fb2acd3aca07704 (patch)
treea431594e70862f368914ed4d4fd7dc44ae23b9a3 /main/rrdtool
parent4c388c3e2f4db5fb370949b243982450376716f4 (diff)
downloadaports-ab41b70761bbcb76e43c2c352fb2acd3aca07704.tar.bz2
aports-ab41b70761bbcb76e43c2c352fb2acd3aca07704.tar.xz
main/rrdtool: disable use of posix_fallocate(), seems broken
(it makes rrdtool throw a bus error when using `rrdtool create`)
Diffstat (limited to 'main/rrdtool')
-rw-r--r--main/rrdtool/APKBUILD13
-rw-r--r--main/rrdtool/no-posix-fallocate.patch12
2 files changed, 21 insertions, 4 deletions
diff --git a/main/rrdtool/APKBUILD b/main/rrdtool/APKBUILD
index ff7978010..59f6def18 100644
--- a/main/rrdtool/APKBUILD
+++ b/main/rrdtool/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=rrdtool
pkgver=1.4.8
-pkgrel=1
+pkgrel=2
pkgdesc="Data logging and graphing application"
url="http://www.rrdtool.org"
arch="all"
@@ -14,7 +14,9 @@ subpackages="$pkgname-dev $pkgname-doc perl-rrd:perl_rrd lua-rrd:lua_rrd py-rrd:
source="http://oss.oetiker.ch/$pkgname/pub/$pkgname-$pkgver.tar.gz
lua-install-cmod.patch
libm-underlinking.patch
+ no-posix-fallocate.patch
"
+options="!strip"
_builddir="$srcdir"/$pkgname-$pkgver
prepare() {
@@ -81,10 +83,13 @@ py_rrd() {
md5sums="dbe59386db97fd2f2216729facd74ca8 rrdtool-1.4.8.tar.gz
f94e916381af48dcf5687aa046b35aac lua-install-cmod.patch
-ab92a2b87f71d59e3830dac3b227c357 libm-underlinking.patch"
+ab92a2b87f71d59e3830dac3b227c357 libm-underlinking.patch
+e14d13f10fa575733e791bcb8b0711fe no-posix-fallocate.patch"
sha256sums="de95b9f5aa488b0683600aad5a07c316f8d98cbe8d00aa0a1c87e2b2ef89f3d6 rrdtool-1.4.8.tar.gz
1e49eeca4561d29da3975f84e06b27f0f305e566bb26922397d938eede678b71 lua-install-cmod.patch
-0495bd122941bcd635ca2a2b7c3f01a6eb3ca3e00b7e40c257862b7071b7738a libm-underlinking.patch"
+0495bd122941bcd635ca2a2b7c3f01a6eb3ca3e00b7e40c257862b7071b7738a libm-underlinking.patch
+8b32dcf1b8c7f9967934e25ab05ef6a9384cb6096d32dd5d63046bafd7cac1ad no-posix-fallocate.patch"
sha512sums="c525978829508e1db393092c948d8db910554f42e1221acc4064a8f546ceac5d68943f603c6f0ef0e6510bbe5f606cfe6862672145ea1b630cd2b7fd07fa805b rrdtool-1.4.8.tar.gz
0be4ebb864233cf32fa70c872f5421b2da50ad39d6a265c2f5869337b40647c0b88011ccf41fe17a8d35de915ca1c38d04d67696118e1e32ff774221b1816ab6 lua-install-cmod.patch
-94449972ccc7d1a057c2b827c041a16de1667c280a47ef30c1323ec9168812a96374704cc42dd832a30b8cc08d7fad94da44ff3695c66f3a0d324a87158fc23c libm-underlinking.patch"
+94449972ccc7d1a057c2b827c041a16de1667c280a47ef30c1323ec9168812a96374704cc42dd832a30b8cc08d7fad94da44ff3695c66f3a0d324a87158fc23c libm-underlinking.patch
+00d079161551a75f8d4fe5085741d45d9c6b06be0a5163090143c6ab47710e29633414bee4dd68bbf950bf0ba1796bf4623b4f307477265a48f49514c8b790ab no-posix-fallocate.patch"
diff --git a/main/rrdtool/no-posix-fallocate.patch b/main/rrdtool/no-posix-fallocate.patch
new file mode 100644
index 000000000..c34c5a187
--- /dev/null
+++ b/main/rrdtool/no-posix-fallocate.patch
@@ -0,0 +1,12 @@
+--- rrdtool-1.4.8.orig/configure.ac
++++ rrdtool-1.4.8/configure.ac
+@@ -280,9 +280,6 @@
+ #include <fcntl.h>])
+ AC_CHECK_FUNCS(posix_fadvise)
+
+-dnl can we use posix_fallocate
+-AC_CHECK_FUNCS(posix_fallocate)
+-
+ CONFIGURE_PART(Libintl Processing)
+
+ AM_GNU_GETTEXT_VERSION(0.17)