summaryrefslogtreecommitdiffstats
path: root/main/rrdtool
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-09-05 09:26:07 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-09-05 10:04:02 +0000
commitca97c182b8e6364f5048e520f59863340293ac55 (patch)
tree531cb89abaa9691081fb24a835d42898592e3efc /main/rrdtool
parent3bb1b3859e07c22768ed937f04eedfd754822573 (diff)
downloadaports-ca97c182b8e6364f5048e520f59863340293ac55.tar.bz2
aports-ca97c182b8e6364f5048e520f59863340293ac55.tar.xz
main/rrdtool: minor fix for pkgconf
'pkg-config --cflags lua' returns a space with freedesktop and no space with pkgconf, so the the following gave different result: if test "$LUA_CFLAGS" = ""; then ...
Diffstat (limited to 'main/rrdtool')
-rw-r--r--main/rrdtool/APKBUILD24
-rw-r--r--main/rrdtool/lua-install-cmod.patch13
2 files changed, 31 insertions, 6 deletions
diff --git a/main/rrdtool/APKBUILD b/main/rrdtool/APKBUILD
index 2088e1bf9..b064ce6c9 100644
--- a/main/rrdtool/APKBUILD
+++ b/main/rrdtool/APKBUILD
@@ -1,18 +1,30 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=rrdtool
pkgver=1.4.7
-pkgrel=2
+pkgrel=3
pkgdesc="Data logging and graphing application"
url="http://www.rrdtool.org"
arch="all"
license="GPL"
depends=
makedepends="libart-lgpl-dev libpng-dev freetype-dev perl-dev cairo-dev
- pango-dev lua-dev man"
+ pango-dev lua-dev man
+ autoconf automake"
subpackages="$pkgname-dev $pkgname-doc perl-rrd:perl_rrd lua-rrd:lua_rrd"
-source="http://oss.oetiker.ch/$pkgname/pub/$pkgname-$pkgver.tar.gz"
+source="http://oss.oetiker.ch/$pkgname/pub/$pkgname-$pkgver.tar.gz
+ lua-install-cmod.patch
+ "
_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
build() {
cd "$_builddir"
./configure --prefix=/usr \
@@ -24,8 +36,7 @@ build() {
--enable-lua-site-install \
--with-perl-options="INSTALLDIRS=vendor" \
|| return 1
-
- make || return 1
+ make || return 1
}
package() {
@@ -58,4 +69,5 @@ lua_rrd() {
}
-md5sums="ffe369d8921b4dfdeaaf43812100c38f rrdtool-1.4.7.tar.gz"
+md5sums="ffe369d8921b4dfdeaaf43812100c38f rrdtool-1.4.7.tar.gz
+f94e916381af48dcf5687aa046b35aac lua-install-cmod.patch"
diff --git a/main/rrdtool/lua-install-cmod.patch b/main/rrdtool/lua-install-cmod.patch
new file mode 100644
index 000000000..672aea78a
--- /dev/null
+++ b/main/rrdtool/lua-install-cmod.patch
@@ -0,0 +1,13 @@
+--- ./configure.orig
++++ ./configure
+@@ -29330,7 +29330,9 @@
+ $as_echo "$as_me: WARNING: Setting Lua include and lib flags to defaults in compat-5.1 and lua 5.1 sources" >&2;}
+ LUA_CFLAGS="-I/usr/local/include -I/usr/local/include/lua -I/usr/local/include/lua/$lua_vdot"
+ LUA_LFLAGS="-L/usr/local/lib -L/usr/local/lib/lua -L/usr/local/lib/lua/$lua_vdot $lua_libs"
+- LUA_INSTALL_CMOD="/usr/local/lib/lua/$lua_vdot"
++ if test -z "$LUA_INSTALL_CMOD"; then
++ LUA_INSTALL_CMOD="/usr/local/lib/lua/$lua_vdot"
++ fi
+ fi
+
+ # Check whether --enable-lua-site-install was given.