summaryrefslogtreecommitdiffstats
path: root/main/sdl
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-05-16 13:48:08 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-05-16 13:48:08 +0000
commitbe91866229a76e73f1ecdbdbfec83b8e69cb6e69 (patch)
tree70498d92324c2cefef72f6ceb660ec5a413ac71b /main/sdl
parenta7e4d66e8974fb4c3c69350ca4c7d25849f01fce (diff)
downloadaports-be91866229a76e73f1ecdbdbfec83b8e69cb6e69.tar.bz2
aports-be91866229a76e73f1ecdbdbfec83b8e69cb6e69.tar.xz
main/sdl: disable the dlopen stuff as it seems to not work
qemu with sdl hangs on startup, apparently it ends up in an endless loop Backtrace from gdb: Program received signal SIGINT, Interrupt. 0x00007ffff7df5904 in ?? () from /lib/ld64-uClibc.so.0.9.32 (gdb) bt #0 0x00007ffff7df5904 in ?? () from /lib/ld64-uClibc.so.0.9.32 #1 0x00007ffff7df653e in _dl_find_hash () from /lib/ld64-uClibc.so.0.9.32 #2 0x00007ffff7df7fa1 in ?? () from /lib/ld64-uClibc.so.0.9.32 #3 0x00007ffff7df6a8a in ?? () from /lib/ld64-uClibc.so.0.9.32 #4 0x00007ffff7df6d03 in _dl_fixup () from /lib/ld64-uClibc.so.0.9.32 #5 0x00007ffff501e015 in ?? () from /lib/libdl.so.0.9.32 #6 0x00007ffff501e224 in dlopen () from /lib/libdl.so.0.9.32 #7 0x00007ffff6803e87 in SDL_LoadObject () from /usr/lib/libSDL-1.2.so.0 #8 0x00007ffff68082a7 in ?? () from /usr/lib/libSDL-1.2.so.0 #9 0x00007ffff680eb74 in ?? () from /usr/lib/libSDL-1.2.so.0 #10 0x00007ffff67ff040 in SDL_VideoInit () from /usr/lib/libSDL-1.2.so.0 #11 0x00007ffff67dd752 in SDL_InitSubSystem () from /usr/lib/libSDL-1.2.so.0 #12 0x00007ffff67dd824 in SDL_Init () from /usr/lib/libSDL-1.2.so.0 #13 0x000055555568cc9b in ?? () #14 0x00005555555c182a in main () We try disable the dlopen stuff and see how that goes
Diffstat (limited to 'main/sdl')
-rw-r--r--main/sdl/APKBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/main/sdl/APKBUILD b/main/sdl/APKBUILD
index 79d2c3ac0..9dca63b4d 100644
--- a/main/sdl/APKBUILD
+++ b/main/sdl/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=sdl
pkgver=1.2.15
-pkgrel=1
+pkgrel=2
pkgdesc="A library for portable low-level access to a video framebuffer, audio output, mouse, and keyboard"
url="http://www.libsdl.org"
arch="all"
@@ -35,7 +35,7 @@ build() {
--disable-video-ggi \
--disable-video-aalib \
--enable-alsa \
- --enable-sdl-dlopen \
+ --disable-sdl-dlopen \
--with-x \
--disable-rpath \
--disable-nls