summaryrefslogtreecommitdiffstats
path: root/main/sems
diff options
context:
space:
mode:
authorNathan Angelacos <nangel@alpinelinux.org>2012-09-20 19:31:58 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-09-20 19:56:06 +0000
commitf64e57590f52bc6503ab1cae8adb7db6653b89e1 (patch)
tree6648f4ab1f93f8c26a610b7c80b92ae3a3b491c5 /main/sems
parent0673f1f7d1c96df35f74a141e32712921dbec45c (diff)
downloadaports-f64e57590f52bc6503ab1cae8adb7db6653b89e1.tar.bz2
aports-f64e57590f52bc6503ab1cae8adb7db6653b89e1.tar.xz
main/sems/sems-0004-fix-PRACK-route.patch: Include full route path in PRACK
Diffstat (limited to 'main/sems')
-rw-r--r--main/sems/APKBUILD5
-rw-r--r--main/sems/sems-0004-fix-PRACK-route.patch14
2 files changed, 17 insertions, 2 deletions
diff --git a/main/sems/APKBUILD b/main/sems/APKBUILD
index cfffe12a0..33458758c 100644
--- a/main/sems/APKBUILD
+++ b/main/sems/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=sems
pkgver=1.5.0
-pkgrel=0
+pkgrel=1
pkgdesc="SIP Express Media Server, an extensible SIP media server"
url="http://iptel.org/sems/"
arch="all"
@@ -22,7 +22,7 @@ source="http://ftp.iptel.org/pub/sems/sems-$pkgver.tar.gz
sems-0001-Force-to-use-system-wide-GSM-includes.patch
sems-0002-Allow-rewrite-of-custom-makefiles-by-CMake.patch
sems-0003-Set-CFG_PREFIX-to-empty-string-by-default.patch
-
+ sems-0004-fix-PRACK-route.patch
sems.initd
"
# sems-0005-Add-sw_prepaid_sip-plugin-to-default-exclude-list-du.patch
@@ -199,4 +199,5 @@ md5sums="ec0a88f9081679b3b4ab9d06e84ea759 sems-1.5.0.tar.gz
5b2fded836b44bda33f39adc37de4de7 sems-0001-Force-to-use-system-wide-GSM-includes.patch
b8efd1a6415afa08f7c676f6976fca36 sems-0002-Allow-rewrite-of-custom-makefiles-by-CMake.patch
331e7529833c906b4738006f32a65fde sems-0003-Set-CFG_PREFIX-to-empty-string-by-default.patch
+62f03dac8e098b0333f3e8b06770b459 sems-0004-fix-PRACK-route.patch
36c2f993ba874781f5d3974b4f4c1503 sems.initd"
diff --git a/main/sems/sems-0004-fix-PRACK-route.patch b/main/sems/sems-0004-fix-PRACK-route.patch
new file mode 100644
index 000000000..af2827143
--- /dev/null
+++ b/main/sems/sems-0004-fix-PRACK-route.patch
@@ -0,0 +1,14 @@
+diff --git a/core/AmSipDialog.cpp b/core/AmSipDialog.cpp
+index d121606..17c9731 100644
+--- a/core/AmSipDialog.cpp
++++ b/core/AmSipDialog.cpp
+@@ -406,6 +406,9 @@ void AmSipDialog::onRxReply(const AmSipReply& reply)
+ else {
+ status = Early;
+ remote_tag = reply.to_tag;
++ route = reply.route;
++ if(!reply.to_uri.empty())
++ remote_uri = reply.to_uri;
+ }
+ }
+ else if(reply.code < 300){