summaryrefslogtreecommitdiffstats
path: root/main/shorewall
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-09-03 06:46:54 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-09-03 06:49:46 +0000
commit67504a569ae27651f80b290f8bdfb42095138b8c (patch)
tree1a7b11bfc793a71cafdfc44ee95657a6f03eaa5e /main/shorewall
parent681f09938f62de69402452b66275215250445348 (diff)
downloadaports-67504a569ae27651f80b290f8bdfb42095138b8c.tar.bz2
aports-67504a569ae27651f80b290f8bdfb42095138b8c.tar.xz
main/shorewall: upgrade to 4.6.3.1
Diffstat (limited to 'main/shorewall')
-rw-r--r--main/shorewall/APKBUILD28
-rw-r--r--main/shorewall/shorewallrc.alpine23
2 files changed, 39 insertions, 12 deletions
diff --git a/main/shorewall/APKBUILD b/main/shorewall/APKBUILD
index 9c01dfa70..b41fc58e2 100644
--- a/main/shorewall/APKBUILD
+++ b/main/shorewall/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=shorewall
-pkgver=4.6.2.1
+pkgver=4.6.3.1
_ver=$pkgver
case $pkgver in
@@ -10,7 +10,7 @@ esac
pkgrel=0
pkgdesc="An iptables front end for firewall configuration"
url="http://www.shorewall.net/"
-arch=""
+arch="noarch"
license="GPL-2"
depends="shorewall-core perl iptables iproute2"
# coreutils for install -T
@@ -19,6 +19,7 @@ replaces=""
subpackages="$pkgname-doc"
source="http://www1.shorewall.net/pub/shorewall/${_ver%.*}/shorewall-$_ver/$pkgname-$pkgver.tar.bz2
shorewall.initd
+ shorewallrc.alpine
"
_builddir="$srcdir/$pkgname-$pkgver"
@@ -30,23 +31,26 @@ prepare() {
*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
esac
done
+ cp "$srcdir"/shorewallrc.alpine .
}
build() {
cd "$_builddir"
- ./configure MANDIR=/usr/share/man SBINDIR=/usr/sbin || return 1
+ ./configure || return 1
}
package() {
cd "$_builddir"
- DESTDIR="$pkgdir" ./install.sh || return 1
- rm -f "$pkgdir"/etc/init.d/shorewall
- install -m755 "$srcdir"/shorewall.initd "$pkgdir"/etc/init.d/shorewall
+ DESTDIR="$pkgdir" ./install.sh shorewallrc.alpine || return 1
+ install -Dm755 "$srcdir"/shorewall.initd "$pkgdir"/etc/init.d/shorewall
}
-md5sums="24f9fa3fb392bb536ee0a71fc3520ccb shorewall-4.6.2.1.tar.bz2
-ac54901de1e876a18d1938df1512ce0d shorewall.initd"
-sha256sums="681f7bcbc969d549d2fb99c3bb64ab259c59f053519dba2d02751c524f363358 shorewall-4.6.2.1.tar.bz2
-8a69643e09f71044b4f733263ea7120c4f6147a9d6d9b814b43e94ea64791a0f shorewall.initd"
-sha512sums="31d9267517047c9597d78573f52eb09aa9218576c6a7ade81def5c67cfc37a1efefc9b42d8b2a7249ff2d59d00ab1b478e7e77d37dbe582175f2966977327f4e shorewall-4.6.2.1.tar.bz2
-c4c3a1137740fd1098680e4b362d707378a263aeeda19a846ba3007614b1b5021ee4a492a5439066b433ce1c27c5a5069a4497ac08d36959a6e1a48cb44422f4 shorewall.initd"
+md5sums="75b0667a28d75da2010b24783f797cd8 shorewall-4.6.3.1.tar.bz2
+ac54901de1e876a18d1938df1512ce0d shorewall.initd
+422c5d36fcee177acba58756b0fec7e2 shorewallrc.alpine"
+sha256sums="6b89a436809ffcf4a9cadef992adc23a3475f07d35e5c47e8391ed3560d890ec shorewall-4.6.3.1.tar.bz2
+8a69643e09f71044b4f733263ea7120c4f6147a9d6d9b814b43e94ea64791a0f shorewall.initd
+99f588523594b5a8062b2f43ab9f59daf91f12634b178f30dd7cb61786bd8220 shorewallrc.alpine"
+sha512sums="913a6839308a1110551ed2fd94eee15720bce87096ccd16f2956b44c4977848a827f7f08dfe1f64f86b5a2334a4514701b2c5102724ed529d3983cf2d2801cb9 shorewall-4.6.3.1.tar.bz2
+c4c3a1137740fd1098680e4b362d707378a263aeeda19a846ba3007614b1b5021ee4a492a5439066b433ce1c27c5a5069a4497ac08d36959a6e1a48cb44422f4 shorewall.initd
+c076ae42e7b404cecf521fdc32f92ba3a6b77d61579726abde2f00b6b6282e55b0b334b9fe5e43a6e4ae56361cce3214d9a38099f9f8714f03ae4fb888c744b7 shorewallrc.alpine"
diff --git a/main/shorewall/shorewallrc.alpine b/main/shorewall/shorewallrc.alpine
new file mode 100644
index 000000000..fd0314f47
--- /dev/null
+++ b/main/shorewall/shorewallrc.alpine
@@ -0,0 +1,23 @@
+#
+# Default Shorewall 4.5 rc file
+#
+HOST=linux #Generic Linux
+BUILD=linux #Default is to detect the build system
+PREFIX=/usr #Top-level directory for shared files, libraries, etc.
+SHAREDIR=${PREFIX}/share #Directory for arch-neutral files.
+LIBEXECDIR=${PREFIX}/share #Directory for executable scripts.
+PERLLIBDIR=${PREFIX}/share/shorewall #Directory to install Shorewall Perl module directory
+CONFDIR=/etc #Directory where subsystem configurations are installed
+SBINDIR=/usr/sbin #Directory where system administration programs are installed
+MANDIR=${SHAREDIR}/man #Directory where manpages are installed.
+INITDIR= #Directory where SysV init scripts are installed.
+INITFILE= #Name of the product's installed SysV init script
+INITSOURCE= #Name of the distributed file to be installed as the SysV init script
+ANNOTATED= #If non-zero, annotated configuration files are installed
+SYSTEMD= #Directory where .service files are installed (systems running systemd only)
+SERVICEFILE= #Name of the file to install in $SYSTEMD. Default is $PRODUCT.service
+SYSCONFFILE= #Name of the distributed file to be installed in $SYSCONFDIR
+SYSCONFDIR= #Directory where SysV init parameter files are installed
+SPARSE= #If non-empty, only install $PRODUCT/$PRODUCT.conf in $CONFDIR
+VARLIB=/var/lib #Directory where product variable data is stored.
+VARDIR=${VARLIB}/$PRODUCT #Directory where product variable data is stored.