summaryrefslogtreecommitdiffstats
path: root/main/sox
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2015-04-30 11:36:50 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2015-04-30 12:03:03 +0000
commit0337bf23bcc31cc2727ae02d019bdaa628eff758 (patch)
tree313cea4e262fdbbeb2aaaa30a1a7b1a0853d7f71 /main/sox
parentd4153732c0dd87185e34190ac7f185dd11579e22 (diff)
downloadaports-0337bf23bcc31cc2727ae02d019bdaa628eff758.tar.bz2
aports-0337bf23bcc31cc2727ae02d019bdaa628eff758.tar.xz
main/sox: upgrade to 14.4.2
Diffstat (limited to 'main/sox')
-rw-r--r--main/sox/0001-Check-for-minimum-size-sphere-headers.patch28
-rw-r--r--main/sox/0002-More-checks-for-invalid-MS-ADPCM-blocks.patch28
-rw-r--r--main/sox/APKBUILD34
-rw-r--r--main/sox/sox-dynamic.patch12
4 files changed, 28 insertions, 74 deletions
diff --git a/main/sox/0001-Check-for-minimum-size-sphere-headers.patch b/main/sox/0001-Check-for-minimum-size-sphere-headers.patch
deleted file mode 100644
index f01fec390..000000000
--- a/main/sox/0001-Check-for-minimum-size-sphere-headers.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From 55e33019afcb3256cccedf606548b86816f6da59 Mon Sep 17 00:00:00 2001
-From: Chris Bagwell <chris@cnpbagwell.com>
-Date: Sat, 13 Dec 2014 12:48:37 -0600
-Subject: [PATCH 1/2] Check for minimum size sphere headers
-
----
- src/sphere.c | 5 +++++
- 1 file changed, 5 insertions(+)
-
-diff --git a/src/sphere.c b/src/sphere.c
-index 479a552..a3fd1c6 100644
---- a/src/sphere.c
-+++ b/src/sphere.c
-@@ -47,6 +47,11 @@ static int start_read(sox_format_t * ft)
-
- /* Determine header size, and allocate a buffer large enough to hold it. */
- sscanf(fldsval, "%lu", &header_size_ul);
-+ if (header_size_ul < 16) {
-+ lsx_fail_errno(ft, SOX_EHDR, "Error reading Sphere header");
-+ return (SOX_EOF);
-+ }
-+
- buf = lsx_malloc(header_size = header_size_ul);
-
- /* Skip what we have read so far */
---
-2.1.0
-
diff --git a/main/sox/0002-More-checks-for-invalid-MS-ADPCM-blocks.patch b/main/sox/0002-More-checks-for-invalid-MS-ADPCM-blocks.patch
deleted file mode 100644
index 72c2d765a..000000000
--- a/main/sox/0002-More-checks-for-invalid-MS-ADPCM-blocks.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From ebb64cddde59ecc9cedf3741ce2337c72148cc0c Mon Sep 17 00:00:00 2001
-From: Chris Bagwell <chris@cnpbagwell.com>
-Date: Sat, 13 Dec 2014 12:49:55 -0600
-Subject: [PATCH 2/2] More checks for invalid MS ADPCM blocks.
-
-If block doesn't exacty match blockAlign then do not allow
-number of samples in invalid size block to ever be more than
-what WAV header defined as samplesPerBlock.
----
- src/wav.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/wav.c b/src/wav.c
-index 61d5908..5202556 100644
---- a/src/wav.c
-+++ b/src/wav.c
-@@ -168,7 +168,7 @@ static unsigned short AdpcmReadBlock(sox_format_t * ft)
- /* work with partial blocks. Specs say it should be null */
- /* padded but I guess this is better than trailing quiet. */
- samplesThisBlock = lsx_ms_adpcm_samples_in((size_t)0, (size_t)ft->signal.channels, bytesRead, (size_t)0);
-- if (samplesThisBlock == 0)
-+ if (samplesThisBlock == 0 || samplesThisBlock > wav->samplesPerBlock)
- {
- lsx_warn("Premature EOF on .wav input file");
- return 0;
---
-2.1.0
-
diff --git a/main/sox/APKBUILD b/main/sox/APKBUILD
index a50bfc64c..c3cf79b93 100644
--- a/main/sox/APKBUILD
+++ b/main/sox/APKBUILD
@@ -1,31 +1,32 @@
# Contributor: Ɓukasz Jendrysik <scadu@yandex.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=sox
-pkgver=14.4.1
-pkgrel=2
+pkgver=14.4.2
+pkgrel=0
pkgdesc="The Swiss Army knife of sound processing tools"
url="http://sox.sourceforge.net/"
arch="all"
license="GPL LGPL"
makedepends="ffmpeg-dev libao-dev libvorbis-dev libogg-dev lame-dev
libmad-dev bash alsa-lib-dev libsndfile-dev libsamplerate-dev
- libtool file-dev libid3tag-dev flac-dev"
+ libtool file-dev libid3tag-dev flac-dev gsm-dev opusfile-dev
+ autoconf automake libtool
+ "
depends=
subpackages="$pkgname-dev $pkgname-doc"
source="http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.gz
- 0001-Check-for-minimum-size-sphere-headers.patch
- 0002-More-checks-for-invalid-MS-ADPCM-blocks.patch
sox-uclibc.patch
+ sox-dynamic.patch
"
prepare() {
cd "$srcdir"/$pkgname-$pkgver
- update_config_sub || return 1
for i in $source; do
case $i in
*.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
esac
done
+ autoreconf -vif
}
build() {
@@ -51,15 +52,12 @@ package() {
"$pkgdir"/usr/lib/sox/*.la \
|| return 1
}
-md5sums="670307f40763490a2bc0d1f322071e7a sox-14.4.1.tar.gz
-fd71128112abc7b79d1f7f87d33b2a28 0001-Check-for-minimum-size-sphere-headers.patch
-f909976e1ac57a2cf10aaecf29d7abbf 0002-More-checks-for-invalid-MS-ADPCM-blocks.patch
-b734d72321470f9aaf44464878b1d12f sox-uclibc.patch"
-sha256sums="9a8c2c6fe51e608da346a157e111508a957af9e3ecf3de26781d36e9a67fa89b sox-14.4.1.tar.gz
-0c30b66aca138f90b88332fdd8e7b2235eb85803cf96b4e79f27fbc8d84bc07b 0001-Check-for-minimum-size-sphere-headers.patch
-d1de894281ed906214c1606de386ec708efac1bca49a9e8cb8397d3ec6894cc0 0002-More-checks-for-invalid-MS-ADPCM-blocks.patch
-0d1447942cf64b0307baa7a16f0a91f553597be187d5c94eadc56d180615717d sox-uclibc.patch"
-sha512sums="a35c0f424ffaa51d06291e69b28ae7f2248a750fa8aded911dcd7e123877ecb5142c292f943eb723142c50dbd890b58163c6ef24c9c0573377855fad1b36fb25 sox-14.4.1.tar.gz
-e0231026de666146ca09598d6113645b52c9f4ced3eaf4e437bff0c1507699463e2f4962d1fd55f97cce5077ed01f2f3abda64cf4d027ce78befa2e818378dfa 0001-Check-for-minimum-size-sphere-headers.patch
-2603c995558ff25b67321845b80de3d1f326d374fce0b297ade4a956d5286c49b690b0c30bd2afc19ac5951ff8c203c5b45db9aff59da7cba0252feefb739c12 0002-More-checks-for-invalid-MS-ADPCM-blocks.patch
-08c55a0de96733e10544d450f39c2205b4057b9fc024503ec97b1906a075752ee8a4b0a1b4c5bbad2eebec17bcf8d069b22d243a63d28b77c23d545efcca6aec sox-uclibc.patch"
+md5sums="d04fba2d9245e661f245de0577f48a33 sox-14.4.2.tar.gz
+b734d72321470f9aaf44464878b1d12f sox-uclibc.patch
+630cf245f283b4dd205bdafde421240c sox-dynamic.patch"
+sha256sums="b45f598643ffbd8e363ff24d61166ccec4836fea6d3888881b8df53e3bb55f6c sox-14.4.2.tar.gz
+0d1447942cf64b0307baa7a16f0a91f553597be187d5c94eadc56d180615717d sox-uclibc.patch
+49fd1d0fc08d4d6722d9dcf7bc44d95122627191c876a5d1748b991cddb604d1 sox-dynamic.patch"
+sha512sums="b5c6203f4f5577503a034fe5b3d6a033ee97fe4d171c533933e2b036118a43a14f97c9668433229708609ccf9ee16abdeca3fc7501aa0aafe06baacbba537eca sox-14.4.2.tar.gz
+08c55a0de96733e10544d450f39c2205b4057b9fc024503ec97b1906a075752ee8a4b0a1b4c5bbad2eebec17bcf8d069b22d243a63d28b77c23d545efcca6aec sox-uclibc.patch
+3950834db26faa0523006c6fd8e0769d080518f127d345c8ec9bf53e9db8a6bd67cd724f0f86492aaf9ce6ede2dfbde167049768f35c14ef3c2b96e7e00302b6 sox-dynamic.patch"
diff --git a/main/sox/sox-dynamic.patch b/main/sox/sox-dynamic.patch
new file mode 100644
index 000000000..94ac6a282
--- /dev/null
+++ b/main/sox/sox-dynamic.patch
@@ -0,0 +1,12 @@
+diff -Naur sox-14.4.2-orig/src/Makefile.am sox-14.4.2/src/Makefile.am
+--- sox-14.4.2-orig/src/Makefile.am 2015-04-08 17:11:09.555343005 -0400
++++ sox-14.4.2/src/Makefile.am 2015-04-08 17:11:25.115317153 -0400
+@@ -95,7 +95,7 @@
+
+ libsox_la_CFLAGS = @WARN_CFLAGS@
+ libsox_la_LDFLAGS = @APP_LDFLAGS@ -version-info @SHLIB_VERSION@ \
+- -export-symbols-regex '^(sox_.*|lsx_(check_read_params|(close|open)_dllibrary|(debug(_more|_most)?|fail|report|warn)_impl|eof|fail_errno|filelength|find_(enum_(text|value)|file_extension)|getopt(_init)?|lpc10_(create_(de|en)coder_state|(de|en)code)|raw(read|write)|read(_b_buf|buf|chars)|realloc|rewind|seeki|sigfigs3p?|strcasecmp|tell|unreadb|write(b|_b_buf|buf|s)))$$'
++ -export-symbols-regex '^(sox_.*|lsx_(error|flush|check_read_params|(close|open)_dllibrary|(debug(_more|_most)?|fail|report|warn)_impl|eof|fail_errno|filelength|find_(enum_(text|value)|file_extension)|getopt(_init)?|lpc10_(create_(de|en)coder_state|(de|en)code)|raw(read|write)|read(_b_buf|buf|chars)|realloc|rewind|seeki|sigfigs3p?|strcasecmp|tell|unreadb|write(b|_b_buf|buf|s)))$$'
+
+ if HAVE_WIN32_LTDL
+ libsox_la_SOURCES += win32-ltdl.c win32-ltdl.h