summaryrefslogtreecommitdiffstats
path: root/main/spice
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2014-12-03 16:52:49 +0200
committerTimo Teräs <timo.teras@iki.fi>2014-12-03 16:52:49 +0200
commit8095fdc37c38c6f1812e946a21064425540da5f9 (patch)
treeb4ee49c274065b0cb86591954bc6fb894be102a0 /main/spice
parentaf44b21daee83a3443b53d808dd7a97c14fbbfd7 (diff)
downloadaports-8095fdc37c38c6f1812e946a21064425540da5f9.tar.bz2
aports-8095fdc37c38c6f1812e946a21064425540da5f9.tar.xz
main/spice: use x86 inline assembly only on x86
Diffstat (limited to 'main/spice')
-rw-r--r--main/spice/APKBUILD15
-rw-r--r--main/spice/fix-non-x86-build.patch17
2 files changed, 27 insertions, 5 deletions
diff --git a/main/spice/APKBUILD b/main/spice/APKBUILD
index f3a04e250..ced05a368 100644
--- a/main/spice/APKBUILD
+++ b/main/spice/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=spice
pkgver=0.12.5
-pkgrel=0
+pkgrel=1
pkgdesc="Implements the SPICE protocol"
url="http://www.spice-space.org/"
arch="x86 x86_64"
@@ -15,7 +15,9 @@ makedepends="$depends_dev alsa-lib-dev libjpeg-turbo-dev libxrandr-dev
install=""
subpackages="$pkgname-dev $pkgname-server $pkgname-client"
source="http://www.spice-space.org/download/releases/spice-$pkgver.tar.bz2
- cstdarg.patch"
+ cstdarg.patch
+ fix-non-x86-build.patch
+ "
_builddir="$srcdir"/spice-$pkgver
prepare() {
@@ -66,8 +68,11 @@ client() {
}
md5sums="1256286214fe402703c0a01bd3a85319 spice-0.12.5.tar.bz2
-3e61fdc18bf201a2b54b332fdbe2912e cstdarg.patch"
+3e61fdc18bf201a2b54b332fdbe2912e cstdarg.patch
+a3518f630a6485a2c9c84678c5b99f52 fix-non-x86-build.patch"
sha256sums="4209a20d8f67cb99a8a6ac499cfe79a18d4ca226360457954a223d6795c2f581 spice-0.12.5.tar.bz2
-bc2219f68ed701e74a02c5196c934bb3e6fbf5813005f39e41e911668e0e622c cstdarg.patch"
+bc2219f68ed701e74a02c5196c934bb3e6fbf5813005f39e41e911668e0e622c cstdarg.patch
+b79134e52a6ce087ed1d194547ff86697b857c1277c0c8c69756250d1817de46 fix-non-x86-build.patch"
sha512sums="1501c913ba3b1856444536a9bfda7a2138a96088f940b483e963df342b91deb945d77bfb3c83ebddfcd7c3008695c0dd7df30ff9fd8502cbbcac1c610a273572 spice-0.12.5.tar.bz2
-040f4104d9658465cb2ffa72101f958341497898d86ee82bdf31bd65e5f3497822be4b9b3e9eca2a9b965385481190a2fb4ca5fb26b89391ab1598fc23d300c9 cstdarg.patch"
+040f4104d9658465cb2ffa72101f958341497898d86ee82bdf31bd65e5f3497822be4b9b3e9eca2a9b965385481190a2fb4ca5fb26b89391ab1598fc23d300c9 cstdarg.patch
+a7b6d3197c2af746657e064229526955f26808c8ae2e65c3f634977bf1b71f85abfde84325d1522341bca0bdb1f4fd9bfced774164ccf8ccf45c897d1ef364e7 fix-non-x86-build.patch"
diff --git a/main/spice/fix-non-x86-build.patch b/main/spice/fix-non-x86-build.patch
new file mode 100644
index 000000000..cca3b1cbe
--- /dev/null
+++ b/main/spice/fix-non-x86-build.patch
@@ -0,0 +1,17 @@
+diff -ru spice-0.12.5.orig/client/utils.h spice-0.12.5/client/utils.h
+--- spice-0.12.5.orig/client/utils.h 2014-05-14 14:14:34.000000000 -0300
++++ spice-0.12.5/client/utils.h 2014-12-03 16:49:54.630411626 -0200
+@@ -50,9 +50,13 @@
+ throw Exception(exption_string, err); \
+ }
+
++#if defined(__i386__) || defined(__x86_64__)
+ #define SPICE_BREAKPOINT() do{ \
+ __asm__ __volatile__ ("int $03"); \
+ }while(0)
++#else
++#define SPICE_BREAKPOINT() do {} while (0)
++#endif
+
+ template <class T>
+ class AutoRef {