summaryrefslogtreecommitdiffstats
path: root/main/spice
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2014-12-04 13:47:12 +0200
committerTimo Teräs <timo.teras@iki.fi>2014-12-04 13:47:12 +0200
commit9bc3eecbb28c4efd71c03f36497701879d9dc054 (patch)
treed3cdf334fe6eaf8903b17bf4bc2d3513206e7bef /main/spice
parenta22b228c20bb2e9ec09270beb68c556396690792 (diff)
downloadaports-9bc3eecbb28c4efd71c03f36497701879d9dc054.tar.bz2
aports-9bc3eecbb28c4efd71c03f36497701879d9dc054.tar.xz
main/spice: fix memory barriers on non-x86 architectures
Diffstat (limited to 'main/spice')
-rw-r--r--main/spice/APKBUILD8
-rw-r--r--main/spice/fix-non-x86-build.patch23
2 files changed, 25 insertions, 6 deletions
diff --git a/main/spice/APKBUILD b/main/spice/APKBUILD
index 5feb8e67c..ecbe6f263 100644
--- a/main/spice/APKBUILD
+++ b/main/spice/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=spice
pkgver=0.12.5
-pkgrel=1
+pkgrel=2
pkgdesc="Implements the SPICE protocol"
url="http://www.spice-space.org/"
arch="all"
@@ -69,10 +69,10 @@ client() {
md5sums="1256286214fe402703c0a01bd3a85319 spice-0.12.5.tar.bz2
3e61fdc18bf201a2b54b332fdbe2912e cstdarg.patch
-a3518f630a6485a2c9c84678c5b99f52 fix-non-x86-build.patch"
+cf73b5f5ee618b9de82a6025b4d4cfff fix-non-x86-build.patch"
sha256sums="4209a20d8f67cb99a8a6ac499cfe79a18d4ca226360457954a223d6795c2f581 spice-0.12.5.tar.bz2
bc2219f68ed701e74a02c5196c934bb3e6fbf5813005f39e41e911668e0e622c cstdarg.patch
-b79134e52a6ce087ed1d194547ff86697b857c1277c0c8c69756250d1817de46 fix-non-x86-build.patch"
+e7d13db986ef482c9788f7c90eb3d7de11d662536a21c9812b332da79659fb6a fix-non-x86-build.patch"
sha512sums="1501c913ba3b1856444536a9bfda7a2138a96088f940b483e963df342b91deb945d77bfb3c83ebddfcd7c3008695c0dd7df30ff9fd8502cbbcac1c610a273572 spice-0.12.5.tar.bz2
040f4104d9658465cb2ffa72101f958341497898d86ee82bdf31bd65e5f3497822be4b9b3e9eca2a9b965385481190a2fb4ca5fb26b89391ab1598fc23d300c9 cstdarg.patch
-a7b6d3197c2af746657e064229526955f26808c8ae2e65c3f634977bf1b71f85abfde84325d1522341bca0bdb1f4fd9bfced774164ccf8ccf45c897d1ef364e7 fix-non-x86-build.patch"
+0420d8e18fd900edbdbe7d100ca2b35b0e8a3466cce6846fd44ecba82da942139fab07111f9f6e7b49d11760028f19f17b75a56f0b7a52651450ae03695e0a90 fix-non-x86-build.patch"
diff --git a/main/spice/fix-non-x86-build.patch b/main/spice/fix-non-x86-build.patch
index cca3b1cbe..04a560b12 100644
--- a/main/spice/fix-non-x86-build.patch
+++ b/main/spice/fix-non-x86-build.patch
@@ -1,6 +1,8 @@
+See also: https://bugs.freedesktop.org/show_bug.cgi?id=86997
+
diff -ru spice-0.12.5.orig/client/utils.h spice-0.12.5/client/utils.h
---- spice-0.12.5.orig/client/utils.h 2014-05-14 14:14:34.000000000 -0300
-+++ spice-0.12.5/client/utils.h 2014-12-03 16:49:54.630411626 -0200
+--- spice-0.12.5.orig/client/utils.h 2014-12-04 13:45:13.843329437 -0200
++++ spice-0.12.5/client/utils.h 2014-12-04 13:44:58.449995951 -0200
@@ -50,9 +50,13 @@
throw Exception(exption_string, err); \
}
@@ -15,3 +17,20 @@ diff -ru spice-0.12.5.orig/client/utils.h spice-0.12.5/client/utils.h
template <class T>
class AutoRef {
+diff -ru spice-0.12.5.orig/spice-common/spice-protocol/spice/barrier.h spice-0.12.5/spice-common/spice-protocol/spice/barrier.h
+--- spice-0.12.5.orig/spice-common/spice-protocol/spice/barrier.h 2013-12-10 20:42:54.000000000 -0200
++++ spice-0.12.5/spice-common/spice-protocol/spice/barrier.h 2014-12-04 13:45:54.593329844 -0200
+@@ -34,12 +34,7 @@
+
+ #ifdef __GNUC__
+
+-#ifdef __i386__
+-#define spice_mb() __asm__ __volatile__ ("lock; addl $0,0(%%esp)": : :"memory")
+-#else
+-//mfence
+-#define spice_mb() __asm__ __volatile__ ("lock; addl $0,0(%%rsp)": : :"memory")
+-#endif
++#define spice_mb() __sync_synchronize()
+
+ #else
+