summaryrefslogtreecommitdiffstats
path: root/main/squark
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2014-11-21 13:37:25 +0200
committerTimo Teräs <timo.teras@iki.fi>2014-11-21 13:37:52 +0200
commit1737438dc1b51a7e8f97da50164bc3e2849a3774 (patch)
treef91b156626f237c474e098a083499cbc832031c3 /main/squark
parent6242564feffb32797bff21ecc81df5ade1cf57e7 (diff)
downloadaports-1737438dc1b51a7e8f97da50164bc3e2849a3774.tar.bz2
aports-1737438dc1b51a7e8f97da50164bc3e2849a3774.tar.xz
main/squark: fix lua module
Diffstat (limited to 'main/squark')
-rw-r--r--main/squark/0001-fix-missing-symbols-from-lua-module.patch25
-rw-r--r--main/squark/APKBUILD12
2 files changed, 33 insertions, 4 deletions
diff --git a/main/squark/0001-fix-missing-symbols-from-lua-module.patch b/main/squark/0001-fix-missing-symbols-from-lua-module.patch
new file mode 100644
index 000000000..82b046cae
--- /dev/null
+++ b/main/squark/0001-fix-missing-symbols-from-lua-module.patch
@@ -0,0 +1,25 @@
+From bd36f7e1710fd429c80ef1814beb81db909c177d Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Timo=20Ter=C3=A4s?= <timo.teras@iki.fi>
+Date: Fri, 21 Nov 2014 12:02:46 +0200
+Subject: [PATCH] fix missing symbols from lua module
+
+---
+ src/Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/Makefile b/src/Makefile
+index 8814b15..f8acd32 100644
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -7,7 +7,7 @@ common-objs += filterdb.o authdb.o blob.o addr.o config.o reporting.o
+ squark-filter-objs += squark-filter.o $(common-objs)
+ squark-auth-snmp-objs += squark-auth-snmp.o $(common-objs)
+ squark-auth-ip-objs += squark-auth-ip.o $(common-objs)
+-squarkdb.so-objs += lua-squarkdb.o filterdb.o blob.o
++squarkdb.so-objs += lua-squarkdb.o filterdb.o blob.o reporting.o
+
+ CFLAGS_config.o += -DSQUARK_VERSION=\"$(FULL_VERSION)\" \
+ -DCONFDIR=\"$(CONFDIR)\" \
+--
+2.1.3
+
diff --git a/main/squark/APKBUILD b/main/squark/APKBUILD
index 5e91d71dc..cca07e01a 100644
--- a/main/squark/APKBUILD
+++ b/main/squark/APKBUILD
@@ -1,12 +1,13 @@
# Maintainer: Timo Teras <timo.teras@iki.fi>
pkgname=squark
pkgver=0.6
-pkgrel=0
+pkgrel=1
pkgdesc="Squark - Squid User Authentication and Rating Kit"
subpackages=
depends="haserl"
makedepends="net-snmp-dev cmph-dev lua-dev pkgconfig"
source="http://dev.alpinelinux.org/archive/$pkgname/$pkgname-$pkgver.tar.xz
+ 0001-fix-missing-symbols-from-lua-module.patch
"
url="http://git.alpinelinux.org/cgit/squark/"
arch="all"
@@ -36,6 +37,9 @@ package() {
make FULL_VERSION="$pkgver-r$pkgrel" DESTDIR="$pkgdir" install
}
-md5sums="8e34e77741ec043362b5554b58206ae1 squark-0.6.tar.xz"
-sha256sums="6349f7b2d840712ef3f0f0eb32cbed4d53ede586a06f42807f1cfda888fd2952 squark-0.6.tar.xz"
-sha512sums="ba671d961b1b2d3026625b21336369e3b3dedc867dd8f68e85db3badcdb13afae8565a068e9337de6ba909c8780ff5ff0e59e4bab42f7f02a415f396654ead19 squark-0.6.tar.xz"
+md5sums="8e34e77741ec043362b5554b58206ae1 squark-0.6.tar.xz
+ab48c3bfff96eac6a47267a0ad214363 0001-fix-missing-symbols-from-lua-module.patch"
+sha256sums="6349f7b2d840712ef3f0f0eb32cbed4d53ede586a06f42807f1cfda888fd2952 squark-0.6.tar.xz
+464dcdaf0cb870686dd440b33308a86a44fc14510c1b38c83c561a3e0d492331 0001-fix-missing-symbols-from-lua-module.patch"
+sha512sums="ba671d961b1b2d3026625b21336369e3b3dedc867dd8f68e85db3badcdb13afae8565a068e9337de6ba909c8780ff5ff0e59e4bab42f7f02a415f396654ead19 squark-0.6.tar.xz
+8824afa6f576f6e0f39381ba52874c6d17a1e4d5db6af6539b54d4aeb6ec85abf6324eb9f1cbee0a40b34cc3fd9c207a25726e6d21f02e9b4f50513f488c0dc0 0001-fix-missing-symbols-from-lua-module.patch"