summaryrefslogtreecommitdiffstats
path: root/main/sylpheed
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-04-25 18:44:18 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-04-25 19:53:05 +0000
commit6e2e5071c7e3304c783f346c7bd89b7e68a99858 (patch)
treedaaee81c7edf5f0abf9315a636cfd4d553478120 /main/sylpheed
parent48666073f2513d5731f56210a562129da274c277 (diff)
downloadaports-6e2e5071c7e3304c783f346c7bd89b7e68a99858.tar.bz2
aports-6e2e5071c7e3304c783f346c7bd89b7e68a99858.tar.xz
main/sylpheed: fix build against glib-2.32
Diffstat (limited to 'main/sylpheed')
-rw-r--r--main/sylpheed/APKBUILD20
-rw-r--r--main/sylpheed/glib.patch26
-rw-r--r--main/sylpheed/gmodule.patch11
3 files changed, 54 insertions, 3 deletions
diff --git a/main/sylpheed/APKBUILD b/main/sylpheed/APKBUILD
index 6eb592625..7a542bc38 100644
--- a/main/sylpheed/APKBUILD
+++ b/main/sylpheed/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=sylpheed
pkgver=3.1.3
-pkgrel=0
+pkgrel=1
pkgdesc="Lightweight and user-friendly e-mail client"
url="http://sylpheed.sraoss.jp/en/"
arch="all"
@@ -9,7 +9,19 @@ license="GPL"
depends=
makedepends="gtk+-dev openldap-dev openssl-dev"
subpackages="$pkgname-dev $pkgname-lang"
-source="http://$pkgname.sraoss.jp/$pkgname/v${pkgver%.*}/$pkgname-$pkgver.tar.bz2"
+source="http://$pkgname.sraoss.jp/$pkgname/v${pkgver%.*}/$pkgname-$pkgver.tar.bz2
+ glib.patch
+ gmodule.patch
+ "
+
+prepare() {
+ cd "$srcdir/sylpheed-$pkgver"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
build() {
cd "$srcdir/sylpheed-$pkgver"
@@ -24,4 +36,6 @@ package() {
make DESTDIR="$pkgdir" install || return 1
find "$pkgdir" -name '*.la' -delete
}
-md5sums="2ad17c0f822b266d83dfba11c3088659 sylpheed-3.1.3.tar.bz2"
+md5sums="2ad17c0f822b266d83dfba11c3088659 sylpheed-3.1.3.tar.bz2
+8add7f81d58958ba4ed5680e8fcc4c80 glib.patch
+e9a3795219bc9c6cafc1cc360eeb9854 gmodule.patch"
diff --git a/main/sylpheed/glib.patch b/main/sylpheed/glib.patch
new file mode 100644
index 000000000..baa258bb4
--- /dev/null
+++ b/main/sylpheed/glib.patch
@@ -0,0 +1,26 @@
+Index: libsylph/defs.h
+===================================================================
+--- ./libsylph/defs.h (revision 3032)
++++ ./libsylph/defs.h (revision 3033)
+@@ -1,6 +1,6 @@
+ /*
+ * LibSylph -- E-Mail client library
+- * Copyright (C) 1999-2010 Hiroyuki Yamamoto
++ * Copyright (C) 1999-2012 Hiroyuki Yamamoto
+ *
+ * This library is free software; you can redistribute it and/or
+ * modify it under the terms of the GNU Lesser General Public
+@@ -24,12 +24,8 @@
+ # include "config.h"
+ #endif
+
+-#include <glibconfig.h>
++#include <glib.h>
+
+-#ifdef G_OS_WIN32
+-# include <glib/gwin32.h>
+-#endif
+-
+ #if HAVE_PATHS_H
+ # include <paths.h>
+ #endif
diff --git a/main/sylpheed/gmodule.patch b/main/sylpheed/gmodule.patch
new file mode 100644
index 000000000..150fc786d
--- /dev/null
+++ b/main/sylpheed/gmodule.patch
@@ -0,0 +1,11 @@
+--- ./src/Makefile.in.orig
++++ ./src/Makefile.in
+@@ -88,7 +88,7 @@
+ GPGME_LIBS = @GPGME_LIBS@
+ GREP = @GREP@
+ GTK_CFLAGS = @GTK_CFLAGS@
+-GTK_LIBS = @GTK_LIBS@
++GTK_LIBS = @GTK_LIBS@ -lgmodule-2.0
+ INSTALL_DATA = @INSTALL_DATA@
+ INSTALL_PROGRAM = @INSTALL_PROGRAM@
+ INSTALL_SCRIPT = @INSTALL_SCRIPT@