summaryrefslogtreecommitdiffstats
path: root/main/syslog-ng
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-11-06 09:26:43 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-11-06 09:26:43 +0000
commitdbfbb9b88abcc2522e8e46b6db218dca09771bb2 (patch)
treef72dbc18461422ea5e05027e9faa0133b6793faf /main/syslog-ng
parentec0afeea4567c35a0eda0f664b4649b1ab006645 (diff)
downloadaports-dbfbb9b88abcc2522e8e46b6db218dca09771bb2.tar.bz2
aports-dbfbb9b88abcc2522e8e46b6db218dca09771bb2.tar.xz
main/syslog-ng: move from testing
Diffstat (limited to 'main/syslog-ng')
-rw-r--r--main/syslog-ng/APKBUILD80
-rw-r--r--main/syslog-ng/syslog-ng-destination.std22
-rw-r--r--main/syslog-ng/syslog-ng-filter.std34
-rw-r--r--main/syslog-ng/syslog-ng-log.std56
-rw-r--r--main/syslog-ng/syslog-ng-options.std37
-rw-r--r--main/syslog-ng/syslog-ng-source.std10
-rw-r--r--main/syslog-ng/syslog-ng.initd76
-rw-r--r--main/syslog-ng/syslog-ng.logrotate40
-rw-r--r--main/syslog-ng/syslog-ng.post-install6
9 files changed, 361 insertions, 0 deletions
diff --git a/main/syslog-ng/APKBUILD b/main/syslog-ng/APKBUILD
new file mode 100644
index 000000000..63fce4800
--- /dev/null
+++ b/main/syslog-ng/APKBUILD
@@ -0,0 +1,80 @@
+# Contributor: jv <jens@eisfair.org>
+# Maintainer: jv <jens@eisfair.org>
+pkgname=syslog-ng
+pkgver=2.1.4
+pkgrel=1
+pkgdesc="Next generation logging daemon"
+url="http://www.balabit.com"
+arch="all"
+license="GPLv2"
+depends=""
+depends_dev="glib-dev libeventlog-dev"
+makedepends="$depends_dev"
+install="$pkgname.post-install"
+subpackages=""
+
+source="http://www.balabit.com/downloads/files/syslog-ng/open-source-edition/${pkgver}/source/syslog-ng_${pkgver}.tar.gz
+ syslog-ng.logrotate
+ syslog-ng.initd
+ syslog-ng-destination.std
+ syslog-ng-filter.std
+ syslog-ng-log.std
+ syslog-ng-options.std
+ syslog-ng-source.std
+ "
+
+_builddir="$srcdir/${pkgname}-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc/syslog-ng \
+ --enable-ipv6 \
+ --disable-sql \
+ --disable-mongodb \
+ --disable-json \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make -j1 DESTDIR=${pkgdir} install || return 1
+ rm -rf ${pkgdir}/usr/share
+ install -D -m755 "$srcdir"/$pkgname.initd ${pkgdir}/etc/init.d/$pkgname || return 1
+ install -D -m644 "$srcdir"/syslog-ng-destination.std ${pkgdir}/etc/syslog-ng/syslog-ng-destination.std || return 1
+ install -D -m644 "$srcdir"/syslog-ng-filter.std ${pkgdir}/etc/syslog-ng/syslog-ng-filter.std || return 1
+ install -D -m644 "$srcdir"/syslog-ng-log.std ${pkgdir}/etc/syslog-ng/syslog-ng-log.std || return 1
+ install -D -m644 "$srcdir"/syslog-ng-options.std ${pkgdir}/etc/syslog-ng/syslog-ng-options.std || return 1
+ install -D -m644 "$srcdir"/syslog-ng-source.std ${pkgdir}/etc/syslog-ng/syslog-ng-source.std || return 1
+ install -D -m644 "$srcdir"/syslog-ng.logrotate ${pkgdir}/etc/logrotate.d/syslog-ng || return 1
+}
+
+md5sums="17c4c7725d2eab62b588395f1ed93f32 syslog-ng_2.1.4.tar.gz
+8916d55f8213d2746e8c2a6a89c29d6c syslog-ng.logrotate
+91cb6aedf897eebcedd6b6250882d9bf syslog-ng.initd
+f0b4a0b530e269c51bc63f5b9d817c9b syslog-ng-destination.std
+405f4730412fec3a170460d724a6b50e syslog-ng-filter.std
+bc676f733ea162ea4de7a8c2a16c06ed syslog-ng-log.std
+f15a2b7c8496038c29d3ca7adc8d4054 syslog-ng-options.std
+8c166661270cd8459897ca3df06066c9 syslog-ng-source.std"
+sha256sums="e2189c7dbf617f2fc883ab0a8a86100dbe7cb4853c6b39732d77e73f335b0502 syslog-ng_2.1.4.tar.gz
+a886b65863d72476504165e6a6dfe3d2922945d8cb61adb6b8eec73ac35d825e syslog-ng.logrotate
+f24a042b7213873f9c3d09afc4a442dc61dee67e2d6ca72da387714f8daa0862 syslog-ng.initd
+bd3097c1d8ff6754df0d7e470659827ae4d6bf86976badf5aabe4d25504fd572 syslog-ng-destination.std
+4ee19a76624624a9742f3399887784a55f684d141e115996b82c593aa74dcb66 syslog-ng-filter.std
+df30f0ce37bdf8cc0ac0fcc04800d7d14880bf3a19d01ab96220a325f1ab3943 syslog-ng-log.std
+8d925e7272a8d7dbda42694fe0e9c6fdc1bee6ffd9d4adf78e0ebb183658d4d4 syslog-ng-options.std
+51399e8d5d3a2d7b2d30f4adefe92776c9ddcae98d5189af9ddae1d2e66db8f3 syslog-ng-source.std"
+sha512sums="5ff5e3a36dbcb99a3b1b36cda3336764290bd9251379244f10a48bd396785d16ed9200d746acb66f69f471d9ce1e8ec2e337afdadd109d7eba0c12d0de403ae0 syslog-ng_2.1.4.tar.gz
+a062d1601f5215f60e2fc40c6ca498d768aa97af3647a9468731123a28fdd67962421b4412bfbe08a1123141b730cb78f102230ab72befec05ba7f398b39e27a syslog-ng.logrotate
+7dc6af65b7c663b85aa4ad1ddb737a48e808631207330de8197afce7abb986d790a02ca65d86bd87d77fe1bbd3e3f9f4257be81ade047468a3ea9fe3f7e64c3a syslog-ng.initd
+b51d8b3da9584b6cb5b5c023b5ca1085d8e4c2cfa56f6ed12fe6feb0f33a390b43825aaaf4dd74eb6b7765485fe42f7f21c74380b72de9ed2c7775787ab1e720 syslog-ng-destination.std
+e04a70a0b8fc4f40951c9b608b0dede1fa561dd7f58ce8fd8bac70b578b749d15d202973fd9de9fe494656ee138ef5efd32ea6229e6ec0a2f19672dd621acc91 syslog-ng-filter.std
+d7864f6666101e0818dd0178a4d1ada2417280de153ff916fe4879348a37b7bfab5936e86629dc52e4edf82fbd601e04d08ed5a2117bcb0470a3d5884add9f55 syslog-ng-log.std
+9f4224faf45c73daa54549aebf20e2c45d0bf533a20d2ad97d7258490ce793c8b08cc34cac2a89d185e936515096eb93c793018986c8d21861d88c4b0005d16a syslog-ng-options.std
+fe4e4921426ea58186d1fbc54d36a2ba7a88992e7b1ce9b1a41470e4f791b6c7850d34785ec458d2793399b8de1a25ef2b290a95437083fd350b3925d11b9aea syslog-ng-source.std"
diff --git a/main/syslog-ng/syslog-ng-destination.std b/main/syslog-ng/syslog-ng-destination.std
new file mode 100644
index 000000000..93bc3030a
--- /dev/null
+++ b/main/syslog-ng/syslog-ng-destination.std
@@ -0,0 +1,22 @@
+# ---------------------------------------------------------------------------------
+# Default syslog-ng standard log files; Do not edit this file!
+# append log file entry with line on a file: syslog-ng-destination.<package>
+# ---------------------------------------------------------------------------------
+ destination df_auth { file("/var/log/auth.log"); };
+ destination df_kern { file("/var/log/kern.log"); };
+ destination df_mail { file("/var/log/mail.log"); };
+ destination df_error { file("/var/log/error.log"); };
+# these files are meant for the mail system log files
+# and provide re-usable destinations for {mail,cron,...}.info,
+# {mail,cron,...}.notice, etc.
+ destination df_facility_dot_info { file("/var/log/$FACILITY.info"); };
+ destination df_facility_dot_notice { file("/var/log/$FACILITY.notice"); };
+ destination df_facility_dot_warn { file("/var/log/$FACILITY.warn"); };
+ destination df_facility_dot_err { file("/var/log/$FACILITY.err"); };
+ destination df_facility_dot_crit { file("/var/log/$FACILITY.crit"); };
+# some more classical and useful files found in standard syslog configurations
+ destination df_debug { file("/var/log/debug"); };
+ destination df_messages { file("/var/log/messages"); };
+# consoles
+# this will send messages to everyone logged in
+ destination du_all { usertty("*"); };
diff --git a/main/syslog-ng/syslog-ng-filter.std b/main/syslog-ng/syslog-ng-filter.std
new file mode 100644
index 000000000..29251f759
--- /dev/null
+++ b/main/syslog-ng/syslog-ng-filter.std
@@ -0,0 +1,34 @@
+# ---------------------------------------------------------------------------------
+# Default syslog-ng standard filters; Do not edit this file!
+# append filter entry with line on a file: syslog-ng-filter.<package>
+# ---------------------------------------------------------------------------------
+# all messages from the auth and authpriv facilities
+ filter f_auth { facility(auth,authpriv); };
+# respectively: messages from the cron, daemon, kern, lpr, mail, news, user,
+# and uucp facilities
+ filter f_cron { facility(cron); };
+ filter f_daemon { facility(daemon); };
+ filter f_kern { facility(kern); };
+ filter f_lpr { facility(lpr); };
+ filter f_mail { facility(mail); };
+ filter f_news { facility(news); };
+ filter f_user { facility(user); };
+ filter f_uucp { facility(uucp); };
+ filter f_ftp { facility(ftp); };
+# some filters to select messages of priority greater or equal to info, warn,
+# and err (equivalents of syslogd's *.info, *.warn, and *.err)
+ filter f_at_least_info { level(info..emerg); };
+ filter f_at_least_notice { level(notice..emerg); };
+ filter f_at_least_warn { level(warn..emerg); };
+ filter f_at_least_err { level(err..emerg); };
+ filter f_at_least_crit { level(crit..emerg); };
+# all messages of priority debug not coming from the auth, authpriv, news, and
+# mail facilities
+ filter f_debug { level(debug) and not facility(auth,authpriv,kern,mail); };
+# all messages of info, notice, or warn priority not coming form the auth, authpriv,
+# kern and mail facilities
+ filter f_messages { level(info,notice,warn) and not facility(auth,authpriv,kern,mail,ftp); };
+# messages with priority emerg
+ filter f_emerg { level(emerg); };
+# mysql syslog write all messages to err level
+ filter f_err_no_mysqld { level(err..emerg) and not program(mysqld); };
diff --git a/main/syslog-ng/syslog-ng-log.std b/main/syslog-ng/syslog-ng-log.std
new file mode 100644
index 000000000..a8cc402b1
--- /dev/null
+++ b/main/syslog-ng/syslog-ng-log.std
@@ -0,0 +1,56 @@
+# ---------------------------------------------------------------------------------
+# Default syslog-ng logs; Do not edit this file!
+# append log with line on a file: syslog-ng-log.<package>
+# ---------------------------------------------------------------------------------
+# order matters if you use "flags(final);" to mark the end of processing in a
+# "log" statement
+# these rules provide the same behavior as the commented original syslogd rules
+
+# auth,authpriv.* /var/log/auth.log
+log {
+ source(s_all);
+ filter(f_auth);
+ destination(df_auth);
+};
+
+# kern.* -/var/log/kern.log
+log {
+ source(s_all);
+ filter(f_kern);
+ destination(df_kern);
+};
+
+# mail.* -/var/log/mail.log
+log {
+ source(s_all);
+ filter(f_mail);
+ destination(df_mail);
+};
+# *.=debug;
+# auth,authpriv.none;\
+# news.none;mail.none -/var/log/debug
+log {
+ source(s_all);
+ filter(f_debug);
+ destination(df_debug);
+};
+# *.=info;*.=notice;*.=warn;\
+# auth,authpriv.none;\
+# mail,news.none -/var/log/messages
+log {
+ source(s_all);
+ filter(f_messages);
+ destination(df_messages);
+};
+# error ... emergency /var/log/error.log
+log {
+ source(s_all);
+ filter(f_err_no_mysqld);
+ destination(df_error);
+};
+# *.emerg *
+log {
+ source(s_all);
+ filter(f_emerg);
+ destination(du_all);
+};
diff --git a/main/syslog-ng/syslog-ng-options.std b/main/syslog-ng/syslog-ng-options.std
new file mode 100644
index 000000000..6e9fe75e5
--- /dev/null
+++ b/main/syslog-ng/syslog-ng-options.std
@@ -0,0 +1,37 @@
+# ---------------------------------------------------------------------------------
+# Default syslog-ng standard options; Do not edit this file!
+# Append entry with line on a file: syslog-ng-options.<package>
+# ---------------------------------------------------------------------------------
+# disable the chained hostname format in logs
+# (default is enabled)
+ chain_hostnames(0);
+# the time to wait before a died connection is re-established (default is 60)
+ time_reopen(10);
+# the time to wait before an idle destination file is closed (default is 60)
+ time_reap(360);
+# the number of lines buffered before written to file you might want to
+# increase this if your disk isn't catching with all the log messages you get
+# or if you want less disk activity (say on a laptop) (default is 0)
+#sync(0);
+# the number of lines fitting in the output queue
+ log_fifo_size(2048);
+# enable or disable directory creation for destination files
+ create_dirs(yes);
+# default owner, group, and permissions for log files (defaults are 0, 0, 0600)
+#owner(root);
+ group(adm);
+ perm(0640);
+# default owner, group, and permissions for created directories (defaults are 0, 0, 0700)
+#dir_owner(root);
+#dir_group(root);
+ dir_perm(0755);
+# enable or disable DNS. Usage syslog-ng blocks on DNS queries, so enabling DNS
+# may lead to a Denial of Service attack (default is yes)
+ use_dns(no);
+# maximum length of message in bytes. This is only limited by the program
+# listening on the /dev/log Unix socket, glibc can handle arbitrary length
+# log messages, but -- for example -- syslogd accepts only 1024 bytes
+# (default is 2048)
+#log_msg_size(2048);
+# Disable statistic log messages.
+ stats_freq(0);
diff --git a/main/syslog-ng/syslog-ng-source.std b/main/syslog-ng/syslog-ng-source.std
new file mode 100644
index 000000000..80a25feb0
--- /dev/null
+++ b/main/syslog-ng/syslog-ng-source.std
@@ -0,0 +1,10 @@
+# ---------------------------------------------------------------------------------
+# Default syslog-ng sources; Do not edit this file!
+# append source with line on a file: syslog-ng-source.<package>
+# ---------------------------------------------------------------------------------
+# message generated by Syslog-NG
+ internal();
+# standard Linux log source (this is the default place for the syslog() function to send logs to)
+ unix-dgram("/dev/log");
+# messages from the kernel
+ file("/proc/kmsg" log_prefix("kernel: "));
diff --git a/main/syslog-ng/syslog-ng.initd b/main/syslog-ng/syslog-ng.initd
new file mode 100644
index 000000000..647c1058c
--- /dev/null
+++ b/main/syslog-ng/syslog-ng.initd
@@ -0,0 +1,76 @@
+#!/sbin/runscript
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+extra_commands="update"
+extra_started_commands="reload"
+
+depend() {
+ need hostname localmount
+ before net
+ provide logger
+}
+
+start() {
+ [ ! -f /etc/syslog-ng/syslog.conf ] && update
+ ebegin "Starting syslog-ng"
+ start-stop-daemon --start --quiet --exec /usr/sbin/syslog-ng --pidfile /run/syslog-ng.pid
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping syslog-ng"
+ start-stop-daemon --stop --quiet --pidfile /run/syslog-ng.pid --exec /usr/sbin/syslog-ng
+ eend $?
+}
+
+reload() {
+ if [ ! -f /run/syslog-ng.pid ]
+ then
+ eerror "syslog-ng not running!"
+ return 1
+ fi
+ ebegin "Reloading syslog-ng"
+ start-stop-daemon --signal HUP --pidfile /run/syslog-ng.pid --exec /usr/sbin/syslog-ng
+ eend $?
+}
+
+grep_syslog_conf_entries() {
+ local section="$1" FN filelist
+ grep -v '^#' /etc/syslog-ng/syslog-ng-${section}.std
+ filelist=$(find /etc/syslog-ng/ -maxdepth 1 -type f -name "syslog-ng-${section}.*" | grep -Ev ".backup|.std|~")
+ if [ $? -eq 0 ]
+ then
+ for FN in ${filelist}
+ do
+ grep -v '^#' $FN
+ done
+ fi
+}
+
+update() {
+ local fname='/etc/syslog-ng/syslog-ng.conf'
+ local f_tmp="/etc/syslog-ng/syslog-ng.conf.$$"
+ for ng_std in options source destination filter log
+ do
+ [ -f /etc/syslog-ng/syslog-ng-${ng_std}.std ] || exit 1
+ done
+ {
+ # create options entries
+ echo "options {"
+ grep_syslog_conf_entries options
+ echo "};"
+ # create source entries
+ echo "source s_all {"
+ grep_syslog_conf_entries source
+ echo "};"
+ # create destination entries
+ grep_syslog_conf_entries destination
+ # create filter entries
+ grep_syslog_conf_entries filter
+ # create log entries
+ grep_syslog_conf_entries log
+ } > $f_tmp
+ cp -p $f_tmp $fname
+ rm -f $f_tmp
+}
diff --git a/main/syslog-ng/syslog-ng.logrotate b/main/syslog-ng/syslog-ng.logrotate
new file mode 100644
index 000000000..c3fd09341
--- /dev/null
+++ b/main/syslog-ng/syslog-ng.logrotate
@@ -0,0 +1,40 @@
+/var/log/auth.log {
+ rotate 14
+ daily
+ missingok
+ notifempty
+ compress
+ postrotate
+ /etc/init.d/syslog-ng reload >/dev/null
+ endscript
+}
+
+/var/log/mail.log /var/log/mail.info /var/log/mail.warn /var/log/mail.err {
+ rotate 8
+ weekly
+ missingok
+ notifempty
+ compress
+}
+
+/var/log/kern.log {
+ rotate 2
+ monthly
+ missingok
+ notifempty
+ compress
+ postrotate
+ /etc/init.d/syslog-ng reload >/dev/null
+ endscript
+}
+
+/var/log/messages /var/log/error.log {
+ rotate 14
+ weekly
+ missingok
+ notifempty
+ compress
+ postrotate
+ /etc/init.d/syslog-ng reload >/dev/null
+ endscript
+}
diff --git a/main/syslog-ng/syslog-ng.post-install b/main/syslog-ng/syslog-ng.post-install
new file mode 100644
index 000000000..ea2a5c2b2
--- /dev/null
+++ b/main/syslog-ng/syslog-ng.post-install
@@ -0,0 +1,6 @@
+#!/bin/sh
+
+[ ! -f /var/log/auth.log ] && touch /var/log/auth.log
+[ ! -f /var/log/error.log ] && touch /var/log/error.log
+[ ! -f /var/log/mail.log ] && touch /var/log/mail.log
+[ ! -f /var/log/kern.log ] && touch /var/log/kern.log