summaryrefslogtreecommitdiffstats
path: root/main/u-boot
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2015-01-23 06:37:53 +0000
committerTimo Teräs <timo.teras@iki.fi>2015-01-23 06:37:53 +0000
commit94818ae4e8c7e0315182656a872917b940f97dd7 (patch)
treef2793dd464b88de95afc8037a6f4c7db258e561f /main/u-boot
parent38758a863fca19a29cf32e9ea55f181b15623d23 (diff)
downloadaports-94818ae4e8c7e0315182656a872917b940f97dd7.tar.bz2
aports-94818ae4e8c7e0315182656a872917b940f97dd7.tar.xz
main/u-boot: do not include unneeded boot loader files
they just take up space
Diffstat (limited to 'main/u-boot')
-rw-r--r--main/u-boot/APKBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/main/u-boot/APKBUILD b/main/u-boot/APKBUILD
index 36c26d5fe..9cd3ad314 100644
--- a/main/u-boot/APKBUILD
+++ b/main/u-boot/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
pkgname=u-boot
pkgver=2015.01
-pkgrel=0
+pkgrel=1
pkgdesc="Bootloader for ARM"
url="http://www.denx.de/wiki/U-Boot/"
arch="armhf"
@@ -77,12 +77,12 @@ _split_boards() {
msg "Including board $board"
mkdir -p "$subpkgdir"/usr/share/$pkgname/$board
export BUILD_DIR="$_builddir"/$board
- if [ -e "$BUILD_DIR"/MLO ]; then
- cp "$BUILD_DIR"/MLO \
- "$subpkgdir"/usr/share/$pkgname/$board || return 1
- fi
- cp "$BUILD_DIR"/u-boot.* \
- "$subpkgdir"/usr/share/$pkgname/$board || return 1
+ for image in MLO u-boot.imx u-boot.img; do
+ if [ -e "$BUILD_DIR"/$image ]; then
+ cp "$BUILD_DIR"/$image "$subpkgdir"/usr/share/$pkgname/$board \
+ || return 1
+ fi
+ done
done
}