summaryrefslogtreecommitdiffstats
path: root/main/unbound/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-10-23 20:22:30 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-10-23 20:22:30 +0000
commit087c3e31555b102ce900c5a0b05cf4c5b185ee88 (patch)
treebc473d5a907e458fd8e6bec8caf759b137d42463 /main/unbound/APKBUILD
parentcc7ab0ab786dc7c81d32fea69344cd5298c32c1d (diff)
downloadaports-087c3e31555b102ce900c5a0b05cf4c5b185ee88.tar.bz2
aports-087c3e31555b102ce900c5a0b05cf4c5b185ee88.tar.xz
main/unbound: moved from testing
Diffstat (limited to 'main/unbound/APKBUILD')
-rw-r--r--main/unbound/APKBUILD78
1 files changed, 78 insertions, 0 deletions
diff --git a/main/unbound/APKBUILD b/main/unbound/APKBUILD
new file mode 100644
index 000000000..14dfbf23c
--- /dev/null
+++ b/main/unbound/APKBUILD
@@ -0,0 +1,78 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=unbound
+pkgver=1.4.13
+pkgrel=1
+pkgdesc="Unbound is a validating, recursive, and caching DNS resolver"
+pkgusers="unbound"
+pkggroups="unbound"
+url="http://unbound.net/"
+arch="all"
+license="BSD"
+depends="dnssec-root"
+depends_dev="openssl-dev expat-dev ldns-dev libevent-dev"
+makedepends="$depends_dev python-dev swig"
+install="$pkgname.pre-install"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-libs py-unbound:py"
+source="http://unbound.net/downloads/unbound-$pkgver.tar.gz
+ unbound-1.4.12-gentoo.patch
+ unbound.initd"
+
+_builddir="$srcdir"/unbound-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --with-pidfile=/var/run/unbound/unbound.pid \
+ --with-username=unbound \
+ --with-libevent \
+ --with-ldns \
+ --with-pthreads \
+ --with-rootkey-file=/usr/share/dnssec/root-anchors.txt \
+ --disable-static \
+ --disable-rpath \
+ --with-ssl \
+ --with-pythonmodule \
+ --with-pyunbound \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm "$pkgdir"/usr/lib/*.la \
+ "$pkgdir"/usr/lib/python*/*/*.la || return 1
+ install -D contrib/update-anchor.sh \
+ "$pkgdir"/usr/share/$pkgname/update-anchor.sh \
+ || return 1
+ install -m755 -D "$srcdir"/unbound.initd \
+ "$pkgdir"/etc/init.d/unbound || return 1
+ install -d -o unbound -g unbound "$pkgdir"/var/run/unbound
+}
+
+libs() {
+ pkgdesc="unbound shared libraries"
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/lib*.so.* "$subpkgdir"/usr/lib/
+}
+
+py() {
+ pkgdesc="Python bindings to libunbound"
+ mkdir -p "$subpkgdir"/usr/lib/
+ mv "$pkgdir"/usr/lib/python* "$subpkgdir"/usr/lib/
+}
+
+md5sums="7e3b27dee2b97640dd2e1783253317ab unbound-1.4.13.tar.gz
+a6d84d596e40da79fcd52529b7fb5046 unbound-1.4.12-gentoo.patch
+ebf2b5f8e1be2c4dbec9c5fad1e0e0de unbound.initd"