summaryrefslogtreecommitdiffstats
path: root/main/uwsgi
diff options
context:
space:
mode:
authorBartłomiej Piotrowski <bpiotrowski@alpinelinux.org>2015-05-02 16:30:24 +0200
committerBartłomiej Piotrowski <bpiotrowski@alpinelinux.org>2015-05-02 16:30:24 +0200
commite430f314f129e5b6fc6d5058ff3e570d1f0ef1b9 (patch)
treea1fb71b994927ec3c0e216a3396a335b889cbe1f /main/uwsgi
parentccb632a4b55af786da72eca0cd8a22aa6f4ea4b3 (diff)
downloadaports-e430f314f129e5b6fc6d5058ff3e570d1f0ef1b9.tar.bz2
aports-e430f314f129e5b6fc6d5058ff3e570d1f0ef1b9.tar.xz
testing/uwsgi: move to main
Diffstat (limited to 'main/uwsgi')
-rw-r--r--main/uwsgi/APKBUILD15
-rw-r--r--main/uwsgi/uwsgi.initd2
2 files changed, 10 insertions, 7 deletions
diff --git a/main/uwsgi/APKBUILD b/main/uwsgi/APKBUILD
index fa8c68cae..bc7c5e459 100644
--- a/main/uwsgi/APKBUILD
+++ b/main/uwsgi/APKBUILD
@@ -9,7 +9,7 @@ arch=all
license=GPL-2
depends=mailcap
makedepends="linux-headers lua5.2-dev python python-dev zeromq-dev paxmark
- pcre-dev"
+ pcre-dev python3 python3-dev"
source="http://projects.unbit.it/downloads/uwsgi-${pkgver}.tar.gz
uwsgi.initd uwsgi.confd
@@ -21,7 +21,7 @@ source="http://projects.unbit.it/downloads/uwsgi-${pkgver}.tar.gz
musl-locking-fix.patch
"
-_plugins="lua python router_uwsgi"
+_plugins="lua python python3 router_uwsgi"
subpackages=""
for _p in $_plugins ; do
subpackages="$subpackages uwsgi-$_p:_$_p"
@@ -46,10 +46,13 @@ build() {
CC="gcc" python uwsgiconfig.py --build core || return 1
export UWSGICONFIG_LUAPC="lua5.2"
- for i in $_plugins; do
+ for i in ${_plugins/python3}; do
msg "building $i plugin"
python uwsgiconfig.py --plugin plugins/$i core || return 1
done
+
+ # build python3 plugin
+ python3 uwsgiconfig.py --plugin plugins/python core python3 || return 1
}
package() {
@@ -83,7 +86,7 @@ for _p in $_plugins; do
done
md5sums="7a9be0db5f6a8d4150dc5e9e0517ce80 uwsgi-2.0.10.tar.gz
-6b285debf97aac42f6c1289f3625017e uwsgi.initd
+23b476a8ad6aab93b162e8eeec50c859 uwsgi.initd
3d6afe6a8c52556d1d6c52384fc38d9a uwsgi.confd
a7f98e2775e9f38a0f16c28332745836 0001-use-portable-pthread-functions-instead-of-the-non-po.patch
b40fe76f34674874815c39a7e611f259 0002-Check-for-GNU-libc-instead-of-linux-for-use-of-execi.patch
@@ -92,7 +95,7 @@ b40fe76f34674874815c39a7e611f259 0002-Check-for-GNU-libc-instead-of-linux-for-u
87c16f6fe482c9b0eac0d33c51873f45 musl-fix-python.patch
0ad5fe4340891bb9e1ee2d598add7a4a musl-locking-fix.patch"
sha256sums="c0b381d6c22da931e85e3efe612629fe33a01ac25b0f028aa631b85d86d5028b uwsgi-2.0.10.tar.gz
-9463bd286fa3cae72e65037766c3fe2847d10f95c7e920de16b2046b971c3799 uwsgi.initd
+df99bc13609a526432afaeb16661086c73f49394e069a19ccb7423bbd025168f uwsgi.initd
4cb047e311aecd0f498da1d6a4c0947dd6dc7cc98575d54cb2ef150cacf8425c uwsgi.confd
b61bf4da3d022ddfd93a73196300cb86d962f8f6198079d11b727f61c0f8acb4 0001-use-portable-pthread-functions-instead-of-the-non-po.patch
360ede589ad228f31dd06fbf8dc17d86d60e968ae76a61b3ca258a2c5ae6f007 0002-Check-for-GNU-libc-instead-of-linux-for-use-of-execi.patch
@@ -101,7 +104,7 @@ b61bf4da3d022ddfd93a73196300cb86d962f8f6198079d11b727f61c0f8acb4 0001-use-porta
3838e8e3926a1f6271bb5aa88d309837a3bcd06cd570c499b72ca549326c682e musl-fix-python.patch
1540ceee3eadb4c62ca1a9d7a585cb4d4bd6cb01d206773c0a938ca6300f0b5a musl-locking-fix.patch"
sha512sums="027f2ad94f5213f5de13c08670a5f084b7d4e5aa1670550fd5ff012d016f8c0e162dbd3962d5a3d16e5202996141bb92bb025e4c0ef40a646cfb6f2368aec857 uwsgi-2.0.10.tar.gz
-00a7e3ce888724716d1245eb7676062c5270098ea0429a12c82623db0806bb098872df7ebda38ad5ae796d8ac34d23f71d67af76ddce82f3669565ff034c1a2c uwsgi.initd
+5d8eadba7c6ee17f86c3dbb6b7c98131ecf9db173156e3196909550954dd09be2191285f46fd4e558f0c47a0cbe7831cde71d3d4c63862d11b819660cc418131 uwsgi.initd
9f00afb2aa574bbc59040f945475712b8c40da0c06eeb5699de5510aa116148e35ab0429fa891084cf0cd7868876d5a80e1601b7c85d0e2e9ea2a1f54cdde619 uwsgi.confd
d105c487d8bd0b496cfac2dad6090f0e420805a83dca514bfbea97c687be26d7a8b9545add0f999cb67eb66818b05995405f9a874b970f53aa38ff5ce3bbdc02 0001-use-portable-pthread-functions-instead-of-the-non-po.patch
f4038ab866f445a94e155f4b73d308959c402e81227401bc7a5fe2165b888a2c8d95141245a2c10b186782934a4103c785769afaf4091fe3fe5524ed3c270fcf 0002-Check-for-GNU-libc-instead-of-linux-for-use-of-execi.patch
diff --git a/main/uwsgi/uwsgi.initd b/main/uwsgi/uwsgi.initd
index 6dc33377e..0f330d568 100644
--- a/main/uwsgi/uwsgi.initd
+++ b/main/uwsgi/uwsgi.initd
@@ -1,4 +1,4 @@
-#!/sbin/openrc-run
+#!/sbin/runscript
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: /var/cvsroot/gentoo-x86/www-servers/uwsgi/files/uwsgi.initd-r3,v 1.1 2013/03/01 09:50:06 ultrabug Exp $