summaryrefslogtreecommitdiffstats
path: root/main/valgrind
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-08-16 12:23:39 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-08-16 12:23:39 +0000
commit92f0c4a8fb6a46befb00de60325acfd5efffd771 (patch)
tree60ea4df568df188f562fab1d029193e9e6a2ed1d /main/valgrind
parentfeacdad55cd3a8148f0210b5c7b08bab599d6c18 (diff)
downloadaports-92f0c4a8fb6a46befb00de60325acfd5efffd771.tar.bz2
aports-92f0c4a8fb6a46befb00de60325acfd5efffd771.tar.xz
main/valgrind: build fix for gcc-4.8
Diffstat (limited to 'main/valgrind')
-rw-r--r--main/valgrind/APKBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/main/valgrind/APKBUILD b/main/valgrind/APKBUILD
index beebe5585..cdf0555d4 100644
--- a/main/valgrind/APKBUILD
+++ b/main/valgrind/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=valgrind
pkgver=3.8.1
-pkgrel=0
+pkgrel=1
pkgdesc="A tool to help find memory-management problems in programs"
url="http://valgrind.org/"
arch="all"
@@ -13,7 +13,7 @@ makedepends="sed paxctl pax-utils perl bash"
# Don't strip the debug info off lib/valgrind/$platform/vgpreload*.so
# in the installation tree. Either Valgrind won't work at all, or it
# will still work if you do, but will generate less helpful error
-# messages.
+# messages.
options="!strip"
subpackages="$pkgname-dev $pkgname-doc"
source="http://$pkgname.org/downloads/$pkgname-$pkgver.tar.bz2
@@ -23,11 +23,10 @@ source="http://$pkgname.org/downloads/$pkgname-$pkgver.tar.bz2
_builddir="$srcdir"/$pkgname-$pkgver
prepare() {
cd "$_builddir"
- local i
- for i in "$srcdir"/*.patch; do
- [ -f "$i" ] || continue
- msg "Applying $i"
- patch -p1 < $i || return 1
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
done
}
@@ -35,7 +34,8 @@ build() {
cd "$_builddir"
# fails to build with ccache
export CC="gcc"
- export CFLAGS="$CFLAGS -fno-stack-protector -fno-pie"
+ export CFLAGS="$CFLAGS -fno-stack-protector"
+ export GCC_SPECS="hardenednopie.specs"
./configure \
--build=$CBUILD \
--host=$CHOST \