summaryrefslogtreecommitdiffstats
path: root/main/vde2
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-12-23 09:00:28 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-12-23 15:29:34 +0000
commitddee2f86a48e087867d4a2c12849b2e3baccc238 (patch)
treea5838197618580a8f5d8831feddad284bff03029 /main/vde2
parentc5cfd319b05aeed1e4a299cc134ec5a3628ebafa (diff)
downloadaports-ddee2f86a48e087867d4a2c12849b2e3baccc238.tar.bz2
aports-ddee2f86a48e087867d4a2c12849b2e3baccc238.tar.xz
main/vde2: musl build fix
Diffstat (limited to 'main/vde2')
-rw-r--r--main/vde2/APKBUILD11
-rw-r--r--main/vde2/musl-build-fix.patch15
2 files changed, 25 insertions, 1 deletions
diff --git a/main/vde2/APKBUILD b/main/vde2/APKBUILD
index fe6509124..0c97c4553 100644
--- a/main/vde2/APKBUILD
+++ b/main/vde2/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Michael Zhou <zhoumichaely@gmail.com>
pkgname=vde2
pkgver=2.3.2
-pkgrel=1
+pkgrel=2
pkgdesc="VDE: Virtual Distributed Ethernet. User mode networking for QEMU, UML, etc."
url="http://vde.sf.net"
arch="all"
@@ -11,6 +11,7 @@ install="vde2.pre-install"
makedepends="openssl-dev libpcap-dev python"
subpackages="$pkgname-doc $pkgname-dev $pkgname-libs"
source="http://downloads.sourceforge.net/project/vde/vde2/$pkgver/vde2-$pkgver.tar.gz
+ musl-build-fix.patch
vde2.pre-up
vde2.post-down
"
@@ -19,6 +20,11 @@ _builddir="$srcdir"/$pkgname-$pkgver
prepare() {
cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
update_config_sub || return 1
}
@@ -56,11 +62,14 @@ libs() {
}
md5sums="d3f3e979558e396b8405c4613df9dfa0 vde2-2.3.2.tar.gz
+00289737d06daba802e99981dac4df97 musl-build-fix.patch
e484324d93baf668d7ec756f36ebf389 vde2.pre-up
d9a32a3e77e64a265e00df5ab1081672 vde2.post-down"
sha256sums="22df546a63dac88320d35d61b7833bbbcbef13529ad009c7ce3c5cb32250af93 vde2-2.3.2.tar.gz
+e1c0ba089d2b7f37692fc33871fd46f5597cfcc11602abfc77514244f61acd29 musl-build-fix.patch
fa02d6c8e95b7959527d6ab0f86fa5bd80efae13e477dea081d5f685cbb33197 vde2.pre-up
add7e49a2b48bb113ce06feffd4d9e144ced0c81de21e87395a5f59cbae53f2d vde2.post-down"
sha512sums="b502ceac8eebd30694a25d913c1d321b58ec8ae97dec0b09acc40455f7a97c05040ff395242c144580a9d9d5cb19292055bc94133ea1bde66bfdab40844533a8 vde2-2.3.2.tar.gz
+52d02c3a5a4f5526ed2e653e5720f012501215c0440e26105c585ea0501423da04047f6bad13a71b7378397a9d9274b191007d839876b675e206ed5be0f25372 musl-build-fix.patch
71b29d538bba80b881f239d683215279089c14e8feec05bf27c159ead51094cdfb168281900fa4527f588c624e8f7687df8d3f79377e07d13ad64de613177df3 vde2.pre-up
d1cf18146145dbe608842c694b05d2906e36553b0ba3fa1ec2e53dbf06027b9e4937ea61aee77c1ccbb73b818f19d55787051eb6d5b09a38c7d18a1dad629190 vde2.post-down"
diff --git a/main/vde2/musl-build-fix.patch b/main/vde2/musl-build-fix.patch
new file mode 100644
index 000000000..c03459c6e
--- /dev/null
+++ b/main/vde2/musl-build-fix.patch
@@ -0,0 +1,15 @@
+diff --git a/src/vdetaplib/libvdetap.c b/src/vdetaplib/libvdetap.c
+index 00cd401..c70f290 100644
+--- a/src/vdetaplib/libvdetap.c
++++ b/src/vdetaplib/libvdetap.c
+@@ -121,6 +121,10 @@ int open(const char *path, int flags, ...)
+ return native_open(path, flags, data);
+ }
+
++/* musl apparently defines open64 as a macro */
++#ifdef open64
++#undef open64
++#endif
+ int open64(const char *path, int flags, ...)
+ {
+ va_list ap;