summaryrefslogtreecommitdiffstats
path: root/main/wireshark
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-10-22 12:30:41 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-10-22 12:32:02 +0000
commit1a2066c2337dc8d9f10afb55c4f95f6cbfdca6df (patch)
treebf63373ea55cc393a965b969d9e7c1a8f6dc0286 /main/wireshark
parent0ec596a82ccab369c0baee9eb7e03a5a3cab1343 (diff)
downloadaports-1a2066c2337dc8d9f10afb55c4f95f6cbfdca6df.tar.bz2
aports-1a2066c2337dc8d9f10afb55c4f95f6cbfdca6df.tar.xz
main/wireshark: fix build error caused by symbols clash
Diffstat (limited to 'main/wireshark')
-rw-r--r--main/wireshark/APKBUILD6
-rw-r--r--main/wireshark/wireshark-0013-dirent-symbols-clash.patch58
2 files changed, 63 insertions, 1 deletions
diff --git a/main/wireshark/APKBUILD b/main/wireshark/APKBUILD
index 1d4b2f4a3..a56764176 100644
--- a/main/wireshark/APKBUILD
+++ b/main/wireshark/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=wireshark
pkgver=1.10.2
-pkgrel=0
+pkgrel=1
pkgdesc="network protocol analyzer - GTK version"
url="http://www.wireshark.org"
arch="all"
@@ -14,6 +14,7 @@ makedepends="bison flex perl glib glib-dev pkgconfig libpcap-dev libcap-dev
install=""
subpackages="$pkgname-dev $pkgname-doc $pkgname-common tshark"
source="http://www.wireshark.org/download/src/${pkgname}-${pkgver}.tar.bz2
+ wireshark-0013-dirent-symbols-clash.patch
wireshark.desktop
wireshark.png"
@@ -82,11 +83,14 @@ tshark() {
}
md5sums="cd7fedd0a67df5ad4905fd356efdc1e8 wireshark-1.10.2.tar.bz2
+ba36dc72f90395b6296d4612d3a083da wireshark-0013-dirent-symbols-clash.patch
504ede44c02b2a52f6cbd3bffdf93b8d wireshark.desktop
e771800a8c977fe223583a453bc27397 wireshark.png"
sha256sums="b7a83314424e13639c591de924aa240bc5f3d9cae01dde69bf858fa04b22a33d wireshark-1.10.2.tar.bz2
+73a697282e2c0111c6b6f8f049f8ff6b7582848c6b7eff38cfcf21875e85eacf wireshark-0013-dirent-symbols-clash.patch
10c8b5bdd1d161454c93df166f39b2bae72efe6021beb61d84dd65dc329260fe wireshark.desktop
a9f6d78dd64a87acd1b600222156b9fc26e7ccbbc43fc77c1da138908bdb2d3c wireshark.png"
sha512sums="fd2ad466b122e2044718d8b42d0b323293d2e7fe04af700a1e94d00c720f78ba664e9cdb9a7fb35a13a6f7d99d81e4345482ee8d98b7538972a3f23250a44702 wireshark-1.10.2.tar.bz2
+05e3dc4439e2c1fd32af2592a2983f1b95c289e9dbea51e171200a9da897ea63982951bde2f319c4e309bb804f06ceadc1406c2fae616b9ac80175a95c67e55a wireshark-0013-dirent-symbols-clash.patch
6e1eab7793a97377017be9126b7d25bd9c10d2b0e06be1e83e66ac2ea64dce5c4f8f7783d483921867241d298eb0ac82ff3f9910e90c2065125bff9a3856f52e wireshark.desktop
b421575dbc3d496a8c3d5485929c161c06d3403bff2fef4f1db07b1db729ca173c6e89cb648d127c02800359975d5e0880c344dc58fa9d24dde570a862bdd7d4 wireshark.png"
diff --git a/main/wireshark/wireshark-0013-dirent-symbols-clash.patch b/main/wireshark/wireshark-0013-dirent-symbols-clash.patch
new file mode 100644
index 000000000..3bef19b9e
--- /dev/null
+++ b/main/wireshark/wireshark-0013-dirent-symbols-clash.patch
@@ -0,0 +1,58 @@
+diff --git a/epan/dissectors/packet-gluster.h b/epan/dissectors/packet-gluster.h
+index f023f62..d0d4651 100644
+--- a/epan/dissectors/packet-gluster.h
++++ b/epan/dissectors/packet-gluster.h
+@@ -356,15 +356,15 @@ enum gf_fop_procnum {
+
+ /* dir-entry types from libglusterfs/src/compat.h */
+ enum gluster_entry_types {
+- DT_UNKNOWN = 0,
+- DT_FIFO = 1,
+- DT_CHR = 2,
+- DT_DIR = 4,
+- DT_BLK = 6,
+- DT_REG = 8,
+- DT_LNK = 10,
+- DT_SOCK = 12,
+- DT_WHT = 14
++ GLUSTER_DT_UNKNOWN = 0,
++ GLUSTER_DT_FIFO = 1,
++ GLUSTER_DT_CHR = 2,
++ GLUSTER_DT_DIR = 4,
++ GLUSTER_DT_BLK = 6,
++ GLUSTER_DT_REG = 8,
++ GLUSTER_DT_LNK = 10,
++ GLUSTER_DT_SOCK = 12,
++ GLUSTER_DT_WHT = 14
+ };
+
+
+diff --git a/epan/dissectors/packet-glusterfs.c b/epan/dissectors/packet-glusterfs.c
+index 5f18258..299e783 100644
+--- a/epan/dissectors/packet-glusterfs.c
++++ b/epan/dissectors/packet-glusterfs.c
+@@ -2002,15 +2002,15 @@ static value_string_ext glusterfs3_1_fop_proc_vals_ext = VALUE_STRING_EXT_INIT(g
+
+ /* dir-entry types */
+ static const value_string glusterfs_entry_type_names[] = {
+- { DT_UNKNOWN, "DT_UNKNOWN" },
+- { DT_FIFO, "DT_FIFO" },
+- { DT_CHR, "DT_CHR" },
+- { DT_DIR, "DT_DIR" },
+- { DT_BLK, "DT_BLK" },
+- { DT_REG, "DT_REG" },
+- { DT_LNK, "DT_LNK" },
+- { DT_SOCK, "DT_SOCK" },
+- { DT_WHT, "DT_WHT" },
++ { GLUSTER_DT_UNKNOWN, "DT_UNKNOWN" },
++ { GLUSTER_DT_FIFO, "DT_FIFO" },
++ { GLUSTER_DT_CHR, "DT_CHR" },
++ { GLUSTER_DT_DIR, "DT_DIR" },
++ { GLUSTER_DT_BLK, "DT_BLK" },
++ { GLUSTER_DT_REG, "DT_REG" },
++ { GLUSTER_DT_LNK, "DT_LNK" },
++ { GLUSTER_DT_SOCK, "DT_SOCK" },
++ { GLUSTER_DT_WHT, "DT_WHT" },
+ { 0, NULL }
+ };
+ static value_string_ext glusterfs_entry_type_names_ext = VALUE_STRING_EXT_INIT(glusterfs_entry_type_names);