summaryrefslogtreecommitdiffstats
path: root/main/xbacklight
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2013-09-29 08:45:29 +0000
committerTimo Teräs <timo.teras@iki.fi>2013-09-29 08:47:22 +0000
commit8f6f2e3166478b14b208ecfb94ddf01d69dd7bdc (patch)
treee1bdd0bbb491926306c1e43e72dabbbe235f4b62 /main/xbacklight
parent832a032dd3794c5cc3e67f4ee580e171996e8e29 (diff)
downloadaports-8f6f2e3166478b14b208ecfb94ddf01d69dd7bdc.tar.bz2
aports-8f6f2e3166478b14b208ecfb94ddf01d69dd7bdc.tar.xz
main/[various]: update config.sub (and remove charset.alias)
for musl build. the changes are automatically done based on previous build log errors, so this does not guarantee successful build, but is a required.
Diffstat (limited to 'main/xbacklight')
-rw-r--r--main/xbacklight/APKBUILD11
1 files changed, 9 insertions, 2 deletions
diff --git a/main/xbacklight/APKBUILD b/main/xbacklight/APKBUILD
index 42aa3d1f3..9f33d9af2 100644
--- a/main/xbacklight/APKBUILD
+++ b/main/xbacklight/APKBUILD
@@ -11,8 +11,15 @@ depends=
makedepends="pkgconfig libx11-dev libxrandr-dev"
source="http://xorg.freedesktop.org/releases/individual/app/$pkgname-$pkgver.tar.bz2"
+_builddir="$srcdir/$pkgname-$pkgver"
+
+prepare() {
+ cd "$_builddir"
+ update_config_sub || return 1
+}
+
build() {
- cd "$srcdir"/$pkgname-$pkgver
+ cd "$_builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -23,7 +30,7 @@ build() {
}
package() {
- cd "$srcdir"/$pkgname-$pkgver
+ cd "$_builddir"
make DESTDIR="$pkgdir" install || return 1
}
md5sums="51b4a1c0ae2b3bd77417306fd78a3e94 xbacklight-1.1.tar.bz2"