summaryrefslogtreecommitdiffstats
path: root/main/xen
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2011-06-10 22:24:44 -0500
committerWilliam Pitcock <nenolod@dereferenced.org>2011-06-10 22:24:44 -0500
commit44ceef1ee856565cb17e38fe6471dad105bf7f9e (patch)
tree3b3d593462585e0160b56856dd0fa3262c53b567 /main/xen
parent3e90d206c5c7ddacb00d9947cb7d495a2e999bcc (diff)
downloadaports-44ceef1ee856565cb17e38fe6471dad105bf7f9e.tar.bz2
aports-44ceef1ee856565cb17e38fe6471dad105bf7f9e.tar.xz
main/xen: upgrade to 4.1.0
Diffstat (limited to 'main/xen')
-rw-r--r--main/xen/APKBUILD29
-rw-r--r--main/xen/xen-disable-fsback.patch10
-rw-r--r--main/xen/xen-disable-werror.patch33
-rw-r--r--main/xen/xen-dont-use-lib64.patch4
4 files changed, 21 insertions, 55 deletions
diff --git a/main/xen/APKBUILD b/main/xen/APKBUILD
index ca734eb16..07523eacf 100644
--- a/main/xen/APKBUILD
+++ b/main/xen/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: William Pitcock <nenolod@dereferenced.org>
# Maintainer: William Pitcock <nenolod@dereferenced.org>
pkgname=xen
-pkgver=4.0.1
-pkgrel=3
+pkgver=4.1.0
+pkgrel=0
pkgdesc="Xen hypervisor"
url="http://www.xen.org/"
license="GPL"
@@ -14,8 +14,6 @@ source="http://bits.xensource.com/oss-xen/release/$pkgver/$pkgname-$pkgver.tar.g
xen-blktap-uclibc.patch
xen-blktap2-uclibc.patch
xen-disable-firmware.patch
- xen-disable-fsback.patch
- xen-disable-werror.patch
xen-dont-use-lib64.patch
xen-sed-is-broken-hack.patch
blktap-write.patch
@@ -28,6 +26,7 @@ _builddir="$srcdir"/$pkgname-$pkgver
prepare() {
cd "$_builddir"
+ msg "Patching sources..."
for i in $source; do
case $i in
*.patch)
@@ -36,8 +35,11 @@ prepare() {
;;
esac
done
+ msg "Sources have been patched successfully."
+
# remove all -Werror
- find -name '*.mk' -o -name 'Make*' | xargs sed 's/-Werror//g'
+ msg "Eradicating -Werror..."
+ find -name '*.mk' -o -name 'Make*' | xargs sed -i -e 's/-Werror//g'
}
build() {
@@ -51,8 +53,17 @@ build() {
# If we provide no parameters it tries to build a kernel image. We
# definitely don't want that.
+ msg "Running preflight check..."
(cd tools/check; ./chk build) || return 1
- make -j1 xen tools stubdom || return 1
+
+ msg "Building hypervisor..."
+ make -j1 xen || return 1
+
+ msg "Building tools..."
+ make -j1 tools || return 1
+
+ msg "Building stub domains..."
+ make -j1 stubdom || return 1
}
package() {
@@ -70,13 +81,11 @@ package() {
install -m755 -D "$srcdir"/xendomains.initd "$pkgdir"/etc/init.d/xendomains
}
-md5sums="d197afad975ab2396a67323d57388c27 xen-4.0.1.tar.gz
+md5sums="db3e1542b7719f375593b2b32b01a177 xen-4.1.0.tar.gz
edb5c3e7fba8214702fac709f0e53124 xen-blktap-uclibc.patch
1f7f847ae0baa915c7b52d0ed5869fe6 xen-blktap2-uclibc.patch
a569f16a7e3c832ba3fab6154f657244 xen-disable-firmware.patch
-03d1fff892e627b812bba4e6c56d696a xen-disable-fsback.patch
-949d0d3bc1e8f300a849279b60760c6a xen-disable-werror.patch
-b6599060e22b61dabee0fe460b4a0c9d xen-dont-use-lib64.patch
+20ce621f3a2fc8ae78e74b9b72da775c xen-dont-use-lib64.patch
0cec6a97de9e4bc178f3e71190495cc3 xen-sed-is-broken-hack.patch
56af00443c8d40944082e26304452a5e blktap-write.patch
1d81b04f8c8b919879a73f0e3d2fe80f xend.initd
diff --git a/main/xen/xen-disable-fsback.patch b/main/xen/xen-disable-fsback.patch
deleted file mode 100644
index d0ae91b12..000000000
--- a/main/xen/xen-disable-fsback.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- xen-4.0.1/tools/Makefile
-+++ xen-4.0.1.mod/tools/Makefile
-@@ -29,7 +28,6 @@
- SUBDIRS-$(CONFIG_NetBSD) += xenbackendd
- SUBDIRS-y += libfsimage
- SUBDIRS-$(LIBXENAPI_BINDINGS) += libxen
--SUBDIRS-$(CONFIG_Linux) += fs-back
- SUBDIRS-$(CONFIG_NetBSD) += fs-back
- SUBDIRS-$(CONFIG_IOEMU) += ioemu-dir
- SUBDIRS-y += xenpmd
diff --git a/main/xen/xen-disable-werror.patch b/main/xen/xen-disable-werror.patch
deleted file mode 100644
index c2c551245..000000000
--- a/main/xen/xen-disable-werror.patch
+++ /dev/null
@@ -1,33 +0,0 @@
---- xen-4.0.1/Config.mk
-+++ xen-4.0.1.mod/Config.mk
-@@ -14,7 +14,7 @@
-
- # Tools to run on system hosting the build
- HOSTCC = gcc
--HOSTCFLAGS = -Wall -Werror -Wstrict-prototypes -O2 -fomit-frame-pointer
-+HOSTCFLAGS = -Wall -Wstrict-prototypes -O2 -fomit-frame-pointer
- HOSTCFLAGS += -fno-strict-aliasing
-
- DISTDIR ?= $(XEN_ROOT)/dist
---- xen-4.0.1/extras/mini-os/minios.mk
-+++ xen-4.0.1.mod/extras/mini-os/minios.mk
-@@ -6,7 +6,7 @@
-
- # Define some default flags.
- # NB. '-Wcast-qual' is nasty, so I omitted it.
--DEF_CFLAGS += -fno-builtin -Wall -Werror -Wredundant-decls -Wno-format -Wno-redundant-decls
-+DEF_CFLAGS += -fno-builtin -Wall -Wredundant-decls -Wno-format -Wno-redundant-decls
- DEF_CFLAGS += $(call cc-option,$(CC),-fno-stack-protector,)
- DEF_CFLAGS += $(call cc-option,$(CC),-fgnu89-inline)
- DEF_CFLAGS += -Wstrict-prototypes -Wnested-externs -Wpointer-arith -Winline
---- xen-4.0.1/tools/libxc/Makefile
-+++ xen-4.0.1.mod/tools/libxc/Makefile
-@@ -57,7 +57,7 @@
-
- -include $(XEN_TARGET_ARCH)/Makefile
-
--CFLAGS += -Werror -Wmissing-prototypes
-+CFLAGS += -Wmissing-prototypes
- CFLAGS += $(INCLUDES) -I. -I../xenstore -I../include
-
- # Needed for posix_fadvise64() in xc_linux.c
diff --git a/main/xen/xen-dont-use-lib64.patch b/main/xen/xen-dont-use-lib64.patch
index a22f13902..b14ff1016 100644
--- a/main/xen/xen-dont-use-lib64.patch
+++ b/main/xen/xen-dont-use-lib64.patch
@@ -4,8 +4,8 @@
INCLUDEDIR = $(PREFIX)/include
LIBLEAFDIR = lib
LIBLEAFDIR_x86_32 = lib
--LIBLEAFDIR_x86_64 = lib64
-+LIBLEAFDIR_x86_64 = lib
+-LIBLEAFDIR_x86_64 ?= lib64
++LIBLEAFDIR_x86_64 ?= lib
LIBDIR = $(PREFIX)/$(LIBLEAFDIR)
LIBDIR_x86_32 = $(PREFIX)/$(LIBLEAFDIR_x86_32)
LIBDIR_x86_64 = $(PREFIX)/$(LIBLEAFDIR_x86_64)