summaryrefslogtreecommitdiffstats
path: root/main
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-06-22 07:44:20 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-06-22 13:18:41 +0000
commit3570515bc4aba95787c16968bfdb3aae53090225 (patch)
tree4cf288eb5689bec96638c09479b22cc3f3581901 /main
parente5755547ac6c582d6a663ce081c064e97beb55a2 (diff)
downloadaports-3570515bc4aba95787c16968bfdb3aae53090225.tar.bz2
aports-3570515bc4aba95787c16968bfdb3aae53090225.tar.xz
main/ffmpeg: upgrade to 0.8 and rebuild dependants
Diffstat (limited to 'main')
-rw-r--r--main/audacious-plugins/APKBUILD8
-rw-r--r--main/audacious-plugins/audacious-plugins-ffmpeg-0.8.patch20
-rw-r--r--main/ffmpeg/APKBUILD11
-rw-r--r--main/sox/APKBUILD21
-rw-r--r--main/sox/sox-ffmpeg-0.8.patch38
-rw-r--r--main/vlc/APKBUILD2
6 files changed, 83 insertions, 17 deletions
diff --git a/main/audacious-plugins/APKBUILD b/main/audacious-plugins/APKBUILD
index b44309f12..34a306397 100644
--- a/main/audacious-plugins/APKBUILD
+++ b/main/audacious-plugins/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: William Pitcock <nenolod@dereferenced.org>
pkgname=audacious-plugins
pkgver=2.5.1
-pkgrel=1
+pkgrel=2
pkgdesc="playlist-oriented media player with multiple interfaces (plugins)"
url="http://audacious-media-player.org/"
arch="all"
@@ -46,7 +46,8 @@ makedepends="libmowgli-dev
install=
subpackages=
source="http://distfiles.atheme.org/$pkgname-$pkgver.tgz
- audacious-plugins-2.5.1-vorbis.patch"
+ audacious-plugins-2.5.1-vorbis.patch
+ audacious-plugins-ffmpeg-0.8.patch"
_builddir="$srcdir"/$pkgname-$pkgver
@@ -86,4 +87,5 @@ package() {
}
md5sums="809d4429d3fbe51f9c19479c3138e6d7 audacious-plugins-2.5.1.tgz
-891db73ec2d00343d06f0a64a57456ac audacious-plugins-2.5.1-vorbis.patch"
+891db73ec2d00343d06f0a64a57456ac audacious-plugins-2.5.1-vorbis.patch
+174fc707d49d5973fc16a3f935f0c49d audacious-plugins-ffmpeg-0.8.patch"
diff --git a/main/audacious-plugins/audacious-plugins-ffmpeg-0.8.patch b/main/audacious-plugins/audacious-plugins-ffmpeg-0.8.patch
new file mode 100644
index 000000000..a7554458e
--- /dev/null
+++ b/main/audacious-plugins/audacious-plugins-ffmpeg-0.8.patch
@@ -0,0 +1,20 @@
+--- ./src/ffaudio/ffaudio-core.c.orig
++++ ./src/ffaudio/ffaudio-core.c
+@@ -341,7 +341,7 @@
+ {
+ s = ic->streams[i];
+ c = s->codec;
+- if (c->codec_type == CODEC_TYPE_AUDIO)
++ if (c->codec_type == AVMEDIA_TYPE_AUDIO)
+ {
+ av_find_stream_info(ic);
+ codec = avcodec_find_decoder(c->codec_id);
+@@ -415,7 +415,7 @@
+ {
+ s = ic->streams[i];
+ c = s->codec;
+- if (c->codec_type == CODEC_TYPE_AUDIO)
++ if (c->codec_type == AVMEDIA_TYPE_AUDIO)
+ {
+ av_find_stream_info(ic);
+ codec = avcodec_find_decoder(c->codec_id);
diff --git a/main/ffmpeg/APKBUILD b/main/ffmpeg/APKBUILD
index 879919b55..5e5cb410f 100644
--- a/main/ffmpeg/APKBUILD
+++ b/main/ffmpeg/APKBUILD
@@ -1,18 +1,17 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=ffmpeg
-pkgver=0.6.3
-pkgrel=2
+pkgver=0.8
+pkgrel=0
pkgdesc="Complete and free Internet live audio and video broadcasting solution for Linux/Unix"
url="http://ffmpeg.org/"
arch="all"
license="GPL"
subpackages="$pkgname-dev $pkgname-doc"
-makedepends="lame-dev libvorbis-dev faad2-dev faac-dev xvidcore-dev zlib-dev
+makedepends="lame-dev libvorbis-dev faac-dev xvidcore-dev zlib-dev
imlib2-dev x264-dev libtheora-dev coreutils bzip2-dev perl libvpx-dev
libvpx-dev sdl-dev"
depends=
source="http://ffmpeg.org/releases/ffmpeg-$pkgver.tar.bz2
- pic.patch
configure-dlvsym.patch"
_builddir="$srcdir"/$pkgname-$pkgver
@@ -34,7 +33,6 @@ build() {
--enable-libmp3lame \
--enable-libvorbis \
--enable-libfaac \
- --enable-libfaad \
--enable-libvpx \
--enable-libxvid \
--enable-libx264 \
@@ -61,6 +59,5 @@ package() {
install -D -m755 tools/qt-faststart "$pkgdir/usr/bin/qt-faststart" || return 1
# strip --strip-debug "$pkgdir"/usr/lib/*.a || return 1
}
-md5sums="cdf4ad9b2a4d195b5ca874494bc7b0b0 ffmpeg-0.6.3.tar.bz2
-d4870ae7350caed041d2b39e406a173b pic.patch
+md5sums="7e9b8c8a6952de0c477027e48249f3ed ffmpeg-0.8.tar.bz2
2cdc11a99bf97c63c7cca27b073cb47c configure-dlvsym.patch"
diff --git a/main/sox/APKBUILD b/main/sox/APKBUILD
index 771d5d5f6..f6c3e8082 100644
--- a/main/sox/APKBUILD
+++ b/main/sox/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=sox
pkgver=14.3.2
-pkgrel=0
+pkgrel=1
pkgdesc="The Swiss Army knife of sound processing tools"
url="http://sox.sourceforge.net/"
arch="all"
@@ -12,11 +12,17 @@ makedepends="ffmpeg-dev libao-dev libvorbis-dev libogg-dev lame-dev
depends=
subpackages="$pkgname-dev $pkgname-doc"
source="http://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.gz
- sox-uclibc.patch"
+ sox-uclibc.patch
+ sox-ffmpeg-0.8.patch
+ "
prepare() {
cd "$srcdir"/$pkgname-$pkgver
- patch -p1 -i ../sox-uclibc.patch
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
}
build() {
@@ -24,7 +30,6 @@ build() {
./configure --prefix=/usr \
--sysconfdir=/etc \
--with-dyn-default \
- --disable-nls \
--with-distro="Alpine Linux" || return 1
make || return 1
}
@@ -33,7 +38,11 @@ package() {
cd "$srcdir"/$pkgname-$pkgver
make DESTDIR="$pkgdir" install || return 1
ln -sf play "$pkgdir"/usr/bin/rec || return 1
- ln -sf ../man1/sox.1.gz "$pkgdir"/usr/share/man/man7/soxeffect.7
+ ln -sf ../man1/sox.1.gz "$pkgdir"/usr/share/man/man7/soxeffect.7 || return 1
+ rm "$pkgdir"/usr/lib/*.la \
+ "$pkgdir"/usr/lib/sox/*.a \
+ "$pkgdir"/usr/lib/sox/*.la \
}
md5sums="e9d35cf3b0f8878596e0b7c49f9e8302 sox-14.3.2.tar.gz
-d8267f718ba6b4fb2f48c5104af31364 sox-uclibc.patch"
+d8267f718ba6b4fb2f48c5104af31364 sox-uclibc.patch
+f99f0c37c31dd103921292a1d89ad266 sox-ffmpeg-0.8.patch"
diff --git a/main/sox/sox-ffmpeg-0.8.patch b/main/sox/sox-ffmpeg-0.8.patch
new file mode 100644
index 000000000..74b8cacdf
--- /dev/null
+++ b/main/sox/sox-ffmpeg-0.8.patch
@@ -0,0 +1,38 @@
+--- ./src/ffmpeg.c.orig
++++ ./src/ffmpeg.c
+@@ -91,7 +91,7 @@
+
+ if (!codec || avcodec_open(enc, codec) < 0)
+ return -1;
+- if (enc->codec_type != CODEC_TYPE_AUDIO) {
++ if (enc->codec_type != AVMEDIA_TYPE_AUDIO) {
+ lsx_fail("ffmpeg CODEC %x is not an audio CODEC", enc->codec_type);
+ return -1;
+ }
+@@ -182,7 +182,7 @@
+ /* Find audio stream (FIXME: allow different stream to be selected) */
+ for (i = 0; (unsigned)i < ffmpeg->ctxt->nb_streams; i++) {
+ AVCodecContext *enc = ffmpeg->ctxt->streams[i]->codec;
+- if (enc->codec_type == CODEC_TYPE_AUDIO && ffmpeg->audio_index < 0) {
++ if (enc->codec_type == AVMEDIA_TYPE_AUDIO && ffmpeg->audio_index < 0) {
+ ffmpeg->audio_index = i;
+ break;
+ }
+@@ -273,7 +273,7 @@
+
+ c = st->codec;
+ c->codec_id = codec_id;
+- c->codec_type = CODEC_TYPE_AUDIO;
++ c->codec_type = AVMEDIA_TYPE_AUDIO;
+
+ /* put sample parameters */
+ c->bit_rate = 256000; /* FIXME: allow specification */
+@@ -423,7 +423,7 @@
+ av_init_packet(&pkt);
+ pkt.size = avcodec_encode_audio(c, ffmpeg->audio_buf_aligned, AVCODEC_MAX_AUDIO_FRAME_SIZE, ffmpeg->samples);
+ pkt.pts = av_rescale_q(c->coded_frame->pts, c->time_base, ffmpeg->audio_st->time_base);
+- pkt.flags |= PKT_FLAG_KEY;
++ pkt.flags |= AV_PKT_FLAG_KEY;
+ pkt.stream_index = ffmpeg->audio_st->index;
+ pkt.data = ffmpeg->audio_buf_aligned;
+
diff --git a/main/vlc/APKBUILD b/main/vlc/APKBUILD
index d0f12a1da..fb8c9f1d8 100644
--- a/main/vlc/APKBUILD
+++ b/main/vlc/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=vlc
pkgver=1.1.10
-pkgrel=1
+pkgrel=2
pkgdesc="A multi-platform MPEG, VCD/DVD, and DivX player"
url="http://www.videolan.org/vlc/"
arch="all"