summaryrefslogtreecommitdiffstats
path: root/testing/abook/APKBUILD
diff options
context:
space:
mode:
authorBartłomiej Piotrowski <b@bpiotrowski.pl>2012-07-13 10:02:51 +0200
committerBartłomiej Piotrowski <b@bpiotrowski.pl>2012-07-13 10:02:51 +0200
commita191920d809ddb58f3611e53f01d28b2b83c7c7d (patch)
tree164aff5c721a1d60f47030b787f481453563683d /testing/abook/APKBUILD
parentca281c03fb074164640c48cd37f43e3e07681b75 (diff)
downloadaports-a191920d809ddb58f3611e53f01d28b2b83c7c7d.tar.bz2
aports-a191920d809ddb58f3611e53f01d28b2b83c7c7d.tar.xz
testing/abook: new aport
Diffstat (limited to 'testing/abook/APKBUILD')
-rw-r--r--testing/abook/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/testing/abook/APKBUILD b/testing/abook/APKBUILD
new file mode 100644
index 000000000..54f0256c1
--- /dev/null
+++ b/testing/abook/APKBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Bartłomiej Piotrowski <nospam@bpiotrowski.pl>
+
+pkgname=abook
+pkgver=0.6.0_pre2
+_ver=0.6.0pre2
+pkgrel=0
+pkgdesc='Text-based addressbook designed for use with Mutt'
+url='http://abook.sourceforge.net/'
+license='GPL2'
+arch='all'
+makedepends='libiconv-dev ncurses-dev readline-dev'
+subpackages="$pkgname-doc"
+source="http://$pkgname.sourceforge.net/devel/$pkgname-${_ver}.tar.gz
+ vcard-compat.patch"
+
+prepare() {
+ cd "$srcdir/$pkgname-$_ver"
+ patch -Np1 -i "$srcdir"/vcard-compat.patch
+}
+
+build() {
+ cd "$srcdir/$pkgname-$_ver"
+ ./configure --prefix=/usr --mandir=/usr/share/man
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$_ver"
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="1e4a7210b3507db7b3d47ee7a2457934 abook-0.6.0pre2.tar.gz
+c7c4972eab913483198d86697ecbbaa1 vcard-compat.patch"