summaryrefslogtreecommitdiffstats
path: root/testing/dhex/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-02-23 12:33:19 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-02-23 12:33:19 +0000
commitc0515f500bcc2309cdc8a2c65f157c45fdba57c3 (patch)
tree519064503d426fa9d742a479b11dc09c0236d6ae /testing/dhex/APKBUILD
parente6ac7b39583124cfbc1de23050ce8325e177c9e9 (diff)
downloadaports-c0515f500bcc2309cdc8a2c65f157c45fdba57c3.tar.bz2
aports-c0515f500bcc2309cdc8a2c65f157c45fdba57c3.tar.xz
testing/dhex: new aport
Ncurses hex editor http://www.dettus.net/dhex/
Diffstat (limited to 'testing/dhex/APKBUILD')
-rw-r--r--testing/dhex/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/dhex/APKBUILD b/testing/dhex/APKBUILD
new file mode 100644
index 000000000..d205c4784
--- /dev/null
+++ b/testing/dhex/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=dhex
+pkgver=0.66
+pkgrel=0
+pkgdesc="Ncurses hex editor"
+url="http://www.dettus.net/dhex/"
+arch="all"
+license="GPL"
+depends=""
+makedepends="ncurses-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://www.dettus.net/dhex/dhex_0.66.tar.gz
+ makefile.patch"
+
+_builddir="$srcdir"/dhex_$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make
+}
+
+package() {
+ cd "$_builddir"
+ make install DESTDIR="$pkgdir" \
+ mandir=/usr/share/man \
+ prefix=/usr/bin
+}
+
+md5sums="304a91cfd9481b2ddf418f3a943190e1 dhex_0.66.tar.gz
+de16e09d3b416650d84ef39235cd2917 makefile.patch"