summaryrefslogtreecommitdiffstats
path: root/testing/e_dbus
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-05-25 16:07:44 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-05-25 16:09:12 +0000
commit97fafd794f6f4b4574408e5cffa74d23c4deed72 (patch)
tree00b7074397db6cb76e0128fa99796da5ee74812b /testing/e_dbus
parent9542db515b80865c7f3b474ed4c236ea513c2711 (diff)
downloadaports-97fafd794f6f4b4574408e5cffa74d23c4deed72.tar.bz2
aports-97fafd794f6f4b4574408e5cffa74d23c4deed72.tar.xz
testing/e_dbus: new aport
Enlightenment's (Ecore) integration to DBus http://trac.enlightenment.org/e/wiki/E_Dbus
Diffstat (limited to 'testing/e_dbus')
-rw-r--r--testing/e_dbus/APKBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/testing/e_dbus/APKBUILD b/testing/e_dbus/APKBUILD
new file mode 100644
index 000000000..8cde465ec
--- /dev/null
+++ b/testing/e_dbus/APKBUILD
@@ -0,0 +1,44 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=e_dbus
+pkgver=1.0.0
+pkgrel=0
+pkgdesc="Enlightenment's (Ecore) integration to DBus"
+url="http://trac.enlightenment.org/e/wiki/E_Dbus"
+arch="all"
+license="BSD"
+depends=
+depends_dev="dbus-dev eina-dev ecore-dev"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev"
+source="http://download.enlightenment.org/releases/e_dbus-$pkgver.tar.gz"
+
+_builddir="$srcdir"/e_dbus-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+md5sums="4a3031a41e7e33f843cf104bf84cd4ee e_dbus-1.0.0.tar.gz"