summaryrefslogtreecommitdiffstats
path: root/testing/fluidsynth
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-02-04 08:13:52 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-02-04 08:13:52 +0000
commit4f6cfa80647332fa0223bddcd787a8d9ff7ae127 (patch)
tree7fc6db59fb07aee6e4be9ef379f6699b925a500f /testing/fluidsynth
parent3e0f99cf3548084c5297978890c35bee934b7de0 (diff)
downloadaports-4f6cfa80647332fa0223bddcd787a8d9ff7ae127.tar.bz2
aports-4f6cfa80647332fa0223bddcd787a8d9ff7ae127.tar.xz
testing/fluidsynth: new aport
Real-time software synthesizer http://www.fluidsynth.org/
Diffstat (limited to 'testing/fluidsynth')
-rw-r--r--testing/fluidsynth/APKBUILD51
1 files changed, 51 insertions, 0 deletions
diff --git a/testing/fluidsynth/APKBUILD b/testing/fluidsynth/APKBUILD
new file mode 100644
index 000000000..e44132419
--- /dev/null
+++ b/testing/fluidsynth/APKBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=fluidsynth
+pkgver=1.1.6
+pkgrel=0
+pkgdesc="Real-time software synthesizer"
+url="http://www.fluidsynth.org/"
+arch="all"
+license="LGPLv2+"
+depends=""
+depends_dev=""
+makedepends="$depends_dev alsa-lib-dev cmake dbus-dev ladspa-dev ncurses-dev
+ jack-dev glib-dev libsndfile-dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
+source="http://downloads.sourceforge.net/fluidsynth/fluidsynth-$pkgver.tar.bz2"
+
+_builddir="$srcdir"/fluidsynth-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+ update_config_sub || return 1
+}
+
+build() {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --localstatedir=/var \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ rm -f "$pkgdir"/usr/lib/*.la
+}
+
+md5sums="f6e696690e989098f70641364fdffad7 fluidsynth-1.1.6.tar.bz2"
+sha256sums="d28b47dfbf7f8e426902ae7fa2981d821fbf84f41da9e1b85be933d2d748f601 fluidsynth-1.1.6.tar.bz2"
+sha512sums="0ead8bf86c0edf6d98044eb16b52b85fac8bc3bdeb9c1478d0bceb4f5b38ca28218fcf2cd18cdd5608190dc70b7c39bde681765d01787bc84bc97c6ab3bbf946 fluidsynth-1.1.6.tar.bz2"